summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/vecgeom/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/vecgeom/package.py')
-rw-r--r--var/spack/repos/builtin/packages/vecgeom/package.py58
1 files changed, 28 insertions, 30 deletions
diff --git a/var/spack/repos/builtin/packages/vecgeom/package.py b/var/spack/repos/builtin/packages/vecgeom/package.py
index 05c1519220..c4ba864f8b 100644
--- a/var/spack/repos/builtin/packages/vecgeom/package.py
+++ b/var/spack/repos/builtin/packages/vecgeom/package.py
@@ -1,27 +1,8 @@
-##############################################################################
-# Copyright (c) 2013-2017, Lawrence Livermore National Security, LLC.
-# Produced at the Lawrence Livermore National Laboratory.
+# Copyright 2013-2018 Lawrence Livermore National Security, LLC and other
+# Spack Project Developers. See the top-level COPYRIGHT file for details.
#
-# This file is part of Spack.
-# Created by Todd Gamblin, tgamblin@llnl.gov, All rights reserved.
-# LLNL-CODE-647188
-#
-# For details, see https://github.com/spack/spack
-# Please also see the NOTICE and LICENSE files for our notice and the LGPL.
-#
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU Lesser General Public License (as
-# published by the Free Software Foundation) version 2.1, February 1999.
-#
-# This program is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the IMPLIED WARRANTY OF
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the terms and
-# conditions of the GNU Lesser General Public License for more details.
-#
-# You should have received a copy of the GNU Lesser General Public
-# License along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
-##############################################################################
+# SPDX-License-Identifier: (Apache-2.0 OR MIT)
+
from spack import *
import platform
@@ -32,9 +13,22 @@ class Vecgeom(CMakePackage):
(toolkits)."""
homepage = "https://gitlab.cern.ch/VecGeom/VecGeom"
-
- version('0.3.rc', git='https://gitlab.cern.ch/VecGeom/VecGeom.git',
- tag='v0.3.rc')
+ url = "https://gitlab.cern.ch/api/v4/projects/VecGeom%2FVecGeom/repository/archive.tar.gz?sha=v0.3.rc"
+
+ version('01.00.00', git='https://gitlab.cern.ch/VecGeom/VecGeom.git', tag='v01.00.00')
+ version('00.05.00', git='https://gitlab.cern.ch/VecGeom/VecGeom.git', tag='v00.05.00', preferred=True)
+ version('0.3.rc', 'c1f5d620f655f3c0610a44e7735203b5')
+
+ variant('cxxstd',
+ default='17',
+ values=('14', '17'),
+ multi=False,
+ description='Use the specified C++ standard when building.')
+ variant('vector',
+ default='native',
+ values=('sse3', 'sse4.2', 'native'),
+ multi=False,
+ description='Specify the instruction set for vectorization.')
depends_on('cmake@3.5:', type='build')
@@ -43,12 +37,16 @@ class Vecgeom(CMakePackage):
'-DBACKEND=Scalar',
'-DGEANT4=OFF',
'-DUSOLIDS=ON',
- '-DUSOLIDS_VECGEOM=ON'
- ]
-
+ '-DUSOLIDS_VECGEOM=ON',
+ '-DROOT=OFF',
+ '-DNO_SPECIALIZATION=ON',
+ '-DCMAKE_VERBOSE_MAKEFILE=TRUE']
+ options.append('-DCMAKE_CXX_STANDARD={0}'.
+ format(self.spec.variants['cxxstd'].value))
arch = platform.machine()
if arch == 'x86_64':
- options.append('-DVECGEOM_VECTOR=sse4.2')
+ options.append('-DVECGEOM_VECTOR={0}'.
+ format(self.spec.variants['vector'].value))
else:
options.append('-DVECGEOM_VECTOR=' + arch)
return options