summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/veclibfort/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/veclibfort/package.py')
-rw-r--r--var/spack/repos/builtin/packages/veclibfort/package.py32
1 files changed, 7 insertions, 25 deletions
diff --git a/var/spack/repos/builtin/packages/veclibfort/package.py b/var/spack/repos/builtin/packages/veclibfort/package.py
index e57384fd2c..988e59adf3 100644
--- a/var/spack/repos/builtin/packages/veclibfort/package.py
+++ b/var/spack/repos/builtin/packages/veclibfort/package.py
@@ -1,27 +1,8 @@
-##############################################################################
-# Copyright (c) 2013-2017, Lawrence Livermore National Security, LLC.
-# Produced at the Lawrence Livermore National Laboratory.
+# Copyright 2013-2018 Lawrence Livermore National Security, LLC and other
+# Spack Project Developers. See the top-level COPYRIGHT file for details.
#
-# This file is part of Spack.
-# Created by Todd Gamblin, tgamblin@llnl.gov, All rights reserved.
-# LLNL-CODE-647188
-#
-# For details, see https://github.com/spack/spack
-# Please also see the NOTICE and LICENSE files for our notice and the LGPL.
-#
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU Lesser General Public License (as
-# published by the Free Software Foundation) version 2.1, February 1999.
-#
-# This program is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the IMPLIED WARRANTY OF
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the terms and
-# conditions of the GNU Lesser General Public License for more details.
-#
-# You should have received a copy of the GNU Lesser General Public
-# License along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
-##############################################################################
+# SPDX-License-Identifier: (Apache-2.0 OR MIT)
+
from spack import *
import sys
@@ -33,9 +14,10 @@ class Veclibfort(Package):
homepage = "https://github.com/mcg1969/vecLibFort"
url = "https://github.com/mcg1969/vecLibFort/archive/0.4.2.tar.gz"
+ git = "https://github.com/mcg1969/vecLibFort.git"
+ version('develop', branch='master')
version('0.4.2', '83395ffcbe8a2122c3f726a5c3a7cf93')
- version('develop', git='https://github.com/mcg1969/vecLibFort.git')
variant('shared', default=True,
description="Build shared libraries as well as static libs.")
@@ -48,7 +30,7 @@ class Veclibfort(Package):
def libs(self):
shared = True if '+shared' in self.spec else False
return find_libraries(
- 'libvecLibFort', root=self.prefix, shared=shared, recurse=True
+ 'libvecLibFort', root=self.prefix, shared=shared, recursive=True
)
def install(self, spec, prefix):