summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/vim/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/vim/package.py')
-rw-r--r--var/spack/repos/builtin/packages/vim/package.py50
1 files changed, 24 insertions, 26 deletions
diff --git a/var/spack/repos/builtin/packages/vim/package.py b/var/spack/repos/builtin/packages/vim/package.py
index d216cb0aed..84c6372ab9 100644
--- a/var/spack/repos/builtin/packages/vim/package.py
+++ b/var/spack/repos/builtin/packages/vim/package.py
@@ -1,27 +1,8 @@
-##############################################################################
-# Copyright (c) 2013-2017, Lawrence Livermore National Security, LLC.
-# Produced at the Lawrence Livermore National Laboratory.
+# Copyright 2013-2018 Lawrence Livermore National Security, LLC and other
+# Spack Project Developers. See the top-level COPYRIGHT file for details.
#
-# This file is part of Spack.
-# Created by Todd Gamblin, tgamblin@llnl.gov, All rights reserved.
-# LLNL-CODE-647188
-#
-# For details, see https://github.com/spack/spack
-# Please also see the NOTICE and LICENSE files for our notice and the LGPL.
-#
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU Lesser General Public License (as
-# published by the Free Software Foundation) version 2.1, February 1999.
-#
-# This program is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the IMPLIED WARRANTY OF
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the terms and
-# conditions of the GNU Lesser General Public License for more details.
-#
-# You should have received a copy of the GNU Lesser General Public
-# License along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
-##############################################################################
+# SPDX-License-Identifier: (Apache-2.0 OR MIT)
+
from spack import *
@@ -35,8 +16,11 @@ class Vim(AutotoolsPackage):
"""
homepage = "http://www.vim.org"
- url = "https://github.com/vim/vim/archive/v8.0.0134.tar.gz"
+ url = "https://github.com/vim/vim/archive/v8.1.0338.tar.gz"
+ version('8.1.0338', '94191b4141245a5deb4955c4a80359bb')
+ version('8.1.0001', 'edb6f5c67cb3100ea9e3966a43b9c9da')
+ version('8.0.1376', '62855881a2d96d48956859d74cfb8a3b')
version('8.0.0503', '82b77bd5cb38b70514bed47cfe033b8c')
version('8.0.0454', '4030bf677bdfbd14efb588e4d9a24128')
version('8.0.0134', 'c74668d25c2acc85d655430dd60886cd')
@@ -65,6 +49,11 @@ class Vim(AutotoolsPackage):
# support for auto/no/gtk2/gnome2/gtk3/motif/athena/neXtaw/photon/carbon
variant('gui', default=False, description="build with gui (gvim)")
variant('x', default=False, description="use the X Window System")
+ depends_on('libx11', when="+x")
+ depends_on('libsm', when="+x")
+ depends_on('libxpm', when="+x")
+ depends_on('libxt', when="+x")
+ depends_on('libxtst', when="+x")
depends_on('ncurses', when="@7.4:")
@@ -95,9 +84,14 @@ class Vim(AutotoolsPackage):
configure_args.append("--with-features=" + feature_set)
if '+python' in spec:
- configure_args.append("--enable-pythoninterp=yes")
+ if 'python@3:' in self.spec:
+ configure_args.append("--enable-python3interp=yes")
+ configure_args.append("--enable-pythoninterp=no")
+ else:
+ configure_args.append("--enable-python3interp=no")
+ configure_args.append("--enable-pythoninterp=yes")
else:
- configure_args.append("--enable-pythoninterp=no")
+ configure_args.append("--enable-python3interp=no")
if '+ruby' in spec:
configure_args.append("--enable-rubyinterp=yes")
@@ -130,6 +124,10 @@ class Vim(AutotoolsPackage):
return configure_args
+ # Tests must be run in serial
+ def check(self):
+ make('test', parallel=False)
+
# Run the install phase with -j 1. There seems to be a problem with
# parallel builds that results in the creation of the links (e.g. view)
# to the vim binary silently failing.