summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/xsbench/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/xsbench/package.py')
-rw-r--r--var/spack/repos/builtin/packages/xsbench/package.py36
1 files changed, 11 insertions, 25 deletions
diff --git a/var/spack/repos/builtin/packages/xsbench/package.py b/var/spack/repos/builtin/packages/xsbench/package.py
index 345d566bc0..e8010c135e 100644
--- a/var/spack/repos/builtin/packages/xsbench/package.py
+++ b/var/spack/repos/builtin/packages/xsbench/package.py
@@ -1,27 +1,8 @@
-##############################################################################
-# Copyright (c) 2013-2017, Lawrence Livermore National Security, LLC.
-# Produced at the Lawrence Livermore National Laboratory.
+# Copyright 2013-2018 Lawrence Livermore National Security, LLC and other
+# Spack Project Developers. See the top-level COPYRIGHT file for details.
#
-# This file is part of Spack.
-# Created by Todd Gamblin, tgamblin@llnl.gov, All rights reserved.
-# LLNL-CODE-647188
-#
-# For details, see https://github.com/spack/spack
-# Please also see the LICENSE file for our notice and the LGPL.
-#
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU Lesser General Public License (as
-# published by the Free Software Foundation) version 2.1, February 1999.
-#
-# This program is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the IMPLIED WARRANTY OF
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the terms and
-# conditions of the GNU Lesser General Public License for more details.
-#
-# You should have received a copy of the GNU Lesser General Public
-# License along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
-##############################################################################
+# SPDX-License-Identifier: (Apache-2.0 OR MIT)
+
from spack import *
@@ -37,10 +18,12 @@ class Xsbench(MakefilePackage):
tags = ['proxy-app', 'ecp-proxy-app']
+ version('18', sha256='a9a544eeacd1be8d687080d2df4eeb701c04eda31d3806e7c3ea1ff36c26f4b0')
version('14', '94d5d28eb031fd4ef35507c9c1862169')
version('13', '72a92232d2f5777fb52f5ea4082aff37')
- variant('mpi', default=False, description='Build with MPI support')
+ variant('mpi', default=True, description='Build with MPI support')
+ variant('openmp', default=True, description='Build with OpenMP support')
depends_on('mpi', when='+mpi')
@@ -54,8 +37,11 @@ class Xsbench(MakefilePackage):
cflags = '-std=gnu99'
if '+mpi' in self.spec:
targets.append('CC={0}'.format(self.spec['mpi'].mpicc))
+ else:
+ targets.append('CC={0}'.format(self.compiler.cxx))
- cflags += ' ' + self.compiler.openmp_flag
+ if '+openmp' in self.spec:
+ cflags += ' ' + self.compiler.openmp_flag
targets.append('CFLAGS={0}'.format(cflags))
targets.append('LDFLAGS=-lm')