summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-12 10:56:11 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-12 10:56:11 +0000
commit025606accdfe07de9aafe079e4f068ac4d54d9d1 (patch)
treef6ac6d3a785ffcc4f2c0a5c705edbe8e17757f1b
parent20b49018c40a8128596be4450639bb4252be6e15 (diff)
downloadpackages-025606accdfe07de9aafe079e4f068ac4d54d9d1.tar.gz
packages-025606accdfe07de9aafe079e4f068ac4d54d9d1.tar.bz2
packages-025606accdfe07de9aafe079e4f068ac4d54d9d1.tar.xz
packages-025606accdfe07de9aafe079e4f068ac4d54d9d1.zip
user/lua-expat: Bump to 1.3.3
-rw-r--r--user/lua-expat/APKBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/user/lua-expat/APKBUILD b/user/lua-expat/APKBUILD
index 9b6295bc1..452404157 100644
--- a/user/lua-expat/APKBUILD
+++ b/user/lua-expat/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: Kiyoshi Aman <adelie@aerdan.vulpine.house>
pkgname=lua-expat
_name=expat
-pkgver=1.3.0
+pkgver=1.3.3
pkgrel=0
pkgdesc="SAX XML parser based on the Expat library"
url="https://matthewwild.co.uk/projects/luaexpat/"
@@ -11,22 +11,22 @@ arch="all"
license="MIT"
depends="lua5.3"
makedepends="lua5.3-dev expat-dev"
-source="http://matthewwild.co.uk/projects/luaexpat/luaexpat-$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/tomasguisasola/luaexpat/archive/v1.3.3.tar.gz"
builddir="$srcdir/luaexpat-$pkgver"
build() {
- cd "$builddir"
make LUA_V=5.3
}
check() {
- cd "$builddir"
- LUA_CPATH="./src/?.so" lua tests/test.lua
+ LUA_CPATH="./src/?.so.1.3.3" lua tests/test.lua
}
package() {
- cd "$builddir"
- make LUA_V=5.3 DESTDIR="$pkgdir" install
+ make \
+ LUA_LIBDIR="$pkgdir"/usr/lib/lua5.3 \
+ LUA_DIR="$pkgdir"/usr/share/lua5.3 \
+ LUA_V=5.3 DESTDIR="$pkgdir" install
}
-sha512sums="91884653310e2dc89ade6d1653875ac8607640a21853d3ccb1fd0f833812e41981fad5c40101732ec249104d2c50c9a332208d1e44423b8428065a223c60b4ae luaexpat-1.3.0.tar.gz"
+sha512sums="aa3f730c64cae3791fc1125302178ec2398d2380e8ec0e65ca4b29f532f181f149baaf555bf687e502b28726d3fd0baafd4f73cf26f04f625d18bbaddb043d63 lua-expat-1.3.3.tar.gz"