summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Rees <maxcrees@me.com>2020-12-30 02:48:41 -0500
committerMax Rees <maxcrees@me.com>2020-12-30 03:01:08 -0500
commit2386d77e93fb5d1a699e6a32531ba05b775b9628 (patch)
tree40fa7b7e59054b61189007d69a53e1d4166a8c4a
parent81b7fc8134227551cf3b3f11653f83cfbc8672c4 (diff)
downloadpackages-2386d77e93fb5d1a699e6a32531ba05b775b9628.tar.gz
packages-2386d77e93fb5d1a699e6a32531ba05b775b9628.tar.bz2
packages-2386d77e93fb5d1a699e6a32531ba05b775b9628.tar.xz
packages-2386d77e93fb5d1a699e6a32531ba05b775b9628.zip
user/py3-apkkit: new package
-rw-r--r--user/py3-apkkit/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/user/py3-apkkit/APKBUILD b/user/py3-apkkit/APKBUILD
new file mode 100644
index 000000000..177c9f901
--- /dev/null
+++ b/user/py3-apkkit/APKBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Max Rees <maxcrees@me.com>
+pkgname=py3-apkkit
+_pkgname=${pkgname#py3-}
+pkgver=0.6.0.1
+pkgrel=0
+pkgdesc="Python library for manipulating and verifying APK packages"
+url="https://code.foxkit.us/adelie/apkkit"
+arch="noarch"
+options="!check" # No test suite.
+license="NCSA"
+depends="python3"
+makedepends=""
+source="https://files.pythonhosted.org/packages/source/a/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+ rm "$pkgdir"/usr/README.rst
+}
+
+sha512sums="ef33047ce765d86872e0b4eb9204ec8741e1bbf3c93257797b2c7a0720bb090a90b83380e5f3194b3788557b9693dd32392e6be8235f82ab2eaf118cba8166e2 apkkit-0.6.0.1.tar.gz"