summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-13 05:05:43 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-13 05:05:43 +0000
commitf809d27d00677997adac74dc1422d8a42ec69b0c (patch)
treeaf404a9ba09eac3ec534a308260193454781879e
parent025606accdfe07de9aafe079e4f068ac4d54d9d1 (diff)
downloadpackages-f809d27d00677997adac74dc1422d8a42ec69b0c.tar.gz
packages-f809d27d00677997adac74dc1422d8a42ec69b0c.tar.bz2
packages-f809d27d00677997adac74dc1422d8a42ec69b0c.tar.xz
packages-f809d27d00677997adac74dc1422d8a42ec69b0c.zip
user/*: Modernise / fix syntax / deps / metadata / code
-rw-r--r--user/checkbashisms/APKBUILD3
-rw-r--r--user/compton/APKBUILD7
-rw-r--r--user/gucharmap/APKBUILD12
-rw-r--r--user/gucharmap/unicode-12.1.patch25
-rw-r--r--user/ipaexfont/APKBUILD5
-rw-r--r--user/kanjistrokeorders/APKBUILD6
-rw-r--r--user/koruri/APKBUILD2
-rw-r--r--user/libcmis/APKBUILD11
-rw-r--r--user/libcmis/icu.patch17
-rw-r--r--user/libnfs/APKBUILD4
-rw-r--r--user/mate-applets/APKBUILD3
-rw-r--r--user/mate-complete/APKBUILD22
-rw-r--r--user/nextcloud/APKBUILD4
-rw-r--r--user/py3-html5lib/APKBUILD14
-rw-r--r--user/py3-html5lib/pytest.patch163
-rw-r--r--user/py3-twisted/APKBUILD2
-rw-r--r--user/subversion/APKBUILD2
17 files changed, 249 insertions, 53 deletions
diff --git a/user/checkbashisms/APKBUILD b/user/checkbashisms/APKBUILD
index f1a54aa14..26345d0ac 100644
--- a/user/checkbashisms/APKBUILD
+++ b/user/checkbashisms/APKBUILD
@@ -33,8 +33,7 @@ bashcomp() {
depends=""
install_if="$pkgname=$pkgver-r$pkgrel bash-completion"
- cd "$builddir"
- install -Dm644 "scripts/$pkgname.bash_completion" \
+ install -Dm644 "$builddir/scripts/$pkgname.bash_completion" \
"$subpkgdir/usr/share/bash-completion/completions/$pkgname"
}
diff --git a/user/compton/APKBUILD b/user/compton/APKBUILD
index 0cfae4b52..82b9cc638 100644
--- a/user/compton/APKBUILD
+++ b/user/compton/APKBUILD
@@ -6,15 +6,15 @@ pkgrel=0
pkgdesc="Lightweight compositor for X11"
url="https://github.com/yshui/compton"
arch="all"
-options="!check" # no tests
+options="!check" # No test suite.
license="MIT AND MPL-2.0"
+depends=""
makedepends="meson libx11-dev libxext-dev libev-dev xcb-util-renderutil-dev
xcb-util-image-dev pixman-dev libconfig-dev pcre-dev mesa-dev
dbus-dev"
-source="compton-$pkgver.tar.gz::https://github.com/yshui/compton/archive/v$pkgver.tar.gz"
+source="https://distfiles.adelielinux.org/source/$pkgname-$pkgver.tar.gz"
build() {
- cd "$builddir"
meson \
--prefix=/usr \
--sysconfdir=/etc \
@@ -26,7 +26,6 @@ build() {
}
package() {
- cd "$builddir"
DESTDIR="$pkgdir" ninja -C output install
}
diff --git a/user/gucharmap/APKBUILD b/user/gucharmap/APKBUILD
index 913d4f749..b3575c955 100644
--- a/user/gucharmap/APKBUILD
+++ b/user/gucharmap/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Kiyoshi Aman <adelie@aerdan.vulpine.house>
pkgname=gucharmap
pkgver=12.0.1
-_unicode=12.0.0
+_unicode=12.1.0
pkgrel=0
pkgdesc="Unicode utility for the Gnome desktop environment"
url="https://gnome.org"
@@ -12,10 +12,11 @@ depends=""
makedepends="desktop-file-utils gobject-introspection-dev gtk+3.0-dev intltool
itstool libxml2-utils unicode-data"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
-source="https://download.gnome.org/sources/gucharmap/${pkgver%.*}/gucharmap-$pkgver.tar.xz"
+source="https://download.gnome.org/sources/gucharmap/${pkgver%.*}/gucharmap-$pkgver.tar.xz
+ unicode-12.1.patch
+ "
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -28,13 +29,12 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="989034350c73c3f1857167f434aa4a5c140ef7574cb799b874e421a8d0c2bf520dfcee85bc0cf8e52f439fb7d30e0db5172a25c107c80b38ce6da4e703a3ffc2 gucharmap-12.0.1.tar.xz"
+sha512sums="989034350c73c3f1857167f434aa4a5c140ef7574cb799b874e421a8d0c2bf520dfcee85bc0cf8e52f439fb7d30e0db5172a25c107c80b38ce6da4e703a3ffc2 gucharmap-12.0.1.tar.xz
+aac3a9b95985b1fd2122f1a759a0c571116a94cc429c4e9736a4f2a36e257241e7bdc4e6ba7badaeebca79bd8cca275ff66b6e9f933c707342b8872ab78dbe7f unicode-12.1.patch"
diff --git a/user/gucharmap/unicode-12.1.patch b/user/gucharmap/unicode-12.1.patch
new file mode 100644
index 000000000..60dbb7af5
--- /dev/null
+++ b/user/gucharmap/unicode-12.1.patch
@@ -0,0 +1,25 @@
+diff -Naur gucharmap-12.0.1-orig/gucharmap/gucharmap-unicode-info.h gucharmap-12.0.1/gucharmap/gucharmap-unicode-info.h
+--- gucharmap-12.0.1-orig/gucharmap/gucharmap-unicode-info.h 2019-03-07 21:21:27.000000000 +0100
++++ gucharmap-12.0.1/gucharmap/gucharmap-unicode-info.h 2019-11-14 17:43:55.007583238 +0100
+@@ -51,7 +51,8 @@
+ GUCHARMAP_UNICODE_VERSION_10_0,
+ GUCHARMAP_UNICODE_VERSION_11_0,
+ GUCHARMAP_UNICODE_VERSION_12_0,
+- GUCHARMAP_UNICODE_VERSION_LATEST = GUCHARMAP_UNICODE_VERSION_12_0 /* private, will move forward with each revision */
++ GUCHARMAP_UNICODE_VERSION_12_1,
++ GUCHARMAP_UNICODE_VERSION_LATEST = GUCHARMAP_UNICODE_VERSION_12_1 /* private, will move forward with each revision */
+ } GucharmapUnicodeVersion;
+
+ /* return values are read-only */
+diff -Naur gucharmap-12.0.1-orig/gucharmap/gucharmap-window.c gucharmap-12.0.1/gucharmap/gucharmap-window.c
+--- gucharmap-12.0.1-orig/gucharmap/gucharmap-window.c 2019-03-07 21:21:27.000000000 +0100
++++ gucharmap-12.0.1/gucharmap/gucharmap-window.c 2019-11-14 17:45:11.145809820 +0100
+@@ -454,7 +454,7 @@
+ gtk_show_about_dialog (GTK_WINDOW (guw),
+ "program-name", _("GNOME Character Map"),
+ "version", VERSION,
+- "comments", _("Based on the Unicode Character Database 12.0.0"),
++ "comments", _("Based on the Unicode Character Database 12.1.0"),
+ "copyright", "Copyright © 2004 Noah Levitt\n"
+ "Copyright © 1991–2019 Unicode, Inc.\n"
+ "Copyright © 2007–2019 Christian Persch\n"
diff --git a/user/ipaexfont/APKBUILD b/user/ipaexfont/APKBUILD
index f76922b9a..fd3fb85d5 100644
--- a/user/ipaexfont/APKBUILD
+++ b/user/ipaexfont/APKBUILD
@@ -12,12 +12,11 @@ license="IPA"
depends="fontconfig"
makedepends=""
subpackages=""
-source="https://oscdl.ipa.go.jp/IPAexfont/IPAexfont$_pkgver.zip"
+source="https://distfiles.adelielinux.org/source/IPAexfont$_pkgver.zip"
builddir="$srcdir/IPAexfont$_pkgver"
package() {
- cd "$builddir"
- install -m644 -Dt "$pkgdir"/usr/share/fonts/X11/TTF/ *.ttf
+ install -m644 -Dt "$pkgdir"/usr/share/fonts/X11/TTF/ "$builddir"/*.ttf
}
sha512sums="fe639ded0a25eed66df8cc1e9d5e965b501574a25fab542a749b3cb8464690448e44343ff5845aecd3224ec481c4089ee56e64880cbbc9211a260b22d4cc68cd IPAexfont00401.zip"
diff --git a/user/kanjistrokeorders/APKBUILD b/user/kanjistrokeorders/APKBUILD
index f73660b2c..b5f88df2e 100644
--- a/user/kanjistrokeorders/APKBUILD
+++ b/user/kanjistrokeorders/APKBUILD
@@ -11,12 +11,10 @@ license="BSD-3-Clause"
depends="fontconfig"
makedepends=""
subpackages=""
-source="KanjiStrokeOrders_v$pkgver.ttf::https://sites.google.com/site/nihilistorguk/KanjiStrokeOrders_v${pkgver}.ttf?attredirects=0"
-builddir="$srcdir/"
+source="https://distfiles.adelielinux.org/source/KanjiStrokeOrders_v${pkgver}.ttf"
package() {
- cd "$builddir"
- install -m644 -Dt "$pkgdir"/usr/share/fonts/X11/TTF/ *.ttf
+ install -m644 -Dt "$pkgdir"/usr/share/fonts/X11/TTF/ "$srcdir"/*.ttf
}
sha512sums="7382be90761ec63f01fb715154955a76fb78acf1a50a6c3abc3b5b753ebb8bb01d1884e154dce6b15284ac2d7600d1276b098705ee925ee86c42d4194c688721 KanjiStrokeOrders_v4.002.ttf"
diff --git a/user/koruri/APKBUILD b/user/koruri/APKBUILD
index 95ba170d1..4f6f28ace 100644
--- a/user/koruri/APKBUILD
+++ b/user/koruri/APKBUILD
@@ -11,7 +11,7 @@ license="Apache-2.0 AND custom:M+-FONTS"
depends="fontconfig"
makedepends=""
subpackages=""
-source="https://mirrors.gigenet.com/OSDN//koruri/70038/Koruri-$pkgver.tar.xz"
+source="https://distfiles.adelielinux.org/source/Koruri-$pkgver.tar.xz"
builddir="$srcdir/Koruri-$pkgver"
package() {
diff --git a/user/libcmis/APKBUILD b/user/libcmis/APKBUILD
index bfc58c4d5..4917aab08 100644
--- a/user/libcmis/APKBUILD
+++ b/user/libcmis/APKBUILD
@@ -2,17 +2,19 @@
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=libcmis
pkgver=0.5.2
-pkgrel=0
+pkgrel=1
pkgdesc="CMIS protocol client library for C/C++"
url="https://github.com/tdf/libcmis"
arch="all"
license="MPL-1.1 OR GPL-2.0+ OR LGPL-2.0+"
depends=""
depends_dev="boost-dev"
-makedepends="$depends_dev curl-dev libxml2-dev"
checkdepends="cppunit-dev"
+makedepends="$depends_dev curl-dev libxml2-dev"
subpackages="$pkgname-dev cmis-client:client"
-source="https://github.com/tdf/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz"
+source="https://github.com/tdf/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz
+ icu.patch
+ "
build() {
# Note: manpages require docbook2x to build
@@ -42,4 +44,5 @@ client() {
mv "$pkgdir"/usr/bin "$subpkgdir"/usr
}
-sha512sums="3dac0eed31d1dd3ac4670e501e0677196811f7875e6d1c253c8d874d6903691cbe4f1c27c8468af07bfd7f79b0d6ec4f933b28cb3bb37dcbea18bc2dd8f6e374 libcmis-0.5.2.tar.gz"
+sha512sums="3dac0eed31d1dd3ac4670e501e0677196811f7875e6d1c253c8d874d6903691cbe4f1c27c8468af07bfd7f79b0d6ec4f933b28cb3bb37dcbea18bc2dd8f6e374 libcmis-0.5.2.tar.gz
+0904a529eafa8e1cfdb673e4e7f37150b0b88886cdc32096a89153cb5856d16dc5fee52f39ae5bfea86065b20690a6e14e4b9ad11b36b682c062702b797e82cd icu.patch"
diff --git a/user/libcmis/icu.patch b/user/libcmis/icu.patch
new file mode 100644
index 000000000..6ba63ee7f
--- /dev/null
+++ b/user/libcmis/icu.patch
@@ -0,0 +1,17 @@
+--- a/inc/libcmis-c/repository.h 2018-12-27 14:07:55.000000000 +0100
++++ b/inc/libcmis-c/repository.h 2019-04-21 01:29:46.504373226 +0200
+@@ -28,12 +28,12 @@
+ #ifndef _REPOSITORY_H_
+ #define _REPOSITORY_H_
+
++#include <libxml/tree.h>
++
+ #ifdef __cplusplus
+ extern "C" {
+ #endif
+
+-#include <libxml/tree.h>
+-
+ #include "libcmis-c/libcmis-c-api.h"
+ #include "libcmis-c/types.h"
+
diff --git a/user/libnfs/APKBUILD b/user/libnfs/APKBUILD
index 4fde5e380..d060df361 100644
--- a/user/libnfs/APKBUILD
+++ b/user/libnfs/APKBUILD
@@ -7,6 +7,7 @@ pkgdesc="Client library for accessing NFS shares"
url="https://github.com/sahlberg/libnfs"
arch="all"
license="LGPL-2.1+ AND BSD-2-Clause-FreeBSD AND GPL-3.0+"
+depends=""
makedepends="autoconf automake libtool"
subpackages="$pkgname-dev $pkgname-doc"
source="https://github.com/sahlberg/libnfs/archive/libnfs-$pkgver.tar.gz
@@ -15,7 +16,6 @@ source="https://github.com/sahlberg/libnfs/archive/libnfs-$pkgver.tar.gz
builddir="$srcdir"/libnfs-libnfs-$pkgver
build() {
- cd "$builddir"
./bootstrap
./configure \
--build=$CBUILD \
@@ -29,12 +29,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
diff --git a/user/mate-applets/APKBUILD b/user/mate-applets/APKBUILD
index e8781f776..387e30bac 100644
--- a/user/mate-applets/APKBUILD
+++ b/user/mate-applets/APKBUILD
@@ -16,7 +16,6 @@ subpackages="$pkgname-doc $pkgname-lang"
source="https://pub.mate-desktop.org/releases/1.22/mate-applets-$pkgver.tar.xz"
build() {
- cd "$builddir"
rm -r mateweather/docs/ru
./configure \
--build=$CBUILD \
@@ -29,12 +28,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
diff --git a/user/mate-complete/APKBUILD b/user/mate-complete/APKBUILD
index ec770dd97..a828fd924 100644
--- a/user/mate-complete/APKBUILD
+++ b/user/mate-complete/APKBUILD
@@ -3,24 +3,26 @@
pkgname=mate-complete
pkgver=1.22.0
pkgrel=0
-url="https://mate-desktop.org"
pkgdesc="Complete MATE desktop environment"
+url="https://mate-desktop.org"
arch="noarch"
options="!check" # No tests
-license=" "
+license="Public-Domain"
depends="atril caja caja-dropbox caja-extensions engrampa eom marco
- mate-applets mate-backgrounds mate-calc mate-control-center
- mate-desktop mate-icon-theme mate-indicator-applet mate-media
- mate-menus mate-netbook mate-notification-daemon mate-panel
- mate-polkit mate-power-manager mate-screensaver mate-sensors-applet
- mate-session-manager mate-settings-daemon mate-system-monitor
- mate-terminal mate-user-guide mate-user-share mate-utils mozo pluma"
+ mate-applets mate-backgrounds mate-calc mate-control-center
+ mate-desktop mate-icon-theme mate-indicator-applet mate-media
+ mate-menus mate-netbook mate-notification-daemon mate-panel
+ mate-polkit mate-power-manager mate-screensaver mate-sensors-applet
+ mate-session-manager mate-settings-daemon mate-system-monitor
+ mate-terminal mate-user-guide mate-user-share mate-utils mozo pluma"
+makedepends=""
+subpackages=""
source="org.adelie-linux.about-mate.desktop"
package() {
- cd "$srcdir"
mkdir -p "$pkgdir"/usr/share/applications
- install -Dm644 org.adelie-linux.about-mate.desktop "$pkgdir"/usr/share/applications
+ install -Dm644 "$srcdir"/org.adelie-linux.about-mate.desktop \
+ "$pkgdir"/usr/share/applications
}
sha512sums="24fd0524d949a22b22e38c81667f31498bc524302c52128c10d8a5802315720543426ba82245f5e7510832c493389ff59f36be14433f1a6a6c68993f733f329c org.adelie-linux.about-mate.desktop"
diff --git a/user/nextcloud/APKBUILD b/user/nextcloud/APKBUILD
index b044b12af..6e948b1ff 100644
--- a/user/nextcloud/APKBUILD
+++ b/user/nextcloud/APKBUILD
@@ -104,10 +104,6 @@ done
# Directory for apps shipped with Nextcloud.
_appsdir="usr/share/webapps/$pkgname/apps"
-build() {
- cd "$builddir"
-}
-
package() {
local basedir="var/lib/$pkgname"
local datadir="$basedir/data"
diff --git a/user/py3-html5lib/APKBUILD b/user/py3-html5lib/APKBUILD
index 898efe4f1..f4f5f7781 100644
--- a/user/py3-html5lib/APKBUILD
+++ b/user/py3-html5lib/APKBUILD
@@ -9,27 +9,27 @@ pkgrel=0
pkgdesc="HTML parser based on the WHATWG HTML specification"
url="https://pypi.python.org/pypi/html5lib"
arch="noarch"
+options="!check" # https://github.com/html5lib/html5lib-python/issues/433
license="MIT"
depends="python3 py3-six py3-webencodings"
-makedepends="python3-dev"
checkdepends="py3-pytest py3-mock py3-pytest-expect"
-source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/$_p/$_pkgname/$_pkgname-$pkgver.tar.gz"
+makedepends="python3-dev"
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/$_p/$_pkgname/$_pkgname-$pkgver.tar.gz
+ pytest.patch
+ "
builddir="$srcdir/$_pkgname-$pkgver"
build() {
- cd "$builddir"
python3 setup.py build
}
check() {
- cd "$builddir"
pytest
}
package() {
- cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
-
}
-sha512sums="35939b4450893864da04e735ee5e0addacf1dd34bae6a6909c76572abf6bfded446a78a713dfde91c1485ba45867d7abeb6a45cf0545c16ea968707be7de5dd2 py3-html5lib-1.0.1.tar.gz"
+sha512sums="35939b4450893864da04e735ee5e0addacf1dd34bae6a6909c76572abf6bfded446a78a713dfde91c1485ba45867d7abeb6a45cf0545c16ea968707be7de5dd2 py3-html5lib-1.0.1.tar.gz
+89be46d5eb7b4a9ada22fa30576ae4f92d705b77988a47d52cbd876bf36240b461e7a0057c865a6b1798a3117343159ecbca43faf5316b446e5a80b8486a7e86 pytest.patch"
diff --git a/user/py3-html5lib/pytest.patch b/user/py3-html5lib/pytest.patch
new file mode 100644
index 000000000..fd6f99649
--- /dev/null
+++ b/user/py3-html5lib/pytest.patch
@@ -0,0 +1,163 @@
+From 2699544837e68b12f1740a7eb56882a0dc0a4008 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Miro=20Hron=C4=8Dok?= <miro@hroncok.cz>
+Date: Thu, 28 Mar 2019 01:45:43 +0100
+Subject: [PATCH] Support pytest 4
+
+Fixes https://github.com/html5lib/html5lib-python/issues/411
+---
+ html5lib/tests/test_encoding.py | 4 ++--
+ html5lib/tests/test_sanitizer.py | 14 +++++++-------
+ html5lib/tests/test_serializer.py | 2 +-
+ html5lib/tests/test_stream.py | 7 ++++---
+ html5lib/tests/test_treewalkers.py | 2 +-
+ requirements-test.txt | 2 +-
+ 6 files changed, 16 insertions(+), 15 deletions(-)
+
+diff --git a/html5lib/tests/test_encoding.py b/html5lib/tests/test_encoding.py
+index 9a411c77..97b6ca2a 100644
+--- a/html5lib/tests/test_encoding.py
++++ b/html5lib/tests/test_encoding.py
+@@ -99,8 +99,8 @@ def test_encoding():
+ for filename in get_data_files("encoding"):
+ tests = _TestData(filename, b"data", encoding=None)
+ for test in tests:
+- yield (runParserEncodingTest, test[b'data'], test[b'encoding'])
+- yield (runPreScanEncodingTest, test[b'data'], test[b'encoding'])
++ runParserEncodingTest(test[b'data'], test[b'encoding'])
++ runPreScanEncodingTest(test[b'data'], test[b'encoding'])
+
+
+ # pylint:disable=wrong-import-position
+diff --git a/html5lib/tests/test_sanitizer.py b/html5lib/tests/test_sanitizer.py
+index 45046d57..1b7285fc 100644
+--- a/html5lib/tests/test_sanitizer.py
++++ b/html5lib/tests/test_sanitizer.py
+@@ -67,19 +67,19 @@ def test_sanitizer():
+ 'tfoot', 'th', 'thead', 'tr', 'select']:
+ continue # TODO
+ if tag_name == 'image':
+- yield (runSanitizerTest, "test_should_allow_%s_tag" % tag_name,
++ runSanitizerTest("test_should_allow_%s_tag" % tag_name,
+ "<img title=\"1\"/>foo &lt;bad&gt;bar&lt;/bad&gt; baz",
+ "<%s title='1'>foo <bad>bar</bad> baz</%s>" % (tag_name, tag_name))
+ elif tag_name == 'br':
+- yield (runSanitizerTest, "test_should_allow_%s_tag" % tag_name,
++ runSanitizerTest("test_should_allow_%s_tag" % tag_name,
+ "<br title=\"1\"/>foo &lt;bad&gt;bar&lt;/bad&gt; baz<br/>",
+ "<%s title='1'>foo <bad>bar</bad> baz</%s>" % (tag_name, tag_name))
+ elif tag_name in constants.voidElements:
+- yield (runSanitizerTest, "test_should_allow_%s_tag" % tag_name,
++ runSanitizerTest("test_should_allow_%s_tag" % tag_name,
+ "<%s title=\"1\"/>foo &lt;bad&gt;bar&lt;/bad&gt; baz" % tag_name,
+ "<%s title='1'>foo <bad>bar</bad> baz</%s>" % (tag_name, tag_name))
+ else:
+- yield (runSanitizerTest, "test_should_allow_%s_tag" % tag_name,
++ runSanitizerTest("test_should_allow_%s_tag" % tag_name,
+ "<%s title=\"1\">foo &lt;bad&gt;bar&lt;/bad&gt; baz</%s>" % (tag_name, tag_name),
+ "<%s title='1'>foo <bad>bar</bad> baz</%s>" % (tag_name, tag_name))
+
+@@ -93,7 +93,7 @@ def test_sanitizer():
+ attribute_value = 'foo'
+ if attribute_name in sanitizer.attr_val_is_uri:
+ attribute_value = '%s://sub.domain.tld/path/object.ext' % sanitizer.allowed_protocols[0]
+- yield (runSanitizerTest, "test_should_allow_%s_attribute" % attribute_name,
++ runSanitizerTest("test_should_allow_%s_attribute" % attribute_name,
+ "<p %s=\"%s\">foo &lt;bad&gt;bar&lt;/bad&gt; baz</p>" % (attribute_name, attribute_value),
+ "<p %s='%s'>foo <bad>bar</bad> baz</p>" % (attribute_name, attribute_value))
+
+@@ -101,7 +101,7 @@ def test_sanitizer():
+ rest_of_uri = '//sub.domain.tld/path/object.ext'
+ if protocol == 'data':
+ rest_of_uri = 'image/png;base64,aGVsbG8gd29ybGQ='
+- yield (runSanitizerTest, "test_should_allow_uppercase_%s_uris" % protocol,
++ runSanitizerTest("test_should_allow_uppercase_%s_uris" % protocol,
+ "<img src=\"%s:%s\">foo</a>" % (protocol, rest_of_uri),
+ """<img src="%s:%s">foo</a>""" % (protocol, rest_of_uri))
+
+@@ -110,7 +110,7 @@ def test_sanitizer():
+ if protocol == 'data':
+ rest_of_uri = 'image/png;base64,aGVsbG8gd29ybGQ='
+ protocol = protocol.upper()
+- yield (runSanitizerTest, "test_should_allow_uppercase_%s_uris" % protocol,
++ runSanitizerTest("test_should_allow_uppercase_%s_uris" % protocol,
+ "<img src=\"%s:%s\">foo</a>" % (protocol, rest_of_uri),
+ """<img src="%s:%s">foo</a>""" % (protocol, rest_of_uri))
+
+diff --git a/html5lib/tests/test_serializer.py b/html5lib/tests/test_serializer.py
+index c23592af..a4250935 100644
+--- a/html5lib/tests/test_serializer.py
++++ b/html5lib/tests/test_serializer.py
+@@ -222,4 +222,4 @@ def test_serializer():
+ with open(filename) as fp:
+ tests = json.load(fp)
+ for test in tests['tests']:
+- yield runSerializerTest, test["input"], test["expected"], test.get("options", {})
++ runSerializerTest(test["input"], test["expected"], test.get("options", {}))
+diff --git a/html5lib/tests/test_stream.py b/html5lib/tests/test_stream.py
+index 27c39538..a9b3ebbe 100644
+--- a/html5lib/tests/test_stream.py
++++ b/html5lib/tests/test_stream.py
+@@ -308,9 +308,10 @@ def test_invalid_codepoints(inp, num):
+ ("'\\uD800\\uD800\\uD800'", 3),
+ ("'a\\uD800a\\uD800a\\uD800a'", 3),
+ ("'\\uDFFF\\uDBFF'", 2),
+- pytest.mark.skipif(sys.maxunicode == 0xFFFF,
+- ("'\\uDBFF\\uDFFF'", 2),
+- reason="narrow Python")])
++ pytest.param(
++ "'\\uDBFF\\uDFFF'", 2,
++ mark=pytest.mark.skipif(sys.maxunicode == 0xFFFF,
++ reason="narrow Python"))])
+ def test_invalid_codepoints_surrogates(inp, num):
+ inp = eval(inp) # pylint:disable=eval-used
+ fp = StringIO(inp)
+diff --git a/html5lib/tests/test_treewalkers.py b/html5lib/tests/test_treewalkers.py
+index 67fc89e5..c2323b7e 100644
+--- a/html5lib/tests/test_treewalkers.py
++++ b/html5lib/tests/test_treewalkers.py
+@@ -99,7 +99,7 @@ def test_treewalker_six_mix():
+
+ for tree in sorted(treeTypes.items()):
+ for intext, attrs, expected in sm_tests:
+- yield runTreewalkerEditTest, intext, expected, attrs, tree
++ runTreewalkerEditTest(intext, expected, attrs, tree)
+
+
+ @pytest.mark.parametrize("tree,char", itertools.product(sorted(treeTypes.items()), ["x", "\u1234"]))
+diff --git a/requirements-test.txt b/requirements-test.txt
+index 4e223a3f..b936e0fa 100644
+--- a/requirements-test.txt
++++ b/requirements-test.txt
+@@ -4,7 +4,7 @@ tox
+
+ flake8<3.0
+
+-pytest==3.2.5
++pytest>=4.3,<4.4
+ coverage
+ pytest-expect>=1.1,<2.0
+ mock
+From 29bb168659da16f7c03ce635a8fbb4cdc2502667 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Mat=C4=9Bj=20Cepl?= <mcepl@cepl.eu>
+Date: Mon, 6 Jan 2020 10:55:49 +0100
+Subject: [PATCH] marks not mark
+
+---
+ html5lib/tests/test_stream.py | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/html5lib/tests/test_stream.py b/html5lib/tests/test_stream.py
+index a9b3ebbe..06663b8c 100644
+--- a/html5lib/tests/test_stream.py
++++ b/html5lib/tests/test_stream.py
+@@ -310,8 +310,8 @@ def test_invalid_codepoints(inp, num):
+ ("'\\uDFFF\\uDBFF'", 2),
+ pytest.param(
+ "'\\uDBFF\\uDFFF'", 2,
+- mark=pytest.mark.skipif(sys.maxunicode == 0xFFFF,
+- reason="narrow Python"))])
++ marks=pytest.mark.skipif(sys.maxunicode == 0xFFFF,
++ reason="narrow Python"))])
+ def test_invalid_codepoints_surrogates(inp, num):
+ inp = eval(inp) # pylint:disable=eval-used
+ fp = StringIO(inp)
diff --git a/user/py3-twisted/APKBUILD b/user/py3-twisted/APKBUILD
index c1f9a6321..37f2b0976 100644
--- a/user/py3-twisted/APKBUILD
+++ b/user/py3-twisted/APKBUILD
@@ -10,7 +10,7 @@ pkgdesc="Asynchronous networking framework written in Python"
url="https://twistedmatrix.com/"
arch="all"
license="MIT"
-depends="py3-incremental"
+depends="python3 py3-incremental"
makedepends="python3-dev"
subpackages=""
source="https://files.pythonhosted.org/packages/source/$_p/$_pkgname/$_pkgname-$pkgver.tar.bz2"
diff --git a/user/subversion/APKBUILD b/user/subversion/APKBUILD
index 7e1940785..4e8c89514 100644
--- a/user/subversion/APKBUILD
+++ b/user/subversion/APKBUILD
@@ -14,7 +14,7 @@ depends_dev="apr-dev apr-util-dev linux-headers"
makedepends="apr-dev apr-util-dev cyrus-sasl-dev db-dev dbus-dev file-dev
kdelibs4support-dev kwallet-dev libsecret-dev lz4-dev openssl-dev
serf-dev sqlite-dev utf8proc-dev zlib-dev autoconf automake python3
- perl-dev swig"
+ perl-dev swig libtool"
subpackages="$pkgname-dev $pkgname-doc $pkgname-gnome $pkgname-kwallet
$pkgname-pl $pkgname-lang"
source="https://www-eu.apache.org/dist/subversion/subversion-$pkgver.tar.bz2