summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2017-01-13 20:33:23 -0600
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2017-01-13 20:33:23 -0600
commit20d58e4a5ce099fd3884cb5fa417c6c0b24607d4 (patch)
tree75cf05701712c1e62567158798735cff9306bf2d /setup.py
parent2a6aa165aa8b4b4e33aa3001bbd118dfa5b9b1e0 (diff)
downloadapkkit-20d58e4a5ce099fd3884cb5fa417c6c0b24607d4.tar.gz
apkkit-20d58e4a5ce099fd3884cb5fa417c6c0b24607d4.tar.bz2
apkkit-20d58e4a5ce099fd3884cb5fa417c6c0b24607d4.tar.xz
apkkit-20d58e4a5ce099fd3884cb5fa417c6c0b24607d4.zip
Add setup.py for distribution
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py44
1 files changed, 44 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..119d2e8
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,44 @@
+from setuptools import setup
+from codecs import open
+from os import path
+
+
+here = path.abspath(path.dirname(__file__))
+
+
+# Get the long description from the README file
+with open(path.join(here, 'README.rst'), encoding='utf-8') as f:
+ long_description = f.read()
+
+
+setup(
+ name='apkkit',
+ version='0.5',
+ description='Manage APK packages from Python',
+ long_description=long_description,
+ url='http://adelielinux.org/',
+ author='A. Wilcox',
+ author_email='awilfox@adelielinux.org',
+ license='NCSA',
+ classifiers=[
+ 'Development Status :: 3 - Alpha',
+ 'Intended Audience :: Developers',
+ 'Intended Audience :: System Administrators',
+ 'License :: OSI Approved',
+ 'Operating System :: POSIX :: Linux',
+ 'Programming Language :: Python :: 3.4',
+ 'Programming Language :: Python :: 3.5',
+ 'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: 3 :: Only',
+ 'Topic :: Software Development :: Libraries',
+ 'Topic :: System :: Archiving :: Packaging',
+ 'Topic :: System :: Software Distribution',
+ ],
+ keywords='apk packaging portage',
+ packages=('apkkit',),
+ install_requires=[
+ 'cryptography',
+ 'jinja',
+ 'pyyaml',
+ ]
+)