summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2020-03-24 07:36:25 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2020-03-24 07:36:25 -0500
commit1f67d2793e2abb7c833172a0a1966d76b1b9a06a (patch)
tree2a61a6a2a8bb5d5370cae8e8192ab48a12a4d4a4 /CMakeLists.txt
parentedad6721912ddedea21150f74cbb52a98f3910ee (diff)
downloadhorizon-1f67d2793e2abb7c833172a0a1966d76b1b9a06a.tar.gz
horizon-1f67d2793e2abb7c833172a0a1966d76b1b9a06a.tar.bz2
horizon-1f67d2793e2abb7c833172a0a1966d76b1b9a06a.tar.xz
horizon-1f67d2793e2abb7c833172a0a1966d76b1b9a06a.zip
Add the beginnings of the Image Creation utility
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6aafe43..76b191c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -76,6 +76,7 @@ IF(INSTALL)
message(FATAL_ERROR "BCNM is required for the Installation Environment.")
endif()
set(BUILD_SHARED_LIBS ON)
+ option(BUILD_IMAGE "Enable building the image creation tools" ON)
add_subdirectory(diskman)
add_subdirectory(executor)
@@ -94,6 +95,9 @@ IF(BUILD_UI)
ENDIF(BUILD_UI)
IF(INSTALL)
add_subdirectory(fetch)
+ IF(BUILD_IMAGE)
+ add_subdirectory(image)
+ ENDIF(BUILD_IMAGE)
ENDIF(INSTALL)