summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-10-26 06:22:53 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-10-26 06:22:53 -0500
commit53522bff955c63e85a507262b85bc7933c1e803d (patch)
tree46c06763625b8023b156f13510f7b654eb16e23b /CMakeLists.txt
parent71a729feb9242fa5f809c6ec4e7a3db572ec8822 (diff)
downloadhorizon-53522bff955c63e85a507262b85bc7933c1e803d.tar.gz
horizon-53522bff955c63e85a507262b85bc7933c1e803d.tar.bz2
horizon-53522bff955c63e85a507262b85bc7933c1e803d.tar.xz
horizon-53522bff955c63e85a507262b85bc7933c1e803d.zip
Build: Exclude Boost from code coverage tests
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 395c70b..64904db 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -79,7 +79,7 @@ IF(COVERAGE)
IF(LCOV_EXECUTABLE)
add_custom_command(OUTPUT horizon.coverage
- COMMAND lcov ARGS --exclude '/usr/include/c++/*' --exclude '*/3rdparty/*' --capture --directory ${CMAKE_BINARY_DIR} --output-file horizon.coverage)
+ COMMAND lcov ARGS --exclude '/usr/include/boost/*' --exclude '/usr/include/c++/*' --exclude '*/3rdparty/*' --capture --directory ${CMAKE_BINARY_DIR} --output-file horizon.coverage)
add_custom_target(lcov_report DEPENDS horizon.coverage)
add_custom_command(OUTPUT cov_html
COMMAND genhtml ARGS horizon.coverage --output-directory cov_html)