summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-10-14 13:37:47 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-10-14 13:37:47 -0500
commit593301e2a40119d4861a6167cf808187ae255035 (patch)
tree4801770626ff589faf36818ffe31ef0999d2febd /CMakeLists.txt
parentf93285df551fc1c97eb969b37308d673408d86e3 (diff)
downloadhorizon-593301e2a40119d4861a6167cf808187ae255035.tar.gz
horizon-593301e2a40119d4861a6167cf808187ae255035.tar.bz2
horizon-593301e2a40119d4861a6167cf808187ae255035.tar.xz
horizon-593301e2a40119d4861a6167cf808187ae255035.zip
hscript: Implement Mount::execute fully, including fstab manipulation
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e3a8619..16f9f58 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -6,6 +6,7 @@ project(Horizon
LANGUAGES CXX
VERSION 0.1.0)
+pkg_check_modules(BLKID REQUIRED blkid)
pkg_check_modules(LIBUDEV REQUIRED libudev)
pkg_check_modules(PARTED REQUIRED libparted)
find_library(BCNM_LIBRARY REQUIRED wpactrl PATH_SUFFIXES bcnm)