summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-10-06 13:46:57 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-10-06 13:46:57 -0500
commit65f70c4d29fb2ffc75aad2435ac6b03059bb6e80 (patch)
treefe78d655b3c918eedb7bc834d1daa281ef0f8430 /CMakeLists.txt
parent600ced25919b7b0d00cad5c7b5d805b549d8c3ed (diff)
downloadhorizon-65f70c4d29fb2ffc75aad2435ac6b03059bb6e80.tar.gz
horizon-65f70c4d29fb2ffc75aad2435ac6b03059bb6e80.tar.bz2
horizon-65f70c4d29fb2ffc75aad2435ac6b03059bb6e80.tar.xz
horizon-65f70c4d29fb2ffc75aad2435ac6b03059bb6e80.zip
Add skeleton logic
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt17
1 files changed, 2 insertions, 15 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f14aeb1..ac98dfb 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -10,18 +10,5 @@ pkg_check_modules(LIBUDEV REQUIRED libudev)
pkg_check_modules(PARTED REQUIRED libparted)
find_library(BCNM_LIBRARY REQUIRED wpactrl PATH_SUFFIXES bcnm)
-set(HSCRIPT_SOURCE
- hscript/script.cc
-)
-
-set(HSCRIPT_INCLUDE
- hscript/script.hh
- hscript/key.hh
-)
-
-add_library(hscript SHARED ${HSCRIPT_SOURCE})
-target_compile_features(hscript PRIVATE cxx_nullptr)
-target_compile_features(hscript PUBLIC cxx_unicode_literals)
-
-install(TARGETS hscript DESTINATION lib)
-install(FILES ${HSCRIPT_INCLUDE} DESTINATION include/hscript)
+add_subdirectory(hscript)
+add_subdirectory(tools)