summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-10-31 18:38:43 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-10-31 18:38:43 -0500
commit686e0a9fc307b38e698055ba258a27fd24cec253 (patch)
treea709cc1c61eb85742bf326bd5086a74f9ee28713 /CMakeLists.txt
parent945f0dd29d9d7b188e01ba27419c043bd0357bbb (diff)
downloadhorizon-686e0a9fc307b38e698055ba258a27fd24cec253.tar.gz
horizon-686e0a9fc307b38e698055ba258a27fd24cec253.tar.bz2
horizon-686e0a9fc307b38e698055ba258a27fd24cec253.tar.xz
horizon-686e0a9fc307b38e698055ba258a27fd24cec253.zip
Build: -Wall -Wextra -Werror
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 64904db..b33b88d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -11,6 +11,13 @@ project(Horizon
add_definitions(-DVERSTR="${PROJECT_VERSION}")
+if(MSVC)
+ add_compile_options(/W4 /WX)
+else()
+ add_compile_options(-Wall -Wextra -Werror)
+endif()
+
+
option(BUILD_TOOLS "Enable building of tools (Validator, Simulator, etc)" ON)