summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2020-05-07 21:58:23 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2020-05-07 21:58:23 -0500
commit78e398856a9a8bb929a596aa5b2fa148403d56e4 (patch)
tree9b29a1162d46c6c921e46262cbe7672335cde1de /CMakeLists.txt
parentcd52d492ec08810fa0ba2425d5e01618a2e8741a (diff)
downloadhorizon-78e398856a9a8bb929a596aa5b2fa148403d56e4.tar.gz
horizon-78e398856a9a8bb929a596aa5b2fa148403d56e4.tar.bz2
horizon-78e398856a9a8bb929a596aa5b2fa148403d56e4.tar.xz
horizon-78e398856a9a8bb929a596aa5b2fa148403d56e4.zip
image: Add functional TAR backend
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 76b191c..a12e125 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -18,6 +18,10 @@ else()
-Werror)
endif()
+if(POLICY CMP0100)
+ cmake_policy(SET CMP0100 NEW)
+endif()
+
option(BUILD_TOOLS "Enable building of tools (Validator, Simulator, etc)" ON)
option(BUILD_UI "Enable user interface" ON)
@@ -85,6 +89,16 @@ ELSE(INSTALL)
ENDIF(INSTALL)
+if("cxx_std_17" IN_LIST CMAKE_CXX_COMPILE_FEATURES)
+ SET(FS_LIBRARY stdc++fs)
+ add_definitions(-DFS_IS_STDCXX)
+ELSE()
+ find_package(Boost REQUIRED COMPONENTS filesystem)
+ SET(FS_LIBRARY ${Boost_FILESYSTEM_LIBRARY})
+ add_definitions(-DFS_IS_BOOST)
+ENDIF()
+
+
add_subdirectory(hscript)
add_subdirectory(owner)
IF(BUILD_TOOLS)