summaryrefslogtreecommitdiff
path: root/hscript/CMakeLists.txt
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-10-14 13:37:47 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-10-14 13:37:47 -0500
commit593301e2a40119d4861a6167cf808187ae255035 (patch)
tree4801770626ff589faf36818ffe31ef0999d2febd /hscript/CMakeLists.txt
parentf93285df551fc1c97eb969b37308d673408d86e3 (diff)
downloadhorizon-593301e2a40119d4861a6167cf808187ae255035.tar.gz
horizon-593301e2a40119d4861a6167cf808187ae255035.tar.bz2
horizon-593301e2a40119d4861a6167cf808187ae255035.tar.xz
horizon-593301e2a40119d4861a6167cf808187ae255035.zip
hscript: Implement Mount::execute fully, including fstab manipulation
Diffstat (limited to 'hscript/CMakeLists.txt')
-rw-r--r--hscript/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/hscript/CMakeLists.txt b/hscript/CMakeLists.txt
index 845ee82..60ca8a9 100644
--- a/hscript/CMakeLists.txt
+++ b/hscript/CMakeLists.txt
@@ -15,6 +15,7 @@ set(HSCRIPT_INCLUDE
add_library(hscript SHARED ${HSCRIPT_SOURCE})
target_compile_features(hscript PRIVATE cxx_nullptr)
target_compile_features(hscript PUBLIC cxx_unicode_literals)
+target_link_libraries(hscript ${BLKID_LIBRARIES})
install(TARGETS hscript DESTINATION lib)
install(FILES ${HSCRIPT_INCLUDE} DESTINATION include/hscript)