summaryrefslogtreecommitdiff
path: root/hscript/CMakeLists.txt
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-10-06 13:46:57 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-10-06 13:46:57 -0500
commit65f70c4d29fb2ffc75aad2435ac6b03059bb6e80 (patch)
treefe78d655b3c918eedb7bc834d1daa281ef0f8430 /hscript/CMakeLists.txt
parent600ced25919b7b0d00cad5c7b5d805b549d8c3ed (diff)
downloadhorizon-65f70c4d29fb2ffc75aad2435ac6b03059bb6e80.tar.gz
horizon-65f70c4d29fb2ffc75aad2435ac6b03059bb6e80.tar.bz2
horizon-65f70c4d29fb2ffc75aad2435ac6b03059bb6e80.tar.xz
horizon-65f70c4d29fb2ffc75aad2435ac6b03059bb6e80.zip
Add skeleton logic
Diffstat (limited to 'hscript/CMakeLists.txt')
-rw-r--r--hscript/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/hscript/CMakeLists.txt b/hscript/CMakeLists.txt
new file mode 100644
index 0000000..da5ce1b
--- /dev/null
+++ b/hscript/CMakeLists.txt
@@ -0,0 +1,15 @@
+set(HSCRIPT_SOURCE
+ script.cc
+)
+
+set(HSCRIPT_INCLUDE
+ script.hh
+ key.hh
+)
+
+add_library(hscript SHARED ${HSCRIPT_SOURCE})
+target_compile_features(hscript PRIVATE cxx_nullptr)
+target_compile_features(hscript PUBLIC cxx_unicode_literals)
+
+install(TARGETS hscript DESTINATION lib)
+install(FILES ${HSCRIPT_INCLUDE} DESTINATION include/hscript)