summaryrefslogtreecommitdiff
path: root/image/CMakeLists.txt
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2020-05-28 10:05:23 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2020-05-28 10:05:23 -0500
commit30b9f32d7a544f50f5e06ef930525d620a028db1 (patch)
tree1c5ba88d16c0fb8d8801e5329251700583754e4e /image/CMakeLists.txt
parenta52fcf56f737c6fc962c12efad1b637521cc5685 (diff)
downloadhorizon-30b9f32d7a544f50f5e06ef930525d620a028db1.tar.gz
horizon-30b9f32d7a544f50f5e06ef930525d620a028db1.tar.bz2
horizon-30b9f32d7a544f50f5e06ef930525d620a028db1.tar.xz
horizon-30b9f32d7a544f50f5e06ef930525d620a028db1.zip
image: Put target inside ir_dir, add WIP ISO backend
ir_dir used to be the target; now the target is inside ir_dir so backends have the choice of making other directories inside ir_dir if needed.
Diffstat (limited to 'image/CMakeLists.txt')
-rw-r--r--image/CMakeLists.txt13
1 files changed, 10 insertions, 3 deletions
diff --git a/image/CMakeLists.txt b/image/CMakeLists.txt
index ea0a3ed..58b5eef 100644
--- a/image/CMakeLists.txt
+++ b/image/CMakeLists.txt
@@ -1,12 +1,19 @@
-find_package(Boost REQUIRED COMPONENTS program_options)
-include_directories(${Boost_INCLUDE_DIR})
-
add_subdirectory(backends)
set(IMG_SRCS
creator.cc
)
add_executable(hscript-image ${IMG_SRCS})
+
+if("cxx_std_17" IN_LIST CMAKE_CXX_COMPILE_FEATURES)
+ find_package(Boost REQUIRED COMPONENTS program_options)
+ set_property(TARGET hscript-image PROPERTY CXX_STANDARD 17)
+else()
+ find_package(Boost REQUIRED COMPONENTS filesystem program_options)
+endif()
+
+include_directories(${Boost_INCLUDE_DIR})
+
target_link_libraries(hscript-image hscript hi-backends ${Boost_LIBRARIES})
install(TARGETS hscript-image DESTINATION bin)
install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/creator.1 DESTINATION share/man/man1 RENAME hscript-image.1)