summaryrefslogtreecommitdiff
path: root/ui/qt5/CMakeLists.txt
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-06 04:49:30 -0600
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-06 04:49:30 -0600
commitd3728b38b12b2f9762ba26fc6fc302cb79f7ee6c (patch)
tree3c0d47166a89110fa504aa1557f69de6e89073bc /ui/qt5/CMakeLists.txt
parentd71a5c29f6d22d2fb18bd483333eaf37b827fd0d (diff)
downloadhorizon-d3728b38b12b2f9762ba26fc6fc302cb79f7ee6c.tar.gz
horizon-d3728b38b12b2f9762ba26fc6fc302cb79f7ee6c.tar.bz2
horizon-d3728b38b12b2f9762ba26fc6fc302cb79f7ee6c.tar.xz
horizon-d3728b38b12b2f9762ba26fc6fc302cb79f7ee6c.zip
Qt UI: Implement UI.Writeout and UI.Commit requirements
Diffstat (limited to 'ui/qt5/CMakeLists.txt')
-rw-r--r--ui/qt5/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/ui/qt5/CMakeLists.txt b/ui/qt5/CMakeLists.txt
index 7fd1ebf..14d5399 100644
--- a/ui/qt5/CMakeLists.txt
+++ b/ui/qt5/CMakeLists.txt
@@ -25,6 +25,12 @@ set(UI_SOURCES
horizon.qrc)
+IF(INSTALL)
+ LIST(APPEND UI_SOURCES commitpage.cc)
+ELSE(INSTALL)
+ LIST(APPEND UI_SOURCES writeoutpage.cc)
+ENDIF(INSTALL)
+
IF(UNSUPPORTED_NONFREE_FIRMWARE)
LIST(APPEND UI_SOURCES firmwarepage.cc)
ENDIF(UNSUPPORTED_NONFREE_FIRMWARE)