summaryrefslogtreecommitdiff
path: root/ui/qt5/CMakeLists.txt
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2023-12-09 21:37:47 -0600
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2023-12-09 21:37:47 -0600
commite415fc62b02d416dae39f2d53765ca839abca419 (patch)
tree83e56661e87462a387e075b69e678d4c05d67a2b /ui/qt5/CMakeLists.txt
parent9f971cc0aedae6c89052bedc684245fc8c893cdf (diff)
downloadhorizon-e415fc62b02d416dae39f2d53765ca839abca419.tar.gz
horizon-e415fc62b02d416dae39f2d53765ca839abca419.tar.bz2
horizon-e415fc62b02d416dae39f2d53765ca839abca419.tar.xz
horizon-e415fc62b02d416dae39f2d53765ca839abca419.zip
Qt UI: Runner: Use specialised QProcess subclass
This allows us to set the uid/gid in the executor process so that APK inherits full root, which prevents a weird error that causes APK Tools to write out all files as owned by the live user's GID when run under live media.
Diffstat (limited to 'ui/qt5/CMakeLists.txt')
-rw-r--r--ui/qt5/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/ui/qt5/CMakeLists.txt b/ui/qt5/CMakeLists.txt
index 086abc7..74b9c68 100644
--- a/ui/qt5/CMakeLists.txt
+++ b/ui/qt5/CMakeLists.txt
@@ -44,6 +44,7 @@ set(RUN_QT_SOURCES
horizonwizardpage.cc
stepprogresswidget.cc
runner/main.cc
+ runner/executorprocess.cc
runner/executorwizard.cc
runner/executepage.cc
runner/errorpage.cc