summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt18
1 files changed, 11 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c423185..0345603 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -53,6 +53,15 @@ IF(NOT HAVE_LINUX_WIRELESS_H)
SET(INSTALL OFF)
ENDIF(NOT HAVE_LINUX_WIRELESS_H)
+
+include_directories(.)
+
+
+## Test stuff ##
+find_program(RSPEC_EXECUTABLE NAMES rspec)
+enable_testing()
+
+
IF(INSTALL)
add_definitions(-DHAS_INSTALL_ENV)
pkg_check_modules(BLKID REQUIRED blkid)
@@ -60,18 +69,13 @@ IF(INSTALL)
pkg_check_modules(PARTED REQUIRED libparted)
find_library(BCNM_LIBRARY REQUIRED wpactrl PATH_SUFFIXES bcnm)
set(BUILD_SHARED_LIBS ON)
+
+ add_subdirectory(executor)
ELSE(INSTALL)
set(BUILD_SHARED_LIBS OFF)
ENDIF(INSTALL)
-include_directories(.)
-
-
-## Test stuff ##
-find_program(RSPEC_EXECUTABLE NAMES rspec)
-enable_testing()
-
add_subdirectory(hscript)
IF(BUILD_TOOLS)
add_subdirectory(tools)