summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f274671..9626fde 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -93,7 +93,7 @@ IF(COVERAGE)
COMMAND lcov ARGS --exclude '/usr/include/boost/*' --exclude '/usr/include/c++/*' --exclude '*/3rdparty/*' --rc lcov_branch_coverage=1 --capture --directory ${CMAKE_BINARY_DIR} --output-file horizon.coverage)
add_custom_target(lcov_report DEPENDS horizon.coverage)
add_custom_command(OUTPUT cov_html
- COMMAND genhtml ARGS horizon.coverage --output-directory cov_html)
+ COMMAND genhtml ARGS horizon.coverage --rc lcov_branch_coverage=1 --output-directory cov_html)
add_custom_target(lcov_html DEPENDS cov_html)
ENDIF(LCOV_EXECUTABLE)
ENDIF(COVERAGE)