summaryrefslogtreecommitdiff
path: root/image/backends/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'image/backends/CMakeLists.txt')
-rw-r--r--image/backends/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/image/backends/CMakeLists.txt b/image/backends/CMakeLists.txt
index 325fddf..790895e 100644
--- a/image/backends/CMakeLists.txt
+++ b/image/backends/CMakeLists.txt
@@ -1,6 +1,5 @@
set(BACKEND_SRCS
basic.cc
- iso.cc
)
set(BACKEND_LIBS "")
@@ -12,6 +11,10 @@ if(LibArchive_FOUND)
list(APPEND BACKEND_LIBS ${LibArchive_LIBRARIES})
endif()
+if(BUILD_ISO)
+ list(APPEND BACKEND_SRCS iso.cc)
+endif(BUILD_ISO)
+
add_library(hi-backends ${BACKEND_SRCS})
target_link_libraries(hi-backends ${BACKEND_LIBS})
install(TARGETS hi-backends DESTINATION lib)