summaryrefslogtreecommitdiff
path: root/ui/qt5/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'ui/qt5/CMakeLists.txt')
-rw-r--r--ui/qt5/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/ui/qt5/CMakeLists.txt b/ui/qt5/CMakeLists.txt
index 38ede75..0dd441b 100644
--- a/ui/qt5/CMakeLists.txt
+++ b/ui/qt5/CMakeLists.txt
@@ -8,6 +8,7 @@ set(UI_SOURCES
main.cc
intropage.cc
+ inputpage.cc
networkingpage.cc
horizon.qrc)
@@ -17,5 +18,8 @@ target_link_libraries(horizon-qt5 Qt5::Widgets)
install(TARGETS horizon-qt5 DESTINATION bin)
IF(INSTALL)
+ pkg_check_modules(XKBFile REQUIRED xkbfile)
+ pkg_check_modules(LIBX11 REQUIRED x11)
+ target_link_libraries(horizon-qt5 ${LIBX11_LIBRARIES} ${XKBFile_LIBRARIES})
# add_executable(horizon-run-qt5 ${RUN_QT_SOURCES})
ENDIF(INSTALL)