summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKonstantin <ria_freelander@gmail.com>2016-06-13 21:37:24 +0300
committerKonstantin <ria_freelander@gmail.com>2016-06-13 21:37:24 +0300
commitc786c7c44a12c04b248376f04679f2f80c0d0d02 (patch)
treeccd0783d62f36dbbab12922874bbd9c71d37f64e /CMakeLists.txt
parent902e80b2d4cbe64ce4703c8ac0f5f7403774f064 (diff)
downloadmusl-locales-c786c7c44a12c04b248376f04679f2f80c0d0d02.tar.gz
musl-locales-c786c7c44a12c04b248376f04679f2f80c0d0d02.tar.bz2
musl-locales-c786c7c44a12c04b248376f04679f2f80c0d0d02.tar.xz
musl-locales-c786c7c44a12c04b248376f04679f2f80c0d0d02.zip
Raspberry fixes
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 7 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8ada96e..b188ad3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2,13 +2,17 @@ project(locales C)
cmake_minimum_required(VERSION 2.8)
include(GNUInstallDirs)
list (APPEND CMAKE_MODULE_PATH ${CMAKE_SOURCE_DIR}/cmake)
-configure_file(config.h.in config.h)
-configure_file(locale.in 00locale.sh)
INCLUDE_DIRECTORIES(${CMAKE_BINARY_DIR})
set(GETTEXT_PACKAGE "musl-locales")
set(MUSL_LOCPATH ${CMAKE_INSTALL_DATAROOTDIR}/i18n/locales/musl CACHE PATH "Locales directory" FORCE)
+configure_file(config.h.in config.h)
+configure_file(locale.in 00locale.sh)
set(LOCALE_SOURCES locale.c categories.c categories.h config.h)
add_executable(locale ${LOCALE_SOURCES})
-install(PROGRAMS 00locale.sh DESTINATION "${CMAKE_INSTALL_SYSCONFDIR}/profile.d")
+target_compile_options(locale
+ PRIVATE $<$<COMPILE_LANGUAGE:C>:-std=gnu11 -Wno-pedantic>
+)
+install(PROGRAMS ${CMAKE_BINARY_DIR}/00locale.sh DESTINATION "${CMAKE_INSTALL_SYSCONFDIR}/profile.d")
install(TARGETS locale DESTINATION bin)
add_subdirectory(po)
+add_subdirectory(musl-po)