summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKonstantin <ria.freelander@gmail.com>2018-01-11 00:58:52 +0300
committerKonstantin <ria.freelander@gmail.com>2018-01-11 00:58:52 +0300
commitdc4f328f872734fdd0c9b2544bbd1bc8623598d0 (patch)
tree39ba2b4efada5857861f02ede31bc58604a87ab4 /CMakeLists.txt
parentece43173b48483498b4a08b7a1711e29de39d65d (diff)
downloadmusl-locales-dc4f328f872734fdd0c9b2544bbd1bc8623598d0.tar.gz
musl-locales-dc4f328f872734fdd0c9b2544bbd1bc8623598d0.tar.bz2
musl-locales-dc4f328f872734fdd0c9b2544bbd1bc8623598d0.tar.xz
musl-locales-dc4f328f872734fdd0c9b2544bbd1bc8623598d0.zip
Fixed Alpine build
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d78453c..c393c5f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -4,7 +4,7 @@ include(GNUInstallDirs)
list (APPEND CMAKE_MODULE_PATH ${CMAKE_SOURCE_DIR}/cmake)
INCLUDE_DIRECTORIES(${CMAKE_BINARY_DIR})
set(GETTEXT_PACKAGE "musl-locales")
-set(MUSL_LOCPATH ${CMAKE_INSTALL_DATAROOTDIR}/i18n/locales/musl CACHE PATH "Locales directory" FORCE)
+set(MUSL_LOCPATH i18n/locales/musl CACHE PATH "Locales directory" FORCE)
configure_file(config.h.in config.h)
configure_file(locale.in 00locale.sh)
find_package(Intl)
@@ -16,7 +16,8 @@ endif()
target_compile_options(locale
PRIVATE $<$<COMPILE_LANGUAGE:C>:-std=gnu11 -Wno-pedantic>
)
-install(PROGRAMS ${CMAKE_BINARY_DIR}/00locale.sh DESTINATION "${CMAKE_INSTALL_SYSCONFDIR}/profile.d")
+install(PROGRAMS ${CMAKE_BINARY_DIR}/00locale.sh DESTINATION
+"${CMAKE_INSTALL_FULL_SYSCONFDIR}/profile.d")
install(TARGETS locale DESTINATION bin)
add_subdirectory(po)
add_subdirectory(musl-po)