summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2022-11-06 01:09:41 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2022-11-06 01:09:41 +0000
commit67b1f606ab04eb7d847d9a7e81d30b9c26dd2b98 (patch)
treeed0ad4b72b5a5eb1f619c233155b62c0219a2a8c
parentc5b882546f831beffaec290c7b5c6ee3b4efc258 (diff)
downloadpackages-zv/openjdk-bootstrap.tar.gz
packages-zv/openjdk-bootstrap.tar.bz2
packages-zv/openjdk-bootstrap.tar.xz
packages-zv/openjdk-bootstrap.zip
user/openjdk7: Progresszv/openjdk-bootstrap
-rw-r--r--user/openjdk7/APKBUILD38
-rw-r--r--user/openjdk7/icedtea-hotspot-kernel.patch13
-rw-r--r--user/openjdk7/icedtea-hotspot-uclibc-fixes.patch2
3 files changed, 34 insertions, 19 deletions
diff --git a/user/openjdk7/APKBUILD b/user/openjdk7/APKBUILD
index 3fa9af806..d2f2f462d 100644
--- a/user/openjdk7/APKBUILD
+++ b/user/openjdk7/APKBUILD
@@ -3,10 +3,10 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: Zach van Rijn <me@zv.io>
pkgname=openjdk7
-# pkgver is <JDK version>.<JDK update>
-pkgver=7.201.$_icedteaver
# Check https://icedtea.classpath.org/download/source/ when updating
_icedteaver=2.6.16
+# pkgver is <JDK version>.<JDK update>
+pkgver=7.201.$_icedteaver
pkgrel=0
pkgdesc="OpenJDK 7 via IcedTea"
url="https://icedtea.classpath.org/"
@@ -21,8 +21,7 @@ _gccver=6.4.0
_gccmaj=${_gccver%%.*}
_ecjver=4.9
makedepends_gcc="bison flex linux-headers texinfo zip
- gmp-dev mpfr-dev mpc1-dev isl-dev zlib-dev libucontext-dev
- libart-lgpl-dev
+ gmp-dev mpfr-dev mpc1-dev isl-dev zlib-dev libart-lgpl-dev
"
makedepends="bash findutils zip file mawk util-linux libxslt
@@ -32,8 +31,7 @@ makedepends="bash findutils zip file mawk util-linux libxslt
lcms2-dev libxp-dev libxtst-dev libxinerama-dev zlib-dev
libxrender-dev alsa-lib-dev freetype-dev fontconfig-dev
gtk+2.0-dev krb5-dev attr-dev pcsc-lite-dev lksctp-tools-dev
- libxcomposite-dev nss-static cmd:wget
- unzip
+ libxcomposite-dev nss-static unzip zip
$makedepends_gcc
"
@@ -74,7 +72,6 @@ subpackages="$pkgname-jre-lib:jrelib:noarch $pkgname-jre $pkgname-jre-base:jreba
$pkgname-doc:doc"
BOOTSTRAP_JAVA_HOME="$_jvmdir"
-_bootstrap_java_home="$srcdir/gcc-$_gccver/usr/share/java"
_dropsver=$_icedteaver
_dropsurl=https://icedtea.classpath.org/download/drops/icedtea7/$_dropsver
@@ -145,6 +142,7 @@ source="https://icedtea.classpath.org/download/source/icedtea-$_icedteaver.tar.g
https://archive.apache.org/dist/ant/binaries/apache-ant-$ANT_VER-bin.tar.gz
https://github.com/mozilla/rhino/releases/download/Rhino${_RHINO_VER}_Release/rhino-$RHINO_VER.zip
+ icedtea-hotspot-kernel.patch
icedtea-hotspot-musl.patch
icedtea-hotspot-musl-ppc.patch
icedtea-hotspot-noagent-musl.patch
@@ -176,13 +174,6 @@ srcdir_gcc="${srcdir}_gcc"
STRIP_FOR_TARGET=${CROSS_COMPILE}strip
-: ${LANG_CXX:=true}
-: ${LANG_OBJC:=false}
-: ${LANG_JAVA:=true}
-: ${LANG_GO:=false}
-: ${LANG_FORTRAN:=false}
-: ${LANG_ADA:=false}
-
LIBGCC=true
LIBATOMIC=true
LIBITM=true
@@ -275,7 +266,7 @@ prepare() {
}
build_gcc() {
- mkdir "$_gccdir"/build
+ mkdir -p "$_gccdir"/build
cd "$_gccdir"/build
local _arch_configure=
@@ -381,6 +372,16 @@ build_gcc() {
# ephemeral (only used for openjdk build)
make -j1 install
cp "$_gccdir"/build/$CTARGET/libjava/scripts/jar "$srcdir"/gcc-$_gccver/usr/bin
+
+
+ # from java-gcj-compat
+ cd "$srcdir"/gcc-$_gccver/usr/bin
+ GCC_LIB_PATH="$srcdir"/gcc-$_gccver/usr/lib
+ ./gcj -Wl,-Bsymbolic -findirect-dispatch \
+ -o "$srcdir"/gcc-$_gccver$_jvmdir/bin/javac \
+ --main=org.eclipse.jdt.internal.compiler.batch.Main \
+ "$srcdir_gcc"/gcc-$_gccver/ecj.jar -Wl,-rpath,"$GCC_LIB_PATH" \
+ -lgcj
}
build() {
@@ -396,7 +397,7 @@ build() {
export HOTSPOT_BUILD_JOBS="${JOBS:-2}"
export JAVA_HOME=$BOOTSTRAP_JAVA_HOME
- export ANT_HOME="$srcdir"/gcc-$_gccver/usr
+ export ANT_HOME="$srcdir"/apache-ant-$ANT_VER
export PATH=$JAVA_HOME/bin:$srcdir/apache-ant-$ANT_VER/bin:$PATH
export DISTRIBUTION_PATCHES=""
@@ -452,7 +453,7 @@ build() {
msg "Icedtea boot"
make -j1 icedtea-boot SHELL=/bin/bash USRBIN_PATH=/bin/
msg "Icedtea boot done"
- make
+ make USRBIN_PATH=/bin/
}
package() {
@@ -529,10 +530,11 @@ ee2443da63ab6b1a525d0633a577f28d28d3916cb47b312d61d71b4795ae3bde4a70478017b76391
73b0338ec293d0d87cc7251f63ef453ec10c7de978c56d8ff455b16ee0506175aed681a9a95fbdcc8b747ba00ef6cf914f63d0c5d22268b40620d4dbc7390a98 hotspot-2.6.16.tar.bz2
0da12cb0f761b8cb76e042449e7d93f43236e7bc948e337215470a70031f0a2dda6d1b508f9397b283808d84c4ebddb31558fe1cd8e6e6469c1dd390d69ec6e7 apache-ant-1.9.11-bin.tar.gz
1b9e8721749e81c5420a00af1e00ee0e4f48624ccb4e9aa969032114116ad50f59b254d4d16d74feff74de64157cc8b0a2ead9b555907c84b7055b796fba9a75 rhino-1.7.7.2.zip
+5cfe2ed790ac41e50c80a61e29456d220fae726d86e405d13c597c9ebd444856f5cf57a7a817d0d8a95881febae7da62deea4dec900446155047d48cfb211ae5 icedtea-hotspot-kernel.patch
f62b942f0bacda8e37d0f1876d8ba14ddb4fc55a7d5fd1019463744927f40f422a85e9ee051948d566242f5a785aa28f275eb58768611283cba89af91235f43c icedtea-hotspot-musl.patch
e5cf4d70f96fc1e72ae8b97a887adb96092ff36584711cbb8de9d9fa9e859cb8731d638838de0d9591239fc44ffe5c74422d1842bd9f10a0c00dff1627bdeeef icedtea-hotspot-musl-ppc.patch
e7a2c1771bb582d427041f8d22e48c0daf8f20d7c0926cbce3549d49c4e949359ee25a35682b486e82f3e390535c950c5beee3bd8d06fb5a717b50f2d9b2a6bc icedtea-hotspot-noagent-musl.patch
-822eee0dc4d3ba677a289dfeb3668b536d2d626708390a9d9702fb4144a481fd443a215a0d2041c6026113837aafa4ba0b5e9ead8589d2da6717a238bbc95a5a icedtea-hotspot-uclibc-fixes.patch
+c05634d147fb9400b63b86e1266286c8bc695fc7d30baa479945f0f834b42b62c2430ed0a261db41c66222204dc933049373ad2e37d11d9a8ecf3845d6a73cd8 icedtea-hotspot-uclibc-fixes.patch
213a537de5f011cb39d608515c3413513ac75fb93593f9a9ef4205f71d72bdd8b097c80db185f7b26021d5bb85045b866f34f3478482dc4189972d8614a13458 icedtea-jdk-fix-build.patch
0391970e6a32946aa3cccf38fdef9c0fe2af26cd0df824b98aa2fcfa1bf661d4a68e339bffcfd16f386c565fc68bb28a29208a67d4bad8a0e847ad02bd8becbb icedtea-jdk-execinfo.patch
48533f87fc2cf29d26b259be0df51087d2fe5b252e72d00c6ea2f4add7b0fb113141718c116279c5905e03f64a1118082e719393786811367cf4d472b5d36774 icedtea-jdk-fix-ipv6-init.patch
diff --git a/user/openjdk7/icedtea-hotspot-kernel.patch b/user/openjdk7/icedtea-hotspot-kernel.patch
new file mode 100644
index 000000000..d0ae5e65a
--- /dev/null
+++ b/user/openjdk7/icedtea-hotspot-kernel.patch
@@ -0,0 +1,13 @@
+Support builds on kernels newer than 4.x.
+
+--- openjdk/hotspot/make/linux/Makefile.old 2018-10-22 05:22:56.000000000 +0000
++++ openjdk/hotspot/make/linux/Makefile 2022-11-06 00:08:29.914187713 +0000
+@@ -255,7 +255,7 @@
+ # Solaris 2.5.1, 2.6).
+ # Disable this check by setting DISABLE_HOTSPOT_OS_VERSION_CHECK=ok.
+
+-SUPPORTED_OS_VERSION = 2.4% 2.5% 2.6% 3% 4%
++SUPPORTED_OS_VERSION = 2.4% 2.5% 2.6% 3% 4% 5% 6%
+ OS_VERSION := $(shell uname -r)
+ EMPTY_IF_NOT_SUPPORTED = $(filter $(SUPPORTED_OS_VERSION),$(OS_VERSION))
+
diff --git a/user/openjdk7/icedtea-hotspot-uclibc-fixes.patch b/user/openjdk7/icedtea-hotspot-uclibc-fixes.patch
index 1c1d82276..c223d30ef 100644
--- a/user/openjdk7/icedtea-hotspot-uclibc-fixes.patch
+++ b/user/openjdk7/icedtea-hotspot-uclibc-fixes.patch
@@ -13,7 +13,7 @@
void os::Linux::libpthread_init() {
+#if 1
-+ // Hard code Alpine Linux supported uclibc/musl compatible settings
++ // Hard code musl compatible settings
+ os::Linux::set_glibc_version("glibc 2.9");
+ os::Linux::set_libpthread_version("NPTL");
+ os::Linux::set_is_NPTL();