summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSíle Ekaterin Liszka <sheila@vulpine.house>2024-03-19 20:29:11 -0700
committerZach van Rijn <me@zv.io>2024-03-20 04:39:06 +0000
commit2af53f4069234e77dc6d5900fbc5eb7d2634a854 (patch)
tree916745b65bd5b6e94e13bdd36770a1025245c0fd
parent058ee486d9487733feb39fa8fd18a8ab21b3588e (diff)
downloadpackages-2af53f4069234e77dc6d5900fbc5eb7d2634a854.tar.gz
packages-2af53f4069234e77dc6d5900fbc5eb7d2634a854.tar.bz2
packages-2af53f4069234e77dc6d5900fbc5eb7d2634a854.tar.xz
packages-2af53f4069234e77dc6d5900fbc5eb7d2634a854.zip
user/fish: remove a problematic test
tests/checks/check-completions.fish is intended to see if completions work for all completions which have a working command to generate them. this is fragile and fails if a command exists but returns nonzero.
-rw-r--r--user/fish/APKBUILD5
1 files changed, 5 insertions, 0 deletions
diff --git a/user/fish/APKBUILD b/user/fish/APKBUILD
index 09e2d3de0..0544bd24b 100644
--- a/user/fish/APKBUILD
+++ b/user/fish/APKBUILD
@@ -15,6 +15,11 @@ install="$pkgname.post-install $pkgname.post-upgrade $pkgname.pre-deinstall"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang $pkgname-tools::noarch"
source="https://github.com/fish-shell/fish-shell/releases/download/$pkgver/$pkgname-$pkgver.tar.xz"
+prepare() {
+ default_prepare
+ rm tests/checks/check-completions.fish
+}
+
build() {
cmake \
-DCMAKE_INSTALL_PREFIX=/usr \