summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZach van Rijn <me@zv.io>2024-09-01 05:04:01 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2024-10-17 00:58:49 -0500
commit2f6e4b9caf98ecd5025e6f2fd7dbfb15b515a358 (patch)
tree24617227f91b873d3e3b2862300059b6a03e6ad3
parent62fafef7749dd7c1d07c73afc240ca3edd087770 (diff)
downloadpackages-2f6e4b9caf98ecd5025e6f2fd7dbfb15b515a358.tar.gz
packages-2f6e4b9caf98ecd5025e6f2fd7dbfb15b515a358.tar.bz2
packages-2f6e4b9caf98ecd5025e6f2fd7dbfb15b515a358.tar.xz
packages-2f6e4b9caf98ecd5025e6f2fd7dbfb15b515a358.zip
bootstrap/rust-1.7x: Reduce debug information
This still provides debug information, but prevents runaway memory usage which was causing 32-bit builders to fail. Closes: #1249
-rw-r--r--bootstrap/rust-1.70/APKBUILD2
-rw-r--r--bootstrap/rust-1.71/APKBUILD2
-rw-r--r--bootstrap/rust-1.72/APKBUILD2
-rw-r--r--bootstrap/rust-1.73/APKBUILD2
-rw-r--r--bootstrap/rust-1.74/APKBUILD2
-rw-r--r--bootstrap/rust-1.75/APKBUILD2
-rw-r--r--bootstrap/rust-1.76/APKBUILD2
-rw-r--r--bootstrap/rust-1.77/APKBUILD2
-rw-r--r--bootstrap/rust-1.78/APKBUILD2
-rw-r--r--bootstrap/rust-1.79/APKBUILD2
10 files changed, 10 insertions, 10 deletions
diff --git a/bootstrap/rust-1.70/APKBUILD b/bootstrap/rust-1.70/APKBUILD
index 1e9ea02a0..39864083a 100644
--- a/bootstrap/rust-1.70/APKBUILD
+++ b/bootstrap/rust-1.70/APKBUILD
@@ -88,7 +88,7 @@ build() {
optimize = true
debug = false
codegen-units = 1
- debuginfo-level = 2
+ debuginfo-level = 1
debuginfo-level-rustc = 0
debuginfo-level-tests = 0
backtrace = true
diff --git a/bootstrap/rust-1.71/APKBUILD b/bootstrap/rust-1.71/APKBUILD
index 456ca69a7..d230bd3fa 100644
--- a/bootstrap/rust-1.71/APKBUILD
+++ b/bootstrap/rust-1.71/APKBUILD
@@ -89,7 +89,7 @@ build() {
optimize = true
debug = false
codegen-units = 1
- debuginfo-level = 2
+ debuginfo-level = 1
debuginfo-level-rustc = 0
debuginfo-level-tests = 0
backtrace = true
diff --git a/bootstrap/rust-1.72/APKBUILD b/bootstrap/rust-1.72/APKBUILD
index 862ce6d73..d813c66d7 100644
--- a/bootstrap/rust-1.72/APKBUILD
+++ b/bootstrap/rust-1.72/APKBUILD
@@ -90,7 +90,7 @@ build() {
optimize = true
debug = false
codegen-units = 1
- debuginfo-level = 2
+ debuginfo-level = 1
debuginfo-level-rustc = 0
debuginfo-level-tests = 0
backtrace = true
diff --git a/bootstrap/rust-1.73/APKBUILD b/bootstrap/rust-1.73/APKBUILD
index 2fd72f256..4255d811c 100644
--- a/bootstrap/rust-1.73/APKBUILD
+++ b/bootstrap/rust-1.73/APKBUILD
@@ -90,7 +90,7 @@ build() {
optimize = true
debug = false
codegen-units = 1
- debuginfo-level = 2
+ debuginfo-level = 1
debuginfo-level-rustc = 0
debuginfo-level-tests = 0
backtrace = true
diff --git a/bootstrap/rust-1.74/APKBUILD b/bootstrap/rust-1.74/APKBUILD
index 03a533699..95c05353a 100644
--- a/bootstrap/rust-1.74/APKBUILD
+++ b/bootstrap/rust-1.74/APKBUILD
@@ -89,7 +89,7 @@ build() {
optimize = true
debug = false
codegen-units = 1
- debuginfo-level = 2
+ debuginfo-level = 1
debuginfo-level-rustc = 0
debuginfo-level-tests = 0
backtrace = true
diff --git a/bootstrap/rust-1.75/APKBUILD b/bootstrap/rust-1.75/APKBUILD
index 29f97ed75..1114c05e4 100644
--- a/bootstrap/rust-1.75/APKBUILD
+++ b/bootstrap/rust-1.75/APKBUILD
@@ -88,7 +88,7 @@ build() {
optimize = true
debug = false
codegen-units = 1
- debuginfo-level = 2
+ debuginfo-level = 1
debuginfo-level-rustc = 0
debuginfo-level-tests = 0
backtrace = true
diff --git a/bootstrap/rust-1.76/APKBUILD b/bootstrap/rust-1.76/APKBUILD
index 0289ab363..8624d194e 100644
--- a/bootstrap/rust-1.76/APKBUILD
+++ b/bootstrap/rust-1.76/APKBUILD
@@ -87,7 +87,7 @@ build() {
optimize = true
debug = false
codegen-units = 1
- debuginfo-level = 2
+ debuginfo-level = 1
debuginfo-level-rustc = 0
debuginfo-level-tests = 0
backtrace = true
diff --git a/bootstrap/rust-1.77/APKBUILD b/bootstrap/rust-1.77/APKBUILD
index 13a44c393..12028e6b6 100644
--- a/bootstrap/rust-1.77/APKBUILD
+++ b/bootstrap/rust-1.77/APKBUILD
@@ -87,7 +87,7 @@ build() {
optimize = true
debug = false
codegen-units = 1
- debuginfo-level = 2
+ debuginfo-level = 1
debuginfo-level-rustc = 0
debuginfo-level-tests = 0
backtrace = true
diff --git a/bootstrap/rust-1.78/APKBUILD b/bootstrap/rust-1.78/APKBUILD
index b22288f10..a35db178f 100644
--- a/bootstrap/rust-1.78/APKBUILD
+++ b/bootstrap/rust-1.78/APKBUILD
@@ -87,7 +87,7 @@ build() {
optimize = true
debug = false
codegen-units = 1
- debuginfo-level = 2
+ debuginfo-level = 1
debuginfo-level-rustc = 0
debuginfo-level-tests = 0
backtrace = true
diff --git a/bootstrap/rust-1.79/APKBUILD b/bootstrap/rust-1.79/APKBUILD
index 9da308742..59cd26715 100644
--- a/bootstrap/rust-1.79/APKBUILD
+++ b/bootstrap/rust-1.79/APKBUILD
@@ -86,7 +86,7 @@ build() {
optimize = true
debug = false
codegen-units = 1
- debuginfo-level = 2
+ debuginfo-level = 1
debuginfo-level-rustc = 0
debuginfo-level-tests = 0
backtrace = true