summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2022-06-12 17:14:16 -0500
committerZach van Rijn <me@zv.io>2022-10-21 18:34:01 -0500
commit6bf730941205e61bf6d7ff9d4fe4bc5594e67a11 (patch)
tree7bac7b306eac1ec027bf6cb72785dc2985dc7fb0
parent73f8ae93e7e9df25876d730914e080a727c62476 (diff)
downloadpackages-6bf730941205e61bf6d7ff9d4fe4bc5594e67a11.tar.gz
packages-6bf730941205e61bf6d7ff9d4fe4bc5594e67a11.tar.bz2
packages-6bf730941205e61bf6d7ff9d4fe4bc5594e67a11.tar.xz
packages-6bf730941205e61bf6d7ff9d4fe4bc5594e67a11.zip
user/[KDE Partition Manager]: Update to 22.04.2
-rw-r--r--user/kpmcore/APKBUILD11
-rw-r--r--user/kpmcore/filesystem.patch10
-rw-r--r--user/kpmcore/test.patch42
-rw-r--r--user/partitionmanager/APKBUILD6
4 files changed, 63 insertions, 6 deletions
diff --git a/user/kpmcore/APKBUILD b/user/kpmcore/APKBUILD
index ea16d434f..eb401b59c 100644
--- a/user/kpmcore/APKBUILD
+++ b/user/kpmcore/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=kpmcore
-pkgver=4.1.0
+pkgver=22.04.2
pkgrel=0
pkgdesc="Core routines for KDE Partition Manager"
url="https://www.kde.org/applications/system/partitionmanager"
@@ -12,7 +12,10 @@ depends_dev="libatasmart-dev parted-dev qt5-qtbase-dev"
makedepends="$depends_dev cmake extra-cmake-modules kcoreaddons-dev ki18n-dev
kwidgetsaddons-dev util-linux-dev kauth-dev qca-dev"
subpackages="$pkgname-dev $pkgname-lang"
-source="https://download.kde.org/stable/kpmcore/$pkgver/src/kpmcore-$pkgver.tar.xz"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kpmcore-$pkgver.tar.xz
+ filesystem.patch
+ test.patch
+ "
build() {
if [ "$CBUILD" != "$CHOST" ]; then
@@ -37,4 +40,6 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="c45b31a41c62a68aee991be0f7954f4bd2136660578cc60f7fa6f05e56716458421e16cd314b3b9a14b56fdc9377db511c1645e5c41f0446d86a8ac5bb66c273 kpmcore-4.1.0.tar.xz"
+sha512sums="3ce043daccbe5a2d56f6fd849a3b8c6518b49c4c47db1989f7cea60282e63f430047815f6ff7c1a9a4195d9b06d2ad3ec357bc3ed66fef80b253762aea099f15 kpmcore-22.04.2.tar.xz
+f8553feb7b73ef3f8e4212b5831354d81c036406ed867805b125a3b1ee24e8df7e524c530d4fb3c4131246342c6ec272dfff074473d8e72e5ff407096806527b filesystem.patch
+547803c36e333a39ad3500e3896cfb407ba8dd15cf08f329c748979c42e3f33a4b1940a11c02d532d00414d6d8f7fa564bb78df986ab9ebf0c62d63a64b4edc7 test.patch"
diff --git a/user/kpmcore/filesystem.patch b/user/kpmcore/filesystem.patch
new file mode 100644
index 000000000..931f44722
--- /dev/null
+++ b/user/kpmcore/filesystem.patch
@@ -0,0 +1,10 @@
+--- kpmcore-22.04.2/src/util/CMakeLists.txt.old 2022-06-03 15:45:10.000000000 -0500
++++ kpmcore-22.04.2/src/util/CMakeLists.txt 2022-06-12 16:01:45.750000000 -0500
+@@ -53,6 +53,7 @@
+ Qt${QT_MAJOR_VERSION}::DBus
+ KF5::I18n
+ PolkitQt${QT_MAJOR_VERSION}-1::Core
++ stdc++fs
+ )
+
+ install(TARGETS kpmcore_externalcommand DESTINATION ${KDE_INSTALL_LIBEXECDIR})
diff --git a/user/kpmcore/test.patch b/user/kpmcore/test.patch
new file mode 100644
index 000000000..e969cb91d
--- /dev/null
+++ b/user/kpmcore/test.patch
@@ -0,0 +1,42 @@
+From 26e069d6cdd2d28b04f0beb9cfb35115ac8f29d5 Mon Sep 17 00:00:00 2001
+From: "A. Wilcox" <AWilcox@Wilcox-Tech.com>
+Date: Sun, 12 Jun 2022 16:14:51 -0500
+Subject: [PATCH] Tests: Fix backend loading for tests
+
+Using $<TARGET_FILE> we receive the entire plugin file path, leading to
+errors such as:
+
+kf.coreaddons: no metadata found in "kpmcore//home/awilcox/Code/KDE/kpmcore/bin/kpmcore/pmdummybackendplugin.so" "The shared library was not found."
+
+Using $<TARGET_FILE_NAME> instead we are able to have just the plugin
+name, which does load properly. The tests now pass.
+---
+ test/CMakeLists.txt | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
+index 262c38f..53cb133 100644
+--- a/test/CMakeLists.txt
++++ b/test/CMakeLists.txt
+@@ -34,15 +34,15 @@ endmacro()
+ # Tests of initialization: try explicitly loading some backends
+ kpm_test(testinit testinit.cpp) # Default backend
+ if(TARGET pmdummybackendplugin)
+- add_test(NAME testinit-dummy COMMAND testinit $<TARGET_FILE:pmdummybackendplugin>)
++ add_test(NAME testinit-dummy COMMAND testinit $<TARGET_FILE_NAME:pmdummybackendplugin>)
+ endif()
+ if(TARGET pmsfdiskbackendplugin)
+- add_test(NAME testinit-sfdisk COMMAND testinit $<TARGET_FILE:pmsfdiskbackendplugin>)
++ add_test(NAME testinit-sfdisk COMMAND testinit $<TARGET_FILE_NAME:pmsfdiskbackendplugin>)
+ else()
+ return() # All the rest really needs a working backend
+ endif()
+
+-set(BACKEND $<TARGET_FILE:pmsfdiskbackendplugin>)
++set(BACKEND $<TARGET_FILE_NAME:pmsfdiskbackendplugin>)
+
+ ###
+ #
+--
+GitLab
+
diff --git a/user/partitionmanager/APKBUILD b/user/partitionmanager/APKBUILD
index d37784b29..be179d3ce 100644
--- a/user/partitionmanager/APKBUILD
+++ b/user/partitionmanager/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=partitionmanager
-pkgver=4.1.0
+pkgver=22.04.2
pkgrel=0
pkgdesc="Qt-based partition manager"
url="https://www.kde.org/applications/system/partitionmanager"
@@ -13,7 +13,7 @@ makedepends="cmake extra-cmake-modules qt5-qtbase-dev kconfig-dev
kiconthemes-dev kio-dev kjobwidgets-dev kservice-dev kwidgetsaddons-dev
kxmlgui-dev kpmcore-dev"
subpackages="$pkgname-doc $pkgname-lang"
-source="https://download.kde.org/stable/partitionmanager/$pkgver/src/partitionmanager-$pkgver.tar.xz"
+source="https://download.kde.org/stable/release-service/$pkgver/src/partitionmanager-$pkgver.tar.xz"
build() {
if [ "$CBUILD" != "$CHOST" ]; then
@@ -38,4 +38,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="63f77c68f0468e6b17da33bf52824e2858b43f33cb46f8ff7069386d56a154c86f5f3ec20113c472d567a790ba0d8593c2ecb44d9c0d4e1614dcdc570b072761 partitionmanager-4.1.0.tar.xz"
+sha512sums="09715df9012b5dab83ce635ca1d2e90e13455a1b798fc1c0a260dbfbc85a48d41db2a96652abc4b8d97a0128c292d360208ce0a6763a4ba5c19963dffc16af42 partitionmanager-22.04.2.tar.xz"