summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-18 21:13:22 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-18 21:13:22 -0500
commit74224eaff174cd1774615a6324e8899006dfbe82 (patch)
tree6daf92fad6c66b24a69d41aa399de5340be7b623
parentcba079d24af13f3a165c6c254399b5c65515cd8c (diff)
downloadpackages-74224eaff174cd1774615a6324e8899006dfbe82.tar.gz
packages-74224eaff174cd1774615a6324e8899006dfbe82.tar.bz2
packages-74224eaff174cd1774615a6324e8899006dfbe82.tar.xz
packages-74224eaff174cd1774615a6324e8899006dfbe82.zip
system/json-c: install to /lib
-rw-r--r--system/json-c/APKBUILD15
-rw-r--r--system/json-c/fix-libdir.patch11
2 files changed, 20 insertions, 6 deletions
diff --git a/system/json-c/APKBUILD b/system/json-c/APKBUILD
index a70257ed7..e5c44cfe8 100644
--- a/system/json-c/APKBUILD
+++ b/system/json-c/APKBUILD
@@ -1,7 +1,7 @@
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer:
pkgname=json-c
pkgver=0.13.1
-pkgrel=0
+pkgrel=1
pkgdesc="A JSON implementation in C"
url="https://github.com/json-c/json-c/wiki"
arch="all"
@@ -12,6 +12,7 @@ makedepends="$depends_dev autoconf automake libtool"
install=""
subpackages="$pkgname-static $pkgname-dev"
source="https://s3.amazonaws.com/${pkgname}_releases/releases/$pkgname-${pkgver}.tar.gz
+ fix-libdir.patch
"
prepare() {
@@ -26,6 +27,7 @@ build() {
./configure --prefix=/usr \
--build=$CBUILD \
--host=$CHOST \
+ --libdir=/lib \
--sysconfdir=/etc \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
@@ -47,9 +49,10 @@ package() {
}
static() {
- pkgdesc="Static json-c library"
- mkdir -p "$subpkgdir"/usr/lib
- mv "$pkgdir"/usr/lib/*.a "$subpkgdir"/usr/lib/
+ pkgdesc="Static JSON C library"
+ mkdir -p "$subpkgdir"/lib
+ mv "$pkgdir"/lib/*.a "$subpkgdir"/lib/
}
-sha512sums="e984db2a42b9c95b52c798b2e8dd1b79951a8dcba27370af30c43b9549fbb00008dbcf052a535c528209aaee38e6d1f760168b706905ae72f3e704ed20f8a1a1 json-c-0.13.1.tar.gz"
+sha512sums="e984db2a42b9c95b52c798b2e8dd1b79951a8dcba27370af30c43b9549fbb00008dbcf052a535c528209aaee38e6d1f760168b706905ae72f3e704ed20f8a1a1 json-c-0.13.1.tar.gz
+939f2b02fe5beb5d85ebc3fd8463bee0cff6b7da98b48edb599e88dda7955b6ba65afc17f9e828025086a1b384aa99703be06b6613e405d9c48541cf52c380f0 fix-libdir.patch"
diff --git a/system/json-c/fix-libdir.patch b/system/json-c/fix-libdir.patch
new file mode 100644
index 000000000..bf69168e7
--- /dev/null
+++ b/system/json-c/fix-libdir.patch
@@ -0,0 +1,11 @@
+--- json-c-0.13.1/Makefile.am.old 2018-03-06 04:13:22.000000000 +0000
++++ json-c-0.13.1/Makefile.am 2018-07-19 02:12:00.270000000 +0000
+@@ -14,7 +14,7 @@
+
+ lib_LTLIBRARIES = libjson-c.la
+
+-pkgconfigdir = $(libdir)/pkgconfig
++pkgconfigdir = /usr/lib/pkgconfig
+ pkgconfig_DATA = json-c.pc
+
+ libjson_cincludedir = $(includedir)/json-c