summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZach van Rijn <me@zv.io>2022-01-11 21:36:39 +0000
committerZach van Rijn <me@zv.io>2022-10-21 18:33:57 -0500
commit7e6c4c26fa4b95fe165a24c022a01c9fc05e73bc (patch)
tree931e6d5cfddd191e983aa19b89af1de597f68646
parent3e3aa629a86fab53f434e0a5a87926b0856ccd7b (diff)
downloadpackages-7e6c4c26fa4b95fe165a24c022a01c9fc05e73bc.tar.gz
packages-7e6c4c26fa4b95fe165a24c022a01c9fc05e73bc.tar.bz2
packages-7e6c4c26fa4b95fe165a24c022a01c9fc05e73bc.tar.xz
packages-7e6c4c26fa4b95fe165a24c022a01c9fc05e73bc.zip
user/py3-*: bunch of new py3 packages and updates. fixes #458, #459.
-rw-r--r--user/py3-appdirs/APKBUILD28
-rw-r--r--user/py3-iniconfig/APKBUILD32
-rw-r--r--user/py3-iniconfig/version.patch23
-rw-r--r--user/py3-markupsafe/APKBUILD4
-rw-r--r--user/py3-more-itertools/APKBUILD4
-rw-r--r--user/py3-ordered-set/APKBUILD24
-rw-r--r--user/py3-py/APKBUILD8
-rw-r--r--user/py3-py/scm.patch12
-rw-r--r--user/py3-python-dateutil/APKBUILD4
-rw-r--r--user/py3-sortedcontainers/APKBUILD27
-rw-r--r--user/py3-toml/APKBUILD28
-rw-r--r--user/py3-tox/APKBUILD6
-rw-r--r--user/py3-virtualenv/APKBUILD16
-rw-r--r--user/py3-virtualenv/python3-provides.patch8
-rw-r--r--user/py3-virtualenv/python3.patch44
-rw-r--r--user/py3-virtualenv/tests.patch84
16 files changed, 163 insertions, 189 deletions
diff --git a/user/py3-appdirs/APKBUILD b/user/py3-appdirs/APKBUILD
new file mode 100644
index 000000000..8f2450db4
--- /dev/null
+++ b/user/py3-appdirs/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: TBK <alpine@jjtc.eu>
+# Contributor: Keith Maxwell <keith.maxwell@gmail.com>
+# Maintainer: Zach van Rijn <me@zv.io>
+pkgname=py3-appdirs
+_pkgname=appdirs
+pkgver=1.4.4
+pkgrel=0
+pkgdesc="A small Python module for determining appropriate platform-specific dirs."
+url="https://pypi.org/project/appdirs/"
+arch="noarch"
+license="MIT"
+depends="python3"
+source="https://files.pythonhosted.org/packages/source/a/appdirs/appdirs-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ PYTHONPATH="$PWD/build/lib" python3 test/test_api.py
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="8b0cdd9fd471d45b186aa47607691cf378dabd3edc7b7026a57bd6d6f57698e86f440818a5e23ba4288b35d6bb8cb6eb0106eae8aab09d8863ee15025d300883 appdirs-1.4.4.tar.gz"
diff --git a/user/py3-iniconfig/APKBUILD b/user/py3-iniconfig/APKBUILD
new file mode 100644
index 000000000..773284ec6
--- /dev/null
+++ b/user/py3-iniconfig/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Justin Berthault <justin.berthault@zaclys.net>
+# Maintainer: Zach van Rijn <me@zv.io>
+pkgname=py3-iniconfig
+_pyname=iniconfig
+pkgver=1.1.1
+pkgrel=0
+pkgdesc="Simple INI configuration parsing for Python"
+url="https://github.com/RonnyPfannschmidt/iniconfig"
+arch="noarch"
+options="!check" # Requires PyTest, which requires iniconfig.
+license="MIT"
+depends="python3"
+makedepends="py3-py"
+source="https://files.pythonhosted.org/packages/source/i/$_pyname/$_pyname-$pkgver.tar.gz
+ version.patch
+ "
+builddir="$srcdir/$_pyname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="c9341db7e3ec2204b6a674fca7824cbeb492e3576d5ac3f084b234c82842b28f2f6acbfdb812e183f4334a95b990551f942a4caf548f5ce7ef14885f931535ee iniconfig-1.1.1.tar.gz
+bcc29e3ab250a8b9aaa496b2bb8f52a03f56faf8a73268c388959ee1090cd5fc86f11b5c6c339f1b9b9c9697984f3a956425b9d392507b69ec0e4aa543e97a92 version.patch"
diff --git a/user/py3-iniconfig/version.patch b/user/py3-iniconfig/version.patch
new file mode 100644
index 000000000..33bf819cf
--- /dev/null
+++ b/user/py3-iniconfig/version.patch
@@ -0,0 +1,23 @@
+From: "A. Wilcox" <AWilcox@Wilcox-Tech.com>
+Date: Sun, 12 Jun 2022 22:48:18 -0500
+Subject: [PATCH] Use correct version when packaging
+
+Using scm_version installs an egg of version 0.0.0 (or whatever the
+containing Git repository describes as). We want to have the actual
+version available when building packages.
+
+--- iniconfig-1.1.1/setup.py.old 2020-10-14 05:19:54.000000000 -0500
++++ iniconfig-1.1.1/setup.py 2022-06-12 22:52:45.840000000 -0500
+@@ -14,11 +14,11 @@
+ readme = fp.read()
+ setup(
+ name='iniconfig',
++ version='1.1.1',
+ packages=['iniconfig'],
+ package_dir={'': 'src'},
+ description='iniconfig: brain-dead simple config-ini parsing',
+ long_description=readme,
+- use_scm_version=True,
+ url='http://github.com/RonnyPfannschmidt/iniconfig',
+ license='MIT License',
+ platforms=['unix', 'linux', 'osx', 'cygwin', 'win32'],
diff --git a/user/py3-markupsafe/APKBUILD b/user/py3-markupsafe/APKBUILD
index a9721b9d3..400594de2 100644
--- a/user/py3-markupsafe/APKBUILD
+++ b/user/py3-markupsafe/APKBUILD
@@ -4,7 +4,7 @@ pkgname=py3-markupsafe
_pkgname=MarkupSafe
_p="${_pkgname#?}"
_p="${_pkgname%"$_p"}"
-pkgver=1.1.1
+pkgver=2.0.1
pkgrel=0
pkgdesc="Safely add untrusted strings to HTML/XML markup."
url="https://pypi.python.org/pypi/MarkupSafe"
@@ -29,4 +29,4 @@ package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="f3014e6131a3ab866914c5635b5397ef71906bffb1b6f8c5f2ed2acf167429ff7914236d38943e872683a57a9be9669f4c5aace6274f3307ab21ef25373db0b6 py3-markupsafe-1.1.1.tar.gz"
+sha512sums="77249bda784111ece15d59eb3de1cbb37a58fb9f22902fe6b73fea9eb0f23857ccbe53dc55463278e3b91f78dc35e2b027fd823ca50d88d8985d5a98ce2327f1 py3-markupsafe-2.0.1.tar.gz"
diff --git a/user/py3-more-itertools/APKBUILD b/user/py3-more-itertools/APKBUILD
index 862a120f4..93998cf89 100644
--- a/user/py3-more-itertools/APKBUILD
+++ b/user/py3-more-itertools/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=py3-more-itertools
_pkgname=more-itertools
-pkgver=8.0.2
+pkgver=8.12.0
pkgrel=0
pkgdesc="More routines for operating on iterables, beyond itertools"
url="https://pypi.org/project/more-itertools"
@@ -26,4 +26,4 @@ package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="c309bfd988efb702c25c241ca76379e0be07e1fdfb9d648c257760ac76872fd1aa77b321d94c2af9be8fb9a6709b4c60a9e0e9eb7450757ee74046bb5f9101b4 py3-more-itertools-8.0.2.tar.gz"
+sha512sums="73759f05d178bd6fe98cadac401707faf90a4f7b456c4aac3f0b3f6c13a2284600971e0b271f1768cacd3ae9b69848404f85432199ca51b8160fbe67045dfd17 py3-more-itertools-8.12.0.tar.gz"
diff --git a/user/py3-ordered-set/APKBUILD b/user/py3-ordered-set/APKBUILD
new file mode 100644
index 000000000..4adac33f0
--- /dev/null
+++ b/user/py3-ordered-set/APKBUILD
@@ -0,0 +1,24 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Zach van Rijn <me@zv.io>
+pkgname=py3-ordered-set
+pkgver=4.0.2
+pkgrel=0
+pkgdesc="MutableSet that remembers its order"
+url="https://github.com/LuminosoInsight/ordered-set"
+arch="noarch"
+options="!check" # Circular dependencies.
+license="MIT"
+depends="python3"
+makedepends=""
+source="https://pypi.io/packages/source/o/ordered-set/ordered-set-$pkgver.tar.gz"
+builddir="$srcdir/ordered-set-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="d7031ae90fdaf116c27415170a7197be34ff4b977a03684a6fb53dc453845a97cd32b9666ed3ae58fb7bc722ff3b2b4f2e156578841033759b490b359a5619b4 ordered-set-4.0.2.tar.gz"
diff --git a/user/py3-py/APKBUILD b/user/py3-py/APKBUILD
index 72f6ee4c1..6c1912664 100644
--- a/user/py3-py/APKBUILD
+++ b/user/py3-py/APKBUILD
@@ -3,7 +3,7 @@
pkgname=py3-py
_pkgname=py
_p=p
-pkgver=1.8.0
+pkgver=1.11.0
pkgrel=0
pkgdesc="A python library with cross-python path, ini-parsing, io, code, log facilities"
url="https://pypi.python.org/project/py"
@@ -15,8 +15,7 @@ license="MIT"
depends="python3"
makedepends="python3-dev"
#checkdepends="py3-pytest"
-source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/$_p/$_pkgname/$_pkgname-$pkgver.tar.gz
- scm.patch"
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/$_p/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
@@ -31,5 +30,4 @@ package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="37b9a66229b834a034d9ba6769a46addf098380b494c1eb863607a52d00b7ec5b9157dd7ac6ffc52535a05006648c775c78716d7f85cf44966065b225be6e95b py3-py-1.8.0.tar.gz
-08a1645832d46ffab5b1fb2e7ef480c55a0d4ac266d53857d9ddae5c46ba11232b04bc0cb035bb9e3d08f9d439e844a623340882080555206811fe0624c61bc1 scm.patch"
+sha512sums="ce8dd791f9f6dd7e60a6caad32ff5cb816389a0840436efdedf4e0d4b0bfa09f7aea9e7c31d89903c72fe6ef17170a85af480525ba92c458ed73501a0420f2c4 py3-py-1.11.0.tar.gz"
diff --git a/user/py3-py/scm.patch b/user/py3-py/scm.patch
deleted file mode 100644
index 44665748f..000000000
--- a/user/py3-py/scm.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- py-1.7.0/setup.py 2018-08-27 20:39:51.000000000 +0000
-+++ py-1.7.0/setup.py 2018-10-11 05:07:12.560247181 +0000
-@@ -6,8 +6,7 @@ def main():
- name='py',
- description='library with cross-python path, ini-parsing, io, code, log facilities',
- long_description=open('README.rst').read(),
-- use_scm_version={"write_to": "py/_version.py"},
-- setup_requires=["setuptools-scm"],
-+ version='1.7.0',
- url='http://py.readthedocs.io/',
- license='MIT license',
- platforms=['unix', 'linux', 'osx', 'cygwin', 'win32'],
diff --git a/user/py3-python-dateutil/APKBUILD b/user/py3-python-dateutil/APKBUILD
index f205ebfc5..5b8ee41f1 100644
--- a/user/py3-python-dateutil/APKBUILD
+++ b/user/py3-python-dateutil/APKBUILD
@@ -4,7 +4,7 @@ pkgname=py3-python-dateutil
_pkgname=python-dateutil
_p="${_pkgname#?}"
_p="${_pkgname%"$_p"}"
-pkgver=2.8.1
+pkgver=2.8.2
pkgrel=0
pkgdesc="Extensions to the standard Python datetime module"
url="https://pypi.python.org/pypi/python-dateutil"
@@ -32,4 +32,4 @@ package() {
}
-sha512sums="337000216e0f8ce32d6363768444144183ab9268f69082f20858f2b3322b1c449e53b2f2b5dcb3645be22294659ce7838f74ace2fd7a7c4f2adc6cf806a9fa2c py3-python-dateutil-2.8.1.tar.gz"
+sha512sums="6538858e4a3e2d1de1bf25b6d8b25e3a8d20bf60fb85e32d07ac491c90ce193e268bb5641371b8a79fb0f033a184bac9896b3bc643c1aca9ee9c6478286ac20c py3-python-dateutil-2.8.2.tar.gz"
diff --git a/user/py3-sortedcontainers/APKBUILD b/user/py3-sortedcontainers/APKBUILD
index 86b3330b7..9220bf117 100644
--- a/user/py3-sortedcontainers/APKBUILD
+++ b/user/py3-sortedcontainers/APKBUILD
@@ -1,21 +1,18 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Contributor: André Klitzing <aklitzing@gmail.com>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=py3-sortedcontainers
-_pkgname=sortedcontainers
-_p="${_pkgname#?}"
-_p="${_pkgname%"$_p"}"
-pkgver=2.2.2
+_pkgname=python-sortedcontainers
+pkgver=2.4.0
pkgrel=0
-pkgdesc="Sorted container objects for Python 3"
-url="https://pypi.python.org/pypi/sortedcontainers"
+pkgdesc="Python library for sorting collections and containers"
+url="http://www.grantjenks.com/docs/sortedcontainers"
arch="noarch"
-options="!check" # See checkdepends comment below.
license="Apache-2.0"
depends="python3"
-# requires unpackaged filelock, toml; requires importlib_metadata<1
-#checkdepends="py3-importlib_metadata py3-packaging py3-tox"
-makedepends="python3-dev"
-source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/$_p/$_pkgname/$_pkgname-$pkgver.tar.gz"
+checkdepends="py3-pytest"
+makedepends="py3-iniconfig"
+source="https://files.pythonhosted.org/packages/source/p/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
@@ -23,12 +20,10 @@ build() {
}
check() {
- python3 setup.py test
+ PYTHONPATH="$PWD"/build/lib python3 -m pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
-
+ python3 setup.py install --prefix=/usr --root="$pkgdir" --skip-build
}
-
-sha512sums="4a7da8d76111b56bda432b211c11ef48ac8af25ddf7fd961cf72628c18f878a6c2a22e272e108f3e5ad88a333b8f646b54c8dd11c9c642349c9da001140abd16 py3-sortedcontainers-2.2.2.tar.gz"
+sha512sums="f80185c6f95a85cc78f88f6f6cf389eb48be22cf94d5fcd84f3592873f17de37ec7f44c1627b7f02956ac4b4f74ca4febefc47d3c6232f70ee05dbb2449ad770 python-sortedcontainers-2.4.0.tar.gz"
diff --git a/user/py3-toml/APKBUILD b/user/py3-toml/APKBUILD
new file mode 100644
index 000000000..2705dcde0
--- /dev/null
+++ b/user/py3-toml/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Zach van Rijn <me@zv.io>
+pkgname=py3-toml
+_pyname=toml
+pkgver=0.10.2
+pkgrel=0
+pkgdesc="Python 3 library for TOML"
+url="https://pypi.org/project/toml/"
+arch="noarch"
+license="MIT"
+depends="python3"
+checkdepends="py3-pytest"
+makedepends="py3-iniconfig"
+source="https://files.pythonhosted.org/packages/source/${_pyname%${_pyname#?}}/$_pyname/$_pyname-$pkgver.tar.gz"
+builddir="$srcdir/"$_pyname-$pkgver
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+sha512sums="ede2c8fed610a3827dba828f6e7ab7a8dbd5745e8ef7c0cd955219afdc83b9caea714deee09e853627f05ad1c525dc60426a6e9e16f58758aa028cb4d3db4b39 toml-0.10.2.tar.gz"
diff --git a/user/py3-tox/APKBUILD b/user/py3-tox/APKBUILD
index d722fe99f..204af0e7e 100644
--- a/user/py3-tox/APKBUILD
+++ b/user/py3-tox/APKBUILD
@@ -1,10 +1,10 @@
# Contributor: Max Rees <maxcrees@me.com>
-# Maintainer:
+# Maintainer: Zach van Rijn <me@zv.io>
pkgname=py3-tox
_pkgname=tox
_p="${_pkgname#?}"
_p="${_pkgname%"$_p"}"
-pkgver=3.13.2
+pkgver=3.24.5
pkgrel=0
pkgdesc="virtualenv management and test command line tool"
url="https://pypi.python.org/pypi/tox"
@@ -29,4 +29,4 @@ package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="06c92c803bef7c2dd3796ecc869d78dc4d3044e62688bcf529b7c6b8330532aab30dcc44425fc226886a35d8227225db5e3f2435a469e90af7ad440231abbc35 py3-tox-3.13.2.tar.gz"
+sha512sums="2b047c5682c2c57268fb46055207388d060fb31511d6e442dc49244a5ac53c4d2fecd7bb9a8e33bb02b580192926592523dfb991c4bd8b216559f71a1c548f9a py3-tox-3.24.5.tar.gz"
diff --git a/user/py3-virtualenv/APKBUILD b/user/py3-virtualenv/APKBUILD
index 1697099f9..aa3e78fc7 100644
--- a/user/py3-virtualenv/APKBUILD
+++ b/user/py3-virtualenv/APKBUILD
@@ -2,25 +2,22 @@
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=py3-virtualenv
_pkgname=virtualenv
-pkgver=16.7.5
+pkgver=20.8.1
pkgrel=0
pkgdesc="Virtual Python Environment builder"
url="https://pypi.org/project/virtualenv"
arch="noarch"
+options="!check"
# Certified net clean
license="MIT"
depends="python3"
-makedepends="python3-dev"
+makedepends="python3-dev py3-iniconfig py3-toml"
checkdepends="py3-pytest cmd:which"
-source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/v/$_pkgname/$_pkgname-$pkgver.tar.gz
- python3-provides.patch
- python3.patch
- tests.patch"
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/v/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
python3 setup.py build
- sed -ie "s/env python$/env python3/" virtualenv.py
}
check() {
@@ -31,7 +28,4 @@ package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="60b734f688eec1491fe5dcc3652d42f3e44df89d0809d3ab563c5dab1b5e340404894f34a08994a5ad4d8c0f7c8bb995d8211f9378906957d34031720bb3c390 py3-virtualenv-16.7.5.tar.gz
-22f05b9c3d35339a28f50f7a01d81df082a00609712a5c38b92fe5d5c98ea077ad76c7d5a5072968105622d06e40897a34878133a4b5fd895a62d1e0d9a8928e python3-provides.patch
-f5e2a5036c7dfa124b71914981c46955466cb718392a90a4d8536dde4c153eb9cf3a8539c5cf870bb820b6e518c8b781025b825e11924ea4533890fa31e5a951 python3.patch
-a5545b1dd3b0465233b983fd90cdfbd4514350e32a7d312107b9cfa83c8755f961bd483796a48697c9938fd44a60171c4368aa3f4b2760be8d2d8e053f719529 tests.patch"
+sha512sums="db373bdb68efce0ce26cefe508e452b62d4336ccf74f08a51aa61272127c8cd43639443342f42cacb62d7bfd1381bc1204211218c486dfcdb165d8486a2e728b py3-virtualenv-20.8.1.tar.gz"
diff --git a/user/py3-virtualenv/python3-provides.patch b/user/py3-virtualenv/python3-provides.patch
deleted file mode 100644
index b3a7f11fc..000000000
--- a/user/py3-virtualenv/python3-provides.patch
+++ /dev/null
@@ -1,8 +0,0 @@
---- virtualenv-16.7.2/setup.py 2019-07-26 05:13:47.000000000 -0400
-+++ virtualenv-16.7.2/setup.py 2019-08-06 10:12:36.010033115 -0400
-@@ -13,4 +13,4 @@ def get_version():
- raise RuntimeError("Unable to find version string.")
-
-
--setup(version=get_version(), py_modules=["virtualenv"], setup_requires=["setuptools >= 40.6.3"])
-+setup(version=get_version(), py_modules=["virtualenv"], setup_requires=[])
diff --git a/user/py3-virtualenv/python3.patch b/user/py3-virtualenv/python3.patch
deleted file mode 100644
index f1550f49c..000000000
--- a/user/py3-virtualenv/python3.patch
+++ /dev/null
@@ -1,44 +0,0 @@
---- virtualenv-16.7.2/virtualenv.py
-+++ virtualenv-16.7.2/virtualenv.py
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python3
- """Create a "virtual" Python installation"""
-
- # fmt: off
-@@ -82,7 +82,7 @@ DEFAULT_CONFIG_FILE = os.path.join(DEFAU
- if IS_PYPY:
- EXPECTED_EXE = "pypy"
- else:
-- EXPECTED_EXE = "python"
-+ EXPECTED_EXE = "python3"
-
- # Return a mapping of version -> Python executable
- # Only provided for Windows, where the information in the registry is used
---- virtualenv-16.7.2/tasks/update_embedded.py
-+++ virtualenv-16.7.2/tasks/update_embedded.py
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python3
- """
- Helper script to rebuild virtualenv.py from virtualenv_support
- """
---- virtualenv-16.7.2/tests/test_virtualenv.py
-+++ virtualenv-16.7.2/tests/test_virtualenv.py
-@@ -288,14 +288,14 @@ def test_resolve_interpreter_with_invali
- def test_activate_after_future_statements():
- """Should insert activation line after last future statement"""
- script = [
-- "#!/usr/bin/env python",
-+ "#!/usr/bin/env python3",
- "from __future__ import with_statement",
- "from __future__ import print_function",
- 'print("Hello, world!")',
- ]
- out = virtualenv.relative_script(script)
- assert out == [
-- "#!/usr/bin/env python",
-+ "#!/usr/bin/env python3",
- "from __future__ import with_statement",
- "from __future__ import print_function",
- "",
diff --git a/user/py3-virtualenv/tests.patch b/user/py3-virtualenv/tests.patch
deleted file mode 100644
index 98619b1c1..000000000
--- a/user/py3-virtualenv/tests.patch
+++ /dev/null
@@ -1,84 +0,0 @@
---- virtualenv-16.7.2/tests/test_virtualenv.py
-+++ virtualenv-16.7.2/tests/test_virtualenv.py
-@@ -10,9 +10,7 @@ import tempfile
- import textwrap
- import zipfile
-
--import pypiserver
- import pytest
--import pytest_localserver.http
- import six
-
- import virtualenv
-@@ -346,7 +344,7 @@ def test_install_python_bin():
- py_exe_no_version = "python"
- py_exe_version_major = "python%s" % sys.version_info[0]
- py_exe_version_major_minor = "python{}.{}".format(sys.version_info[0], sys.version_info[1])
-- required_executables = [py_exe_no_version, py_exe_version_major, py_exe_version_major_minor]
-+ required_executables = [py_exe_version_major, py_exe_version_major_minor]
-
- for pth in required_executables:
- assert os.path.exists(os.path.join(bin_dir, pth)), "%s should exist in bin_dir" % pth
-@@ -489,6 +487,7 @@ def test_create_environment_in_dir_with_
- virtualenv.create_environment(ve_path)
-
-
-+@pytest.mark.skip(reason="pypiserver et al are not packaged")
- def test_create_environment_with_local_https_pypi(tmpdir):
- """Create virtual environment using local PyPI listening https with
- certificate signed with custom certificate authority
-@@ -643,7 +642,7 @@ def test_create_environment_with_old_pip
- def test_license_builtin(clean_python):
- _, bin_dir, _ = clean_python
- proc = subprocess.Popen(
-- (os.path.join(bin_dir, "python"), "-c", "license()"), stdin=subprocess.PIPE, stdout=subprocess.PIPE
-+ (os.path.join(bin_dir, "python3"), "-c", "license()"), stdin=subprocess.PIPE, stdout=subprocess.PIPE
- )
- out_b, _ = proc.communicate(b"q\n")
- out = out_b.decode()
---- virtualenv-16.7.2/tests/test_zipapp.py
-+++ virtualenv-16.7.2/tests/test_zipapp.py
-@@ -55,6 +55,7 @@ def test_zipapp_basic_invocation(call_zi
- _test_basic_invocation(call_zipapp, tmp_path)
-
-
-+@pytest.mark.skip(reason="requires network access")
- def test_wheel_basic_invocation(call_wheel, tmp_path):
- _test_basic_invocation(call_wheel, tmp_path)
-
-@@ -91,6 +91,7 @@ def _test_invocation_dash_p(make_env, tm
- assert_venv_looks_good(venv, [expected], "python{}".format(".exe" if virtualenv.IS_WIN else ""))
-
-
-+@pytest.mark.skip(reason="no python2 available")
- def test_zipapp_invocation_dash_p(call_zipapp, tmp_path):
- _test_invocation_dash_p(call_zipapp, tmp_path)
-
-@@ -95,6 +95,6 @@ def test_zipapp_invocation_dash_p(call_z
- _test_invocation_dash_p(call_zipapp, tmp_path)
-
-
--@pytest.mark.skipif(sys.platform == "win32" and six.PY2, reason="no python 3 for windows on CI")
-+@pytest.mark.skip(reason="no python2 available")
- def test_wheel_invocation_dash_p(call_wheel, tmp_path):
- _test_invocation_dash_p(call_wheel, tmp_path)
---- virtualenv-16.7.2/tests/test_from_source.py
-+++ virtualenv-16.7.2/tests/test_from_source.py
-@@ -40,6 +40,7 @@ def test_use_from_source_sdist(sdist, tm
- )
-
-
-+@pytest.mark.skip(reason="requires network access")
- def test_use_from_wheel(tmp_path, extracted_wheel, clean_python, monkeypatch, call_subprocess):
- """test that we can create a virtual environment by feeding to a clean python the wheels content"""
- virtualenv_file = extracted_wheel / "virtualenv.py"
---- virtualenv-16.7.2/tests/test_source_content.py
-+++ virtualenv-16.7.2/tests/test_source_content.py
-@@ -41,6 +41,7 @@ def test_sdist_contains(sdist):
- assert not extra, " | ".join(extra)
-
-
-+@pytest.mark.skip(reason="requires network access")
- def test_wheel_contains(extracted_wheel):
- content = set(extracted_wheel.iterdir())
-