summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-28 05:49:40 -0600
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-28 05:49:40 -0600
commit8462b261d6159bcc469e9ff1996430a07e62b2b0 (patch)
tree19b3dbe681ed4a355a6c1d58d1e91892a7bdd574
parent409644990803bfcb544169b8ab6c364be0c94bae (diff)
downloadpackages-8462b261d6159bcc469e9ff1996430a07e62b2b0.tar.gz
packages-8462b261d6159bcc469e9ff1996430a07e62b2b0.tar.bz2
packages-8462b261d6159bcc469e9ff1996430a07e62b2b0.tar.xz
packages-8462b261d6159bcc469e9ff1996430a07e62b2b0.zip
user/{libtheora,pciutils,sdl}: modernise/fix syntax
-rw-r--r--user/libtheora/APKBUILD5
-rw-r--r--user/pciutils/APKBUILD2
-rw-r--r--user/sdl/APKBUILD7
3 files changed, 5 insertions, 9 deletions
diff --git a/user/libtheora/APKBUILD b/user/libtheora/APKBUILD
index 618f413b9..59e55f677 100644
--- a/user/libtheora/APKBUILD
+++ b/user/libtheora/APKBUILD
@@ -2,14 +2,15 @@
pkgname=libtheora
pkgver=1.1.1
pkgrel=14
-pkgdesc="An open video codec developed by the Xiph.org"
+pkgdesc="An open video codec developed by Xiph.org"
url="https://www.theora.org/"
arch="all"
license="BSD-3-Clause"
-subpackages="$pkgname-dev $pkgname-doc $pkgname-examples"
+depends=""
depends_dev="libogg-dev"
makedepends="libvorbis-dev libogg-dev sdl-dev autoconf automake libtool
linux-headers"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-examples"
source="http://downloads.xiph.org/releases/theora/$pkgname-$pkgver.tar.bz2
libtheora-flags.patch
enc.patch
diff --git a/user/pciutils/APKBUILD b/user/pciutils/APKBUILD
index a20e48e9d..45924bda1 100644
--- a/user/pciutils/APKBUILD
+++ b/user/pciutils/APKBUILD
@@ -17,7 +17,6 @@ source="https://www.kernel.org/pub/software/utils/$pkgname/$pkgname-$pkgver.tar.
"
build() {
- cd "$builddir"
sed -i -e "106s/^/\#/" Makefile
make OPT="$CFLAGS" ZLIB=no \
SHARED=yes \
@@ -28,7 +27,6 @@ build() {
}
package() {
- cd "$builddir"
make PREFIX="$pkgdir"/usr \
SHARED=yes \
SHAREDIR="$pkgdir"/usr/share/hwdata \
diff --git a/user/sdl/APKBUILD b/user/sdl/APKBUILD
index 176ac36b9..4c3d0084f 100644
--- a/user/sdl/APKBUILD
+++ b/user/sdl/APKBUILD
@@ -7,11 +7,11 @@ url="http://www.libsdl.org"
arch="all"
options="!check" # Tests are all interactive.
license="LGPL-2.1+"
-subpackages="$pkgname-dev $pkgname-doc"
-depends=
+depends=""
depends_dev="libx11-dev"
makedepends="$depends_dev libxext-dev libxrender-dev libx11-dev libice-dev
libsm-dev libxrandr-dev mesa-dev alsa-lib-dev glu-dev"
+subpackages="$pkgname-dev $pkgname-doc"
source="http://www.libsdl.org/release/SDL-$pkgver.tar.gz
SDL-1.2.10-GrabNotViewable.patch
SDL-1.2.15-const_XData32.patch
@@ -19,13 +19,11 @@ source="http://www.libsdl.org/release/SDL-$pkgver.tar.gz
builddir="$srcdir"/SDL-$pkgver
prepare() {
- cd "$builddir"
update_config_sub
default_prepare
}
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -42,7 +40,6 @@ build() {
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}