summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLaurent Bercot <ska-adelie@skarnet.org>2024-04-16 17:05:19 +0000
committerZach van Rijn <me@zv.io>2024-04-25 02:48:27 +0000
commita13ce58908653b32ec910c381db3aa8d54aced30 (patch)
treea57d25385ec57031bf0bc98b69b9a33210d42297
parent147011dc0b52b7caaa45671585612c626687ffd8 (diff)
downloadpackages-a13ce58908653b32ec910c381db3aa8d54aced30.tar.gz
packages-a13ce58908653b32ec910c381db3aa8d54aced30.tar.bz2
packages-a13ce58908653b32ec910c381db3aa8d54aced30.tar.xz
packages-a13ce58908653b32ec910c381db3aa8d54aced30.zip
user/tipidee: improve APKBUILD, fix packaging nits
-rw-r--r--user/tipidee/APKBUILD14
-rw-r--r--user/tipidee/tipidee.initd5
-rw-r--r--user/tipidee/tipidee.post-install8
-rw-r--r--user/tipidee/tipidee.pre-install6
4 files changed, 17 insertions, 16 deletions
diff --git a/user/tipidee/APKBUILD b/user/tipidee/APKBUILD
index 593b19dae..81751848c 100644
--- a/user/tipidee/APKBUILD
+++ b/user/tipidee/APKBUILD
@@ -24,6 +24,8 @@ install="
tipidee.pre-install
tipidee.post-install
"
+pkggroups="tipidee"
+pkgusers="tipideelog tipideed"
build() {
./configure \
@@ -43,22 +45,26 @@ build() {
_makeservicedir() {
name="http${1}d-${2}"
fn="$pkgdir/var/lib/tipidee/services/$name"
- mkdir -p -m 0755 "$fn/log"
+ mkdir -p "$fn/log"
echo 3 > "$fn/log/notification-fd"
sed -e "s/@S@/${1}/g; s/@V@/${2}/g;" "$srcdir/logger.run" > "$fn/log/run"
chmod 0755 "$fn/log/run"
echo 3 > "$fn/notification-fd"
sed -e "s/@V@/${2}/g;" "$srcdir/http${1}d.run" > "$fn/run"
chmod 0755 "$fn/run"
+ fn="$pkgdir/var/log/$name"
+ mkdir -p "$fn"
+ chown tipideelog:tipidee "$fn"
+ chmod 02755 "$fn"
}
package() {
- mkdir -p -m 0755 "$pkgdir/etc" "$pkgdir/usr/share/doc" "$pkgdir/var/lib/tipidee/docroot"
+ mkdir -p "$pkgdir/usr/share/doc" "$pkgdir/var/lib/tipidee/docroot"
make DESTDIR="$pkgdir" install
- cp "$srcdir/tipidee.conf" "$pkgdir/etc/tipidee.conf"
for i in '' s ; do for j in 4 6 ; do
_makeservicedir "$i" "$j"
done ; done
+ install -m 0644 -D "$srcdir/tipidee.conf" "$pkgdir/etc/tipidee.conf"
install -m 0644 -D "$srcdir/tipidee.confd" "$pkgdir/etc/conf.d/tipidee"
install -m 0755 -D "$srcdir/tipidee.initd" "$pkgdir/etc/init.d/tipidee"
cp -a "$builddir/doc" "$pkgdir/usr/share/doc/$pkgname"
@@ -77,4 +83,4 @@ sha512sums="d177f4c00db9855792dbddc4c96d2c75bd302443f29376e1d35d511d56964e5de11d
b5af306fe7040f966b13da84bfb0c4b528683c03205519d08fe429ee826ffad27c9ddb32be8c8bf8b42ce7964ef15572e3c66a96494aed833ee951c769f81bd2 logger.run
bb2681a3000133724bb8fd4918bc3209ea676c2e4f96ad8b298d8e7302aeebd6876341ea205f2d808f34e4c9b5c138bba032694c6069c17026b0ddf23702f9ba tipidee.conf
7a999200ad21b2b0737ce82136bc8e055d7ab4a865b7727e6dc8df0eaeea6ace11eb5756b64231ce7938d11b5ec218944173ea1df3db059d033bf3f848c9a608 tipidee.confd
-13e27b5c9f8ed6b1186b41bce6ffc280146643cb7b568958f24b63a4d73fcb7a147b68cd7cf74812ca55a2a5ae3b3717f177ea1546be7d30a86ff09954d9ec0f tipidee.initd"
+5001d079b1ca7920d163cc2d58a5855e2740e72ed85df25414b4719c52133bd0f2f9e69c63c57f31645159189fc046c7d213048fc1cbd0f640336e43874e4482 tipidee.initd"
diff --git a/user/tipidee/tipidee.initd b/user/tipidee/tipidee.initd
index ebd0787a7..f196bcd23 100644
--- a/user/tipidee/tipidee.initd
+++ b/user/tipidee/tipidee.initd
@@ -4,13 +4,12 @@ description="Start/stop the tipidee services"
depend()
{
- after net
- after localmount
+ after net
+ after localmount
}
_get_services()
{
- . /etc/conf.d/tipidee
list=
if "$HTTP" ; then
if test -n "$TIPIDEED_IPv4" ; then
diff --git a/user/tipidee/tipidee.post-install b/user/tipidee/tipidee.post-install
index 9ff3c9691..425ab5aaa 100644
--- a/user/tipidee/tipidee.post-install
+++ b/user/tipidee/tipidee.post-install
@@ -1,7 +1,3 @@
-#!/bin/sh -e
+#!/bin/execlineb -P
-list="/var/log/httpd-4 /var/log/httpd-6 /var/log/httpsd-4 /var/log/httpsd-6"
-mkdir -p -m 0755 $list
-chown tipideelog:tipidee $list
-chmod 02755 $list
-exec tipidee-config
+tipidee-config
diff --git a/user/tipidee/tipidee.pre-install b/user/tipidee/tipidee.pre-install
index 0ef043441..e92fd1d0a 100644
--- a/user/tipidee/tipidee.pre-install
+++ b/user/tipidee/tipidee.pre-install
@@ -1,7 +1,7 @@
#!/bin/sh
-addgroup -S tipidee 2>/dev/null
-adduser -S -D -h / -H -s /sbin/nologin -G tipidee -g tipideelog tipideelog 2>/dev/null
-adduser -S -D -h / -H -s /sbin/nologin -G tipidee -g tipideed tipideed 2>/dev/null
+groupadd -r -- tipidee 2>/dev/null
+useradd -r -d / -M -N -s /sbin/nologin -g tipidee -c tipideelog -- tipideelog 2>/dev/null
+useradd -r -d / -M -N -s /sbin/nologin -g tipidee -c tipideed -- tipideed 2>/dev/null
exit 0