summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2024-05-25 13:48:03 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2024-07-09 03:58:18 -0500
commitbc8a65907b61a9fb20d82868b744abd3dfceeb29 (patch)
treeedef3d537b21280946b379fb6a802016b4f66898
parent6d91c03f2c7ae7996df6ae0ce8cd087177eb84b7 (diff)
downloadpackages-bc8a65907b61a9fb20d82868b744abd3dfceeb29.tar.gz
packages-bc8a65907b61a9fb20d82868b744abd3dfceeb29.tar.bz2
packages-bc8a65907b61a9fb20d82868b744abd3dfceeb29.tar.xz
packages-bc8a65907b61a9fb20d82868b744abd3dfceeb29.zip
system/icu: Multiple test improvements
* Use TZ=UTC for running tests. Ref: #1169. * Use older GCC behaviour for floating point math. Closes: #1193.
-rw-r--r--system/icu/APKBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/system/icu/APKBUILD b/system/icu/APKBUILD
index a2b0af950..62b39f2e4 100644
--- a/system/icu/APKBUILD
+++ b/system/icu/APKBUILD
@@ -43,6 +43,9 @@ prepare() {
}
build() {
+ # GCC 13 changed default fp precision behavior. (#1193)
+ export CXXFLAGS="${CXXFLAGS} -fexcess-precision=fast"
+
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -59,7 +62,8 @@ build() {
}
check() {
- make check
+ # Using TZ=UTC temporarily until we can update ICU. (#1169)
+ TZ=UTC make check
}
package() {