summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-12 09:08:07 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-12 09:08:07 +0000
commite43c6ac7e6a5d054e6bbd47650f4b2531df91017 (patch)
tree15ef27c72b46256c95aca12b49ca10e3b117ee26
parenta659f1f6d9acf841ab364e2b031a56dc1b630698 (diff)
downloadpackages-e43c6ac7e6a5d054e6bbd47650f4b2531df91017.tar.gz
packages-e43c6ac7e6a5d054e6bbd47650f4b2531df91017.tar.bz2
packages-e43c6ac7e6a5d054e6bbd47650f4b2531df91017.tar.xz
packages-e43c6ac7e6a5d054e6bbd47650f4b2531df91017.zip
user/*: Modernise / fix syntax / deps / code
-rw-r--r--user/claws-mail/APKBUILD16
-rw-r--r--user/claws-mail/etpan.patch97
-rw-r--r--user/ode/APKBUILD8
-rw-r--r--user/ode/stdint.patch44
-rw-r--r--user/s6-linux-utils/APKBUILD15
-rw-r--r--user/s6-portable-utils/APKBUILD14
-rw-r--r--user/serf/APKBUILD4
-rw-r--r--user/xmoto/APKBUILD7
8 files changed, 169 insertions, 36 deletions
diff --git a/user/claws-mail/APKBUILD b/user/claws-mail/APKBUILD
index 1194f3c0e..f59ff40e1 100644
--- a/user/claws-mail/APKBUILD
+++ b/user/claws-mail/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=claws-mail
pkgver=3.17.4
-pkgrel=1
+pkgrel=2
pkgdesc="User-friendly, lightweight, and fast email client"
url="https://www.claws-mail.org/"
arch="all"
@@ -11,9 +11,16 @@ depends="compface"
makedepends="compface-dev curl-dev dbus-glib-dev enchant-dev gnutls-dev
gpgme-dev gtk+2.0-dev libcanberra-gtk2 libcanberra-dev libetpan-dev
libical-dev libnotify-dev librsvg-dev openldap-dev
- startup-notification-dev"
+ startup-notification-dev autoconf automake libtool"
subpackages="$pkgname-doc $pkgname-lang"
-source="https://www.claws-mail.org/download.php?file=releases/claws-mail-$pkgver.tar.xz"
+source="https://www.claws-mail.org/download.php?file=releases/claws-mail-$pkgver.tar.xz
+ etpan.patch
+ "
+
+prepare() {
+ default_prepare
+ autoreconf -vif
+}
build() {
./configure \
@@ -36,4 +43,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="4fc3b04d89c84b068654902d3d4f8ba66ec86c4ea9c4bd145fb3169dd26a2fcfc26adc8367b0ed90c69d095f6b1717ba3a9a52cc6d3e310a9dad1c3f733d8012 claws-mail-3.17.4.tar.xz"
+sha512sums="4fc3b04d89c84b068654902d3d4f8ba66ec86c4ea9c4bd145fb3169dd26a2fcfc26adc8367b0ed90c69d095f6b1717ba3a9a52cc6d3e310a9dad1c3f733d8012 claws-mail-3.17.4.tar.xz
+39e70ba2edfad857d4c042db0fa38ac806cf188d1cf7642b92d0115e162349919df7b98ade49da822fb1b299c5ef06d221b5c600e218ed33e0e8a48c3635d0a2 etpan.patch"
diff --git a/user/claws-mail/etpan.patch b/user/claws-mail/etpan.patch
new file mode 100644
index 000000000..572380d2e
--- /dev/null
+++ b/user/claws-mail/etpan.patch
@@ -0,0 +1,97 @@
+diff --git a/configure.ac b/configure.ac
+index 412a3f014..6a80c2a92 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -908,38 +908,62 @@ fi
+ dnl Libetpan
+ AC_MSG_CHECKING([whether to use libetpan])
+ if test x"$enable_libetpan" = xyes; then
+- AC_MSG_RESULT(yes)
+- libetpan_result=no
+- AC_PATH_PROG(libetpanconfig, [libetpan-config])
+- if test "x$libetpanconfig" != "x"; then
+- CPPFLAGS="$CPPFLAGS `$libetpanconfig --cflags 2>/dev/null`"
+- AC_CHECK_HEADER(libetpan/libetpan.h, [libetpan_result=yes])
+- if test "x$libetpan_result" = "xyes"; then
+- AC_MSG_CHECKING([whether libetpan-config hints compiles and links fine])
+- LIBS="$LIBS `$libetpanconfig --libs 2>/dev/null`"
+- AC_TRY_LINK([#include <libetpan/dbstorage.h>], [db_mailstorage_init(NULL, NULL);], [libetpan_result=yes], [libetpan_result=no])
+- AC_MSG_RESULT([$libetpan_result])
+- fi
+- fi
+- if test "x$libetpan_result" = "xyes"; then
+- LIBETPAN_CPPFLAGS="`$libetpanconfig --cflags`"
+- LIBETPAN_LIBS="`$libetpanconfig --libs`"
+- LIBETPAN_VERSION=`$libetpanconfig --version | $AWK -F. '{printf "%d", ($1 * 100) + $2}'`
+- if test "$LIBETPAN_VERSION" -lt "57"; then
+- AC_MSG_RESULT([*** Claws Mail requires libetpan 0.57 or newer. See http://www.etpan.org/])
+- AC_MSG_RESULT([*** You can use --disable-libetpan if you don't need IMAP4 and/or NNTP support.])
++ AC_MSG_RESULT(yes)
++
++ libetpan_config=no
++ libetpan_result=no
++ libetpan_versiontype=0
++
++ # since 1.9.4, libetpan uses pkg-config
++ PKG_CHECK_MODULES([LIBETPAN], [libetpan >= 1.9.4],
++ [
++ LIBETPAN_VERSION=`pkg-config --modversion | $AWK -F. '{printf "%d", ($1 * 10000) + ($2 * 100) + $3}'`
++ libetpan_config=yes
++ ],
++ [
++ # before 1.9.4, libetpan uses its own libetpan-config script
++ AC_PATH_PROG(libetpanconfig, [libetpan-config])
++ if test "x$libetpanconfig" != "x"; then
++ LIBETPAN_CPPFLAGS="`$libetpanconfig --cflags`"
++ LIBETPAN_LIBS="`$libetpanconfig --libs`"
++ # support libetpan version like x.x and x.x.x
++ libetpan_versiontype=`$libetpanconfig --version | tr -dc . | wc -c`
++ if test $libetpan_versiontype -eq 1; then
++ LIBETPAN_VERSION=`$libetpanconfig --version | $AWK -F. '{printf "%d", ($1 * 100) + $2}'`
++ else
++ LIBETPAN_VERSION=`$libetpanconfig --version | $AWK -F. '{printf "%d", ($1 * 10000) + ($2 * 100) + $3}'`
++ fi
++ libetpan_config=yes
++ fi
++ ])
++ if test "x$libetpan_config" = "xyes"; then
++ CPPFLAGS="$CPPFLAGS $LIBETPAN_FLAGS"
++ AC_CHECK_HEADER(libetpan/libetpan.h, [libetpan_result=yes])
++ if test "x$libetpan_result" = "xyes"; then
++ AC_MSG_CHECKING([whether libetpan-config hints compiles and links fine])
++ LIBS="$LIBS $LIBETPAN_LIBS"
++ AC_TRY_LINK([#include <libetpan/dbstorage.h>], [db_mailstorage_init(NULL, NULL);], [libetpan_result=yes], [libetpan_result=no])
++ AC_MSG_RESULT([$libetpan_result])
++ fi
++ fi
++ if test "x$libetpan_result" = "xyes"; then
++ if test $libetpan_versiontype -eq 1; then
++ if test "$LIBETPAN_VERSION" -lt "57"; then
++ AC_MSG_RESULT([*** Claws Mail requires libetpan 0.57 or newer. See http://www.etpan.org/])
++ AC_MSG_RESULT([*** You can use --disable-libetpan if you don't need IMAP4 and/or NNTP support.])
+ AC_MSG_ERROR([libetpan 0.57 not found])
+- fi
+- AC_SUBST(LIBETPAN_FLAGS)
+- AC_SUBST(LIBETPAN_LIBS)
+- AC_DEFINE(HAVE_LIBETPAN, 1, Define if you want IMAP and/or NNTP support.)
+- else
+- AC_MSG_RESULT([*** Claws Mail requires libetpan 0.57 or newer. See http://www.etpan.org/ ])
+- AC_MSG_RESULT([*** You can use --disable-libetpan if you don't need IMAP4 and/or NNTP support.])
+- AC_MSG_ERROR([libetpan 0.57 not found])
+- fi
++ fi
++ fi
++ AC_SUBST(LIBETPAN_FLAGS)
++ AC_SUBST(LIBETPAN_LIBS)
++ AC_DEFINE(HAVE_LIBETPAN, 1, Define if you want IMAP and/or NNit TP support.)
++ else
++ AC_MSG_RESULT([*** Claws Mail requires libetpan 0.57 or newer. See http://www.etpan.org/ ])
++ AC_MSG_RESULT([*** You can use --disable-libetpan if you don't need IMAP4 and/or NNTP support.])
++ AC_MSG_ERROR([libetpan 0.57 not found])
++ fi
+ else
+- AC_MSG_RESULT(no)
++ AC_MSG_RESULT(no)
+ fi
+ AM_CONDITIONAL(CLAWS_LIBETPAN, test "x$libetpan_result" = "xyes")
+
diff --git a/user/ode/APKBUILD b/user/ode/APKBUILD
index 24c1fcc74..9e1f520d1 100644
--- a/user/ode/APKBUILD
+++ b/user/ode/APKBUILD
@@ -13,11 +13,10 @@ makedepends="autoconf automake libtool"
subpackages="$pkgname-dev"
source="https://bitbucket.org/odedevs/ode/downloads/ode-$pkgver.tar.gz
fix-test-link.patch
+ stdint.patch
"
build() {
- cd "$builddir"
-
./bootstrap
CXXFLAGS="$CXXFLAGS -fpermissive" ./configure \
--build=$CBUILD \
@@ -35,14 +34,13 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
sha512sums="302e6f689851acb9ba0db23e13ab59ae0acbbd8dbdfa7e277b57d870c0d3435274e64da16134fb4b7053f951489c138e485165d79664d11764a88b3437d703d3 ode-0.16.tar.gz
-8630d5d059fd0f623db6af4000666868358002a42ba84817117b1fb5e01c776bb23cbf1c8c43181d7bf40a0d71b640f9d2f9785461d8a77877dcbdadd775792e fix-test-link.patch"
+8630d5d059fd0f623db6af4000666868358002a42ba84817117b1fb5e01c776bb23cbf1c8c43181d7bf40a0d71b640f9d2f9785461d8a77877dcbdadd775792e fix-test-link.patch
+0d618cec0afdab86279687275bf476594897d1dfd7b5619fe6bc05343f22f6292c9598a73ff6f2967d5f39e071abcf282fc673c0ffe33f7efd9bbe56ca674dae stdint.patch"
diff --git a/user/ode/stdint.patch b/user/ode/stdint.patch
new file mode 100644
index 000000000..f3674335e
--- /dev/null
+++ b/user/ode/stdint.patch
@@ -0,0 +1,44 @@
+--- ode-0.16/include/ode/odeconfig.h.old 2018-12-09 20:04:03.000000000 +0000
++++ ode-0.16/include/ode/odeconfig.h 2020-01-12 08:36:16.664428956 +0000
+@@ -32,6 +32,7 @@
+ #include <math.h>
+ #include <string.h>
+ #include <float.h>
++#include <stdint.h>
+
+
+ #include <ode/precision.h>
+@@ -128,20 +129,20 @@
+ typedef __int64 dint64;
+ typedef unsigned __int64 duint64;
+ #else
+- typedef long long dint64;
+- typedef unsigned long long duint64;
++ typedef int64_t dint64;
++ typedef uint64_t duint64;
+ #endif
+- typedef int dint32;
+- typedef unsigned int duint32;
+- typedef short dint16;
+- typedef unsigned short duint16;
+- typedef signed char dint8;
+- typedef unsigned char duint8;
+-
+- typedef dint32 dintptr;
+- typedef duint32 duintptr;
+- typedef dint32 ddiffint;
+- typedef duint32 dsizeint;
++ typedef int32_t dint32;
++ typedef uint32_t duint32;
++ typedef int16_t dint16;
++ typedef uint16_t duint16;
++ typedef int8_t dint8;
++ typedef uint8_t duint8;
++
++ typedef intptr_t dintptr;
++ typedef uintptr_t duintptr;
++ typedef ptrdiff_t ddiffint;
++ typedef size_t dsizeint;
+
+ #endif
+
diff --git a/user/s6-linux-utils/APKBUILD b/user/s6-linux-utils/APKBUILD
index e71092f9a..54ff1b005 100644
--- a/user/s6-linux-utils/APKBUILD
+++ b/user/s6-linux-utils/APKBUILD
@@ -9,13 +9,12 @@ arch="all"
options="!check"
license="ISC"
_skalibs_version=2.9
-depends=
+depends=""
makedepends="skalibs-dev>=$_skalibs_version skalibs-libs-dev>=$_skalibs_version"
subpackages="$pkgname-doc"
source="https://skarnet.org/software/$pkgname/$pkgname-$pkgver.tar.gz"
build() {
- cd "$builddir"
./configure \
--disable-allstatic \
--prefix=/usr \
@@ -24,17 +23,15 @@ build() {
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
-
doc() {
- pkgdesc="$pkgdesc (documentation)"
- depends=
- install_if="docs $pkgname=$pkgver-r$pkgrel"
- mkdir -p "$subpkgdir/usr/share/doc"
- cp -a "$builddir/doc" "$subpkgdir/usr/share/doc/$pkgname"
+ pkgdesc="$pkgdesc (documentation)"
+ depends=""
+ install_if="docs $pkgname=$pkgver-r$pkgrel"
+ mkdir -p "$subpkgdir/usr/share/doc"
+ cp -a "$builddir/doc" "$subpkgdir/usr/share/doc/$pkgname"
}
sha512sums="59c58c4d8e13b7a6e0215f21978f8ac2ac54fc3685884204ea1f011f2a882b9381a9686cbb24c9e566e322c14174dda40368c308e37e9c44f6a1687231d108a2 s6-linux-utils-2.5.1.1.tar.gz"
diff --git a/user/s6-portable-utils/APKBUILD b/user/s6-portable-utils/APKBUILD
index fb81c7529..5a7a85540 100644
--- a/user/s6-portable-utils/APKBUILD
+++ b/user/s6-portable-utils/APKBUILD
@@ -9,13 +9,12 @@ arch="all"
options="!check"
license="ISC"
_skalibs_version=2.9
-depends=
+depends=""
makedepends="skalibs-dev>=$_skalibs_version skalibs-libs-dev>=$_skalibs_version"
subpackages="$pkgname-doc"
source="https://skarnet.org/software/$pkgname/$pkgname-$pkgver.tar.gz"
build() {
- cd "$builddir"
./configure \
--disable-allstatic \
--prefix=/usr \
@@ -24,17 +23,14 @@ build() {
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
-
doc() {
- pkgdesc="$pkgdesc (documentation)"
- depends=
- install_if="docs $pkgname=$pkgver-r$pkgrel"
- mkdir -p "$subpkgdir/usr/share/doc"
- cp -a "$builddir/doc" "$subpkgdir/usr/share/doc/$pkgname"
+ pkgdesc="$pkgdesc (documentation)"
+ install_if="docs $pkgname=$pkgver-r$pkgrel"
+ mkdir -p "$subpkgdir/usr/share/doc"
+ cp -a "$builddir/doc" "$subpkgdir/usr/share/doc/$pkgname"
}
sha512sums="2e74befec59ae6d3f27cb5f2bb92db23af484043e4d5e53e4816d75927059af6698614a4c3ce7ed7e380a88d5bbe88e41dcbc97eb607a10d7a3e46b8a36744ed s6-portable-utils-2.2.2.1.tar.gz"
diff --git a/user/serf/APKBUILD b/user/serf/APKBUILD
index 06cc98c2a..4ff3c66dd 100644
--- a/user/serf/APKBUILD
+++ b/user/serf/APKBUILD
@@ -15,18 +15,14 @@ source="https://www.apache.org/dist/serf/serf-$pkgver.tar.bz2
"
build() {
- cd "$builddir"
scons PREFIX=/usr -j "$JOBS"
}
check() {
- cd "$builddir"
scons test
}
package() {
- cd "$builddir"
- local _header
install -D -m644 libserf-1.a "$pkgdir"/usr/lib/libserf-1.a
install -D -m755 libserf-1.so.1.3.0 "$pkgdir"/usr/lib/libserf-1.so.1.3.0
ln -s libserf-1.so.1.3.0 "$pkgdir"/usr/lib/libserf-1.so.1
diff --git a/user/xmoto/APKBUILD b/user/xmoto/APKBUILD
index 62bbdd1e7..f13b7d68d 100644
--- a/user/xmoto/APKBUILD
+++ b/user/xmoto/APKBUILD
@@ -10,7 +10,8 @@ license="GPL-2.0+"
depends=""
makedepends="bzip2-dev curl-dev glu-dev libjpeg-turbo-dev libpng-dev
libxdg-basedir-dev libxml2-dev lua5.3-dev mesa-dev ode-dev sdl-dev
- sdl_mixer-dev sdl_net-dev sdl_ttf-dev sqlite-dev zlib-dev"
+ sdl_mixer-dev sdl_net-dev sdl_ttf-dev sqlite-dev zlib-dev
+ autoconf automake"
subpackages="$pkgname-doc $pkgname-lang"
source="http://download.tuxfamily.org/xmoto/xmoto/0.5.11/xmoto-$pkgver-src.tar.gz
stupid-lua.patch
@@ -18,14 +19,12 @@ source="http://download.tuxfamily.org/xmoto/xmoto/0.5.11/xmoto-$pkgver-src.tar.g
"
prepare() {
- cd "$builddir"
default_prepare
update_config_sub
rm -r src/ode
}
build() {
- cd "$builddir"
./bootstrap
CPPFLAGS="$CPPFLAGS -D_GLIBCXX_USE_CXX11_ABI=0" \
LDFLAGS="$LDFLAGS $(pkg-config --libs lua)" \
@@ -41,12 +40,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
install -D -m644 "$builddir"/extra/xmoto.desktop \
"$pkgdir"/usr/share/applications/xmoto.desktop