summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-21 01:21:59 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-21 01:21:59 +0000
commite64e8125463de387720322e2fc84e2943811dfdf (patch)
treebbb1a55d0e9e9273304af2ec17cb34d025ae1f4a
parent0bde1639103fa9dab748dc0bfc7d483c652e96a7 (diff)
downloadpackages-e64e8125463de387720322e2fc84e2943811dfdf.tar.gz
packages-e64e8125463de387720322e2fc84e2943811dfdf.tar.bz2
packages-e64e8125463de387720322e2fc84e2943811dfdf.tar.xz
packages-e64e8125463de387720322e2fc84e2943811dfdf.zip
system/t*: modernise, fix metadata
-rw-r--r--system/tcl/APKBUILD6
-rw-r--r--system/tzdata/APKBUILD2
2 files changed, 2 insertions, 6 deletions
diff --git a/system/tcl/APKBUILD b/system/tcl/APKBUILD
index 9bd27f90c..e12202883 100644
--- a/system/tcl/APKBUILD
+++ b/system/tcl/APKBUILD
@@ -33,7 +33,6 @@ build() {
case "$CARCH" in
x86_64) _64bit="--enable-64bit";;
esac
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -47,7 +46,6 @@ build() {
}
package() {
- cd "$builddir"
export LD_LIBRARY_PATH="$_builddir"
make -j1 INSTALL_ROOT="${pkgdir}" install install-private-headers
@@ -59,8 +57,6 @@ package() {
}
check() {
- cd "$builddir"
-
# thread-4.5 and thread-5* is suppressed because it tests UB
# http* is suppressed because it tries to do network i/o
# unixInit-3* is suppressed due to hardcoded locale assumptions
@@ -69,7 +65,7 @@ check() {
dev() {
default_dev
- cd $pkgdir
+ cd "$pkgdir"
for i in $(find . -name '*.c' -o -name '*Config.sh'); do
mkdir -p "$subpkgdir"/${i%/*}
mv $i "$subpkgdir"/${i%/*}/ || return 1
diff --git a/system/tzdata/APKBUILD b/system/tzdata/APKBUILD
index cdcbdbc26..4fbdec71f 100644
--- a/system/tzdata/APKBUILD
+++ b/system/tzdata/APKBUILD
@@ -12,8 +12,8 @@ arch="all"
options="!check" # Until we have sgml-common.
license="Public-Domain"
depends=""
-makedepends=""
checkdepends="sgml-common sp"
+makedepends=""
subpackages="$pkgname-doc"
source="https://www.iana.org/time-zones/repository/releases/tzcode$_tzcodever.tar.gz
https://www.iana.org/time-zones/repository/releases/tzdata$pkgver.tar.gz