summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZach van Rijn <me@zv.io>2024-12-08 04:24:19 +0000
committerZach van Rijn <me@zv.io>2024-12-08 04:25:18 +0000
commitfc41716954da50c07b83fb139df5668b95a5d3c5 (patch)
tree27acc09233677bf2c3b8377e2483ad72eb00c4ed
parent7fb83a9f59dec68e4c906aef243e5d7a595e95d2 (diff)
downloadpackages-fc41716954da50c07b83fb139df5668b95a5d3c5.tar.gz
packages-fc41716954da50c07b83fb139df5668b95a5d3c5.tar.bz2
packages-fc41716954da50c07b83fb139df5668b95a5d3c5.tar.xz
packages-fc41716954da50c07b83fb139df5668b95a5d3c5.zip
user/tmux: bump { 3.5 --> 3.5a }. no 'yacc' needed.
The patch is inverted to effectively revert this requirement.
-rw-r--r--user/tmux/APKBUILD14
-rw-r--r--user/tmux/no-yacc-needed.patch26
2 files changed, 37 insertions, 3 deletions
diff --git a/user/tmux/APKBUILD b/user/tmux/APKBUILD
index 79f99f068..5edfa97f5 100644
--- a/user/tmux/APKBUILD
+++ b/user/tmux/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Zach van Rijn <me@zv.io>
pkgname=tmux
-pkgver=3.5
+pkgver=3.5a
pkgrel=0
pkgdesc="Tool to control multiple terminals from a single terminal"
url="https://github.com/tmux/tmux/wiki"
@@ -10,7 +10,14 @@ license="MIT"
depends="ncurses-terminfo"
makedepends="bsd-compat-headers libevent-dev libutempter-dev ncurses-dev"
subpackages="$pkgname-doc"
-source="https://github.com/tmux/tmux/releases/download/$pkgver/$pkgname-$pkgver.tar.gz"
+source="https://github.com/tmux/tmux/releases/download/$pkgver/$pkgname-$pkgver.tar.gz
+ no-yacc-needed.patch
+ "
+
+prepare() {
+ default_prepare
+ autoreconf -fiv
+}
build() {
./configure \
@@ -36,4 +43,5 @@ package() {
install -m644 "README" "$pkgdir"/usr/share/doc/$pkgname/
}
-sha512sums="bb3ca1ae8b330c3efc8fcbe8a65a40f78beadaf08c79265f6377c4187d26028e485e5404b832bbea16b170fd9bbdf2f1554d67dd3b1289e183fca19df460b695 tmux-3.5.tar.gz"
+sha512sums="2383e99aec2dcdb1d899793d5ecab40a68b921194f84770d3f4d19712bfc85590657a99d2a9a7bec36d4ba5ab39fa713f13937b0acad3b61cd9b2302dba61d43 tmux-3.5a.tar.gz
+54494c910f361e23433f276c49e6257b1ccb028ffba1af032e5494e786eb35506d495714916774956db875306e090edd0c2bf8433b2cffc50c4a25d45dfb0594 no-yacc-needed.patch"
diff --git a/user/tmux/no-yacc-needed.patch b/user/tmux/no-yacc-needed.patch
new file mode 100644
index 000000000..1e6c706b3
--- /dev/null
+++ b/user/tmux/no-yacc-needed.patch
@@ -0,0 +1,26 @@
+From 00812c9053a0b1067f833925b726086a67d8528d Mon Sep 17 00:00:00 2001
+From: Nicholas Marriott <nicholas.marriott@gmail.com>
+Date: Tue, 2 Aug 2022 11:52:09 +0100
+Subject: [PATCH] Check for $YACC, from Wei Shih in GitHub issue 3267.
+
+---
+ configure.ac | 6 ++++++
+ 1 file changed, 6 insertions(+)
+
+diff --git a/configure.ac b/configure.ac
+index 276f71c8bf..8e84604289 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -267,12 +267,6 @@ if test "x$found_libevent" = xno; then
+ AC_MSG_ERROR("libevent not found")
+ fi
+
+-# Look for yacc.
+-AC_CHECK_PROG(found_yacc, $YACC, yes, no)
+-if test "x$found_yacc" = xno; then
+- AC_MSG_ERROR("yacc not found")
+-fi
+-
+ # Look for ncurses or curses. Try pkg-config first then directly for the
+ # library.
+ PKG_CHECK_MODULES(