summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorst Burkhardt <horst@adelielinux.org>2024-09-05 13:25:38 +1000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2024-12-05 19:54:32 -0600
commitfe76ab5f761f63822c7e76fe0f8d07890eef06aa (patch)
treebdd36657c9512d11d0cfe42e99e1077a1c9a6dd9
parentad8cce69d881313bdc4f3400ef447d494377c590 (diff)
downloadpackages-fe76ab5f761f63822c7e76fe0f8d07890eef06aa.tar.gz
packages-fe76ab5f761f63822c7e76fe0f8d07890eef06aa.tar.bz2
packages-fe76ab5f761f63822c7e76fe0f8d07890eef06aa.tar.xz
packages-fe76ab5f761f63822c7e76fe0f8d07890eef06aa.zip
bootstrap/classpath-0.93: correct issues id'd by awilfox
Signed-off-by: Horst Burkhardt <horst@adelielinux.org>
-rw-r--r--bootstrap/classpath-0.93/APKBUILD13
1 files changed, 4 insertions, 9 deletions
diff --git a/bootstrap/classpath-0.93/APKBUILD b/bootstrap/classpath-0.93/APKBUILD
index 8ef9df182..871825b90 100644
--- a/bootstrap/classpath-0.93/APKBUILD
+++ b/bootstrap/classpath-0.93/APKBUILD
@@ -5,19 +5,14 @@ pkgrel=0
pkgdesc="GNU Classpath Java Class Library"
url="https://www.gnu.org/software/classpath/"
arch="all"
-options="!check"
+options="!check" #No test suite provided.
license="GPL-2.0-with-classpath-exception"
depends=""
makedepends="zlib-dev fastjar jikes libltdl"
subpackages="$pkgname-dev $pkgname-doc"
-source="ftp://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.gz
+source="https://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.gz
add-aarch64-endianness.patch
em64t-vmfile-return.patch"
-builddir="$srcdir/"
-
-prepare() {
- default_prepare
- }
build() {
export JAVAC="/usr/bin/jikes"
@@ -34,11 +29,11 @@ build() {
--bindir=/usr/libexec/classpath \
--with-glibj-dir=/usr/share/classpath \
--includedir=/usr/include/classpath
- make DESTDIR=/usr
+ make DESTDIR="$pkgdir"/usr
}
package() {
- make DESTDIR=/usr install
+ make DESTDIR="$pkgdir"/usr install
}
sha512sums="69d831361085514bb7c5607fa694914cc01bc9fe589b7744d5534c97d434722193a1b68a336642d0dba9a3b50e9acea0364741790e9f19d196e5956a51c320b0 classpath-0.93.tar.gz