summaryrefslogtreecommitdiff
path: root/bootstrap/llvm16/APKBUILD
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2024-10-21 06:48:43 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2024-10-21 06:48:43 -0500
commit1cc4415e5d2f5b28e7b85c7e531b46a0df7f6ef0 (patch)
tree7ddcc8ebe1b6b642fd225b0bbdaef5b4f3f9f2b3 /bootstrap/llvm16/APKBUILD
parent55815ff45513e7877423f9a8cc89258ba2a83339 (diff)
downloadpackages-1cc4415e5d2f5b28e7b85c7e531b46a0df7f6ef0.tar.gz
packages-1cc4415e5d2f5b28e7b85c7e531b46a0df7f6ef0.tar.bz2
packages-1cc4415e5d2f5b28e7b85c7e531b46a0df7f6ef0.tar.xz
packages-1cc4415e5d2f5b28e7b85c7e531b46a0df7f6ef0.zip
bootstrap/llvm16: Fix issues on pmmx
Use fast precision to avoid x87-related bugs in SSE register scheduling. Import fix from LLVM 14 for the test failure caused by fast precision. Ref: #1200 Closes: #1258
Diffstat (limited to 'bootstrap/llvm16/APKBUILD')
-rw-r--r--bootstrap/llvm16/APKBUILD15
1 files changed, 15 insertions, 0 deletions
diff --git a/bootstrap/llvm16/APKBUILD b/bootstrap/llvm16/APKBUILD
index df88dd1b4..841085be8 100644
--- a/bootstrap/llvm16/APKBUILD
+++ b/bootstrap/llvm16/APKBUILD
@@ -24,6 +24,7 @@ source="https://github.com/llvm/llvm-project/releases/download/llvmorg-$pkgver/l
disable-FileSystemTest.CreateDir-perms-assert.patch
dyld-elf-ppc32.patch
exegesis-mcjit.patch
+ graph-diff-simple.txt
hexagon.patch
macho32.patch
musl-ppc64-elfv2.patch
@@ -97,12 +98,25 @@ prepare() {
test/tools/UpdateTestChecks \
test/ExecutionEngine/MCJIT/load-object-a.ll \
;
+ #1202
+ case $CARCH in
+ pmmx)
+ mv "$srcdir"/graph-diff-simple.txt \
+ test/tools/llvm-xray/X86/graph-diff-simple.txt ;;
+ esac
}
build() {
# Auto-detect it by guessing either.
ffi_include_dir="$(pkg-config --cflags-only-I libffi | sed 's|^-I||g')"
+ case $CTARGET_ARCH in
+ pmmx)
+ # The standard precision breaks more than it fixes; there are
+ # 4 failures in standard mode and only (different) 1 in fast.
+ export CXXFLAGS="$CXXFLAGS -fexcess-precision=fast";;
+ esac
+
# Disabled m68k because the endianness fix from llvm18 doesn't work.
cmake -G "Unix Makefiles" -Wno-dev \
-DCMAKE_BUILD_TYPE=Release \
@@ -259,6 +273,7 @@ e6fec46f3a1183774e4a47b81f3287adc5aa28ebdd52f614c1111fb157cd3137d1b86e04ca76a92b
8e694af50a9f1f8a3dcf7c0e1ce1165237011767e3514271984877882962e492057efd16f0e6e303ee534a48c039c8ec00ed8a34eb9e9826b0324100292695f9 disable-FileSystemTest.CreateDir-perms-assert.patch
962ea62f96927f397a234c8770fd5a41d5c8ef528de56da6da76908369ee0e9faca2fcba46b3957a928b8138b46c7c0d8c5f353088009e1921f9c3cfffd96081 dyld-elf-ppc32.patch
5f24f99e31b8e0d1d7a7253be028df55f3524ff600c037404a4870ed22c02467f378b222d7fdd3d7af5b1ef006a90ec0c32c44122771e2ea8763eb62dcfca9dc exegesis-mcjit.patch
+a1533f4b9d35e1069fd065fbeb5fedce96fa49fdb007f994d8921d8a04cf2caadca276bbd9553ff86040b0f9dfce489c385fa2a7434e2dee3732942e6914db4e graph-diff-simple.txt
807587a0c897d47a01a846c5c4f7cbf1f2d16437a163b66ee2381a7147e9d04b0141b2c76d022db61903d0d2841ddb267ba98c66c9e41501ca41837659743df8 hexagon.patch
de9791cc476817782b553c4edab696132da4ed2b9a3d80dbf1b85b7dc7a8c5e4caf14f2f26e33c27cd80a91b36709d3b24caea910c0a6315ffbb297cb748468d macho32.patch
bec1fe4761dae33a8012a54b7bbdd179cac82febcd46ace1844772c06f207661c903f05fcb7a5ebbbece3e33a88b20a5d9b31b40e8a8cd5c626aec04cb6735be musl-ppc64-elfv2.patch