summaryrefslogtreecommitdiff
path: root/bootstrap
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2024-12-07 21:10:58 -0600
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2024-12-07 21:10:58 -0600
commit7fb83a9f59dec68e4c906aef243e5d7a595e95d2 (patch)
tree5a116b8ad1d747b75705eb8339522b4476f92869 /bootstrap
parentbc7fcd1b36a697ab8ce5fd6ace425a9143330dce (diff)
downloadpackages-7fb83a9f59dec68e4c906aef243e5d7a595e95d2.tar.gz
packages-7fb83a9f59dec68e4c906aef243e5d7a595e95d2.tar.bz2
packages-7fb83a9f59dec68e4c906aef243e5d7a595e95d2.tar.xz
packages-7fb83a9f59dec68e4c906aef243e5d7a595e95d2.zip
user/llvm18: Ensure stack sizes are set properly
* Run `chelf` on the binaries after they are installed, in case they are re-linked during the install process. This was the cause of #1272. * Disable two more tests that caused failures on gwyn due to #1250. Closes: #1272
Diffstat (limited to 'bootstrap')
-rw-r--r--bootstrap/llvm18/APKBUILD9
1 files changed, 9 insertions, 0 deletions
diff --git a/bootstrap/llvm18/APKBUILD b/bootstrap/llvm18/APKBUILD
index 3c0f57c68..0e1ff4d02 100644
--- a/bootstrap/llvm18/APKBUILD
+++ b/bootstrap/llvm18/APKBUILD
@@ -130,7 +130,9 @@ prepare() {
#1250
rm -v \
+ test/tools/dsymutil/ARM/DWARFLinkerParallel/accel-imported-declarations.test \
test/tools/dsymutil/X86/DWARFLinkerParallel/odr-member-functions.cpp \
+ test/tools/dsymutil/X86/DWARFLinkerParallel/odr-parents.test \
test/tools/dsymutil/X86/DWARFLinkerParallel/odr-predictable-output2.test \
test/tools/dsymutil/X86/DWARFLinkerParallel/odr-string.test \
test/tools/dsymutil/X86/DWARFLinkerParallel/odr-uniquing.cpp
@@ -246,6 +248,13 @@ package() {
ln -s ../../include/$pkgname include
ln -s "$pkgdir"/usr/lib/cmake/llvm ../$pkgname/lib/cmake/llvm
+
+ # Thread 3 requires a lot of stack space to LTO when targeting ARM.
+ # Note that this occurs even when crossing (on a ppc64 host).
+ chelf -s 1048576 bin/llvm-lto2
+ # Needed for parallel-linker support (pthread stack size).
+ chelf -s 1048576 bin/dsymutil
+ chelf -s 1048576 bin/llvm-dwarfutil
}
static() {