summaryrefslogtreecommitdiff
path: root/legacy/libreoffice/gettext-tiny.patch
diff options
context:
space:
mode:
authorZach van Rijn <me@zv.io>2022-11-25 19:29:48 -0600
committerZach van Rijn <me@zv.io>2022-11-25 20:02:32 -0600
commitd7e5a71711acc59d51324fd29340e00b720ba625 (patch)
treec820d9dcf99598f59fc86e07182de201fb704ab6 /legacy/libreoffice/gettext-tiny.patch
parentb5aeea18b753bd91d3967a23d3e65478733da3cc (diff)
downloadpackages-d7e5a71711acc59d51324fd29340e00b720ba625.tar.gz
packages-d7e5a71711acc59d51324fd29340e00b720ba625.tar.bz2
packages-d7e5a71711acc59d51324fd29340e00b720ba625.tar.xz
packages-d7e5a71711acc59d51324fd29340e00b720ba625.zip
user/libreoffice: Move to legacy/
We have decided to not ship LO for RC3 in its current form; bumping it to the latest version will require significant effort to bump Skia, which will be done post-RC3.
Diffstat (limited to 'legacy/libreoffice/gettext-tiny.patch')
-rw-r--r--legacy/libreoffice/gettext-tiny.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/legacy/libreoffice/gettext-tiny.patch b/legacy/libreoffice/gettext-tiny.patch
new file mode 100644
index 000000000..a63f45553
--- /dev/null
+++ b/legacy/libreoffice/gettext-tiny.patch
@@ -0,0 +1,38 @@
+gettext-tiny does not currently ship msguniq, so let's cheat around it
+
+--- libreoffice-6.2.1.2/solenv/gbuild/AllLangMoTarget.mk
++++ libreoffice-6.2.1.2/solenv/gbuild/AllLangMoTarget.mk
+@@ -40,10 +40,10 @@
+ $(call gb_Helper_abbreviate_dirs,\
+ mkdir -p $(dir $@) && \
+ if test -e $(gb_POLOCATION)/$(LANGUAGE)/$(POLOCATION)/messages.po; then \
+- $(MSGUNIQ) --force-po $(gb_POLOCATION)/$(LANGUAGE)/$(POLOCATION)/messages.po | $(MSGFMT) - -o $@; \
++ cat $(gb_POLOCATION)/$(LANGUAGE)/$(POLOCATION)/messages.po | $(MSGFMT) - -o $@; \
+ else \
+ echo missing $(gb_POLOCATION)/$(LANGUAGE)/$(POLOCATION)/messages.po && \
+- $(MSGUNIQ) --force-po $(SRCDIR)/solenv/bin/dummy.po | $(MSGFMT) - -o $@; \
++ cat $(SRCDIR)/solenv/bin/dummy.po | $(MSGFMT) - -o $@; \
+ fi)
+
+ #$(info $(call gb_MoTarget_get_target,$(1)))
+--- libreoffice-6.2.1.2/configure.ac
++++ libreoffice-6.2.1.2/configure.ac
+@@ -12106,18 +12106,6 @@ else
+ fi
+ fi
+ fi
+- if test -z "$MSGUNIQ"; then
+- if test -n "$LODE_HOME" -a -x "$LODE_HOME/opt/bin/msguniq" ; then
+- MSGUNIQ="$LODE_HOME/opt/bin/msguniq"
+- elif test -x "/opt/lo/bin/msguniq"; then
+- MSGUNIQ="/opt/lo/bin/msguniq"
+- else
+- AC_CHECK_PROGS(MSGUNIQ, [msguniq])
+- if test -z "$MSGUNIQ"; then
+- AC_MSG_ERROR([msguniq not found. Install GNU gettext, or re-run without languages.])
+- fi
+- fi
+- fi
+ fi
+ AC_SUBST(MSGFMT)
+ AC_SUBST(MSGUNIQ)