summaryrefslogtreecommitdiff
path: root/legacy/which/APKBUILD
diff options
context:
space:
mode:
authorCyberLeo <cyberleo@cyberleo.net>2020-03-28 05:45:52 -0500
committerCyberLeo <cyberleo@cyberleo.net>2020-03-28 05:45:52 -0500
commit9297468fa579836e3a6a381b798feb6b78217c2d (patch)
tree53168212f427afbcf0693b534530a4af803152e9 /legacy/which/APKBUILD
parenta63cc05c53a6f4c22422dc8c69808b14d87a6f6e (diff)
parentda5a69b65a8791fffa6e93366ee585f87eff136d (diff)
downloadpackages-9297468fa579836e3a6a381b798feb6b78217c2d.tar.gz
packages-9297468fa579836e3a6a381b798feb6b78217c2d.tar.bz2
packages-9297468fa579836e3a6a381b798feb6b78217c2d.tar.xz
packages-9297468fa579836e3a6a381b798feb6b78217c2d.zip
Merge branch 'master' into zfs
Diffstat (limited to 'legacy/which/APKBUILD')
-rw-r--r--legacy/which/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/legacy/which/APKBUILD b/legacy/which/APKBUILD
new file mode 100644
index 000000000..f8360b7b7
--- /dev/null
+++ b/legacy/which/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Stuart Cardall <developer@it-offshore.co.uk>
+# Maintainer: Kiyoshi Aman <adelie@aerdan.vulpine.house>
+pkgname=which
+pkgver=2.21
+pkgrel=2
+pkgdesc="A utility to show the full path of commands"
+url="http://savannah.gnu.org/projects/which"
+arch="all"
+license="GPL-2.0+ AND LGPL-2.0+ AND GPL-3.0+"
+makedepends=""
+subpackages="$pkgname-doc"
+source="https://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.gz"
+provider_priority=1
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="d2f04a5c5291f2d7d1226982da7cf999d36cfe24d3f7bda145508efcfb359511251d3c68b860c0ddcedd66b15a0587b648a35ab6d1f173707565305c506dfc61 which-2.21.tar.gz"