summaryrefslogtreecommitdiff
path: root/legacy
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2020-07-25 02:19:11 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2020-07-25 02:19:11 +0000
commit6b9635f493367d712260a86500518448691e1b9d (patch)
tree704e492e79bcf4d0caea36044c1e6af818971877 /legacy
parentfd76be540ea686e379662b3798736861b14da16a (diff)
downloadpackages-6b9635f493367d712260a86500518448691e1b9d.tar.gz
packages-6b9635f493367d712260a86500518448691e1b9d.tar.bz2
packages-6b9635f493367d712260a86500518448691e1b9d.tar.xz
packages-6b9635f493367d712260a86500518448691e1b9d.zip
user/consolekit2: Move to legacy
Diffstat (limited to 'legacy')
-rw-r--r--legacy/consolekit2/APKBUILD54
-rw-r--r--legacy/consolekit2/consolekit2.initd9
-rw-r--r--legacy/consolekit2/pam-foreground-compat.ck17
-rw-r--r--legacy/consolekit2/poweroff.patch22
4 files changed, 102 insertions, 0 deletions
diff --git a/legacy/consolekit2/APKBUILD b/legacy/consolekit2/APKBUILD
new file mode 100644
index 000000000..084504191
--- /dev/null
+++ b/legacy/consolekit2/APKBUILD
@@ -0,0 +1,54 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgbase=ConsoleKit2
+pkgname=consolekit2
+pkgver=1.2.1
+pkgrel=1
+pkgdesc="Framework for defining and tracking users, login sessions, and seats"
+url="https://consolekit2.github.io/ConsoleKit2"
+arch="all"
+license="GPL-2.0+"
+depends="eudev polkit"
+checkdepends="libxml2-utils"
+makedepends="acl-dev docbook-xml eudev-dev glib-dev libdrm-dev libevdev-dev
+ libnih-dev libxslt-dev linux-pam-dev polkit-dev xmlto xorg-server-dev
+ zlib-dev"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang $pkgname-openrc"
+source="https://github.com/ConsoleKit2/$pkgbase/releases/download/$pkgver/$pkgbase-$pkgver.tar.bz2
+ consolekit2.initd
+ pam-foreground-compat.ck
+ poweroff.patch"
+# Capital "ConsoleKit"
+builddir="$srcdir"/$pkgbase-$pkgver
+
+build() {
+ XMLTO_FLAGS='--skip-validation' ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --disable-static \
+ --enable-pam-module \
+ --enable-udev-acl \
+ --enable-tests \
+ --enable-docbook-docs \
+ --enable-polkit
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+ install -m 755 "$srcdir"/pam-foreground-compat.ck \
+ "$pkgdir"/usr/lib/ConsoleKit/run-session.d/
+ install -D -m755 "$srcdir"/consolekit2.initd \
+ "$pkgdir"/etc/init.d/consolekit
+}
+
+sha512sums="31befe89f7fa604138bfb0722fc6cf12f0934bac004f98fc331004eb5a7f466ed7bd0dc9adc9869da739974208f9a3bc125068ff8a60d4b2badb58ef70a3eb10 ConsoleKit2-1.2.1.tar.bz2
+8c16c452707475bdd4a50d3ade367d52ad92a6560be48b4e21e5b5eadef6e56c39d3d03d3a64f9b45a59eca50179cf5aa9c11978904d5d101db7498fb9bc0339 consolekit2.initd
+3b114fbbe74cfba0bfd4dad0eb1b85d08b4979a998980c1cbcd7f44b8a16b0ceca224680d4f4a1644cd24698f8817e5e8bdfcdc4ead87a122d0e323142f47910 pam-foreground-compat.ck
+033595766671f545ba6c9f3fcb529547d20359cdd8eb901bb7a6c3b319b495038e8072e3b01f2fd264f592b0c7825a79282d8bc590f057a5f62e9fdfedde9c68 poweroff.patch"
diff --git a/legacy/consolekit2/consolekit2.initd b/legacy/consolekit2/consolekit2.initd
new file mode 100644
index 000000000..697eea8f9
--- /dev/null
+++ b/legacy/consolekit2/consolekit2.initd
@@ -0,0 +1,9 @@
+#!/sbin/openrc-run
+
+description="Tracks sessions and seats"
+pidfile="/var/run/ConsoleKit/pid"
+command="/usr/sbin/console-kit-daemon"
+
+depend() {
+ need dbus
+}
diff --git a/legacy/consolekit2/pam-foreground-compat.ck b/legacy/consolekit2/pam-foreground-compat.ck
new file mode 100644
index 000000000..c9255503c
--- /dev/null
+++ b/legacy/consolekit2/pam-foreground-compat.ck
@@ -0,0 +1,17 @@
+#!/bin/sh
+TAGDIR=/var/run/console
+
+[ -n "$CK_SESSION_USER_UID" ] || exit 1
+[ "$CK_SESSION_IS_LOCAL" = "true" ] || exit 0
+
+TAGFILE="$TAGDIR/`getent passwd $CK_SESSION_USER_UID | cut -f 1 -d:`"
+
+if [ "$1" = "session_added" ]; then
+ mkdir -p "$TAGDIR"
+ echo "$CK_SESSION_ID" >> "$TAGFILE"
+fi
+
+if [ "$1" = "session_removed" ] && [ -e "$TAGFILE" ]; then
+ sed -i "\%^$CK_SESSION_ID\$%d" "$TAGFILE"
+ [ -s "$TAGFILE" ] || rm -f "$TAGFILE"
+fi
diff --git a/legacy/consolekit2/poweroff.patch b/legacy/consolekit2/poweroff.patch
new file mode 100644
index 000000000..8ae9d21a5
--- /dev/null
+++ b/legacy/consolekit2/poweroff.patch
@@ -0,0 +1,22 @@
+Most users expect "shutdown" to also power off the machine when
+requested from a graphical environment. "Actions after halting are
+unspecified" when using -h (LSB 3.0) - sysvinit additionally tries to
+power off when using -h, whereas s6-linux-init only halts.
+Use the **non-standard** -P option (implemented by sysvinit and
+s6-linux-init since 1.0.2.0) to request power off after halting.
+
+--- ConsoleKit2-1.2.1/tools/linux/ck-system-stop 2017-06-02 01:31:44.000000000 +0000
++++ ConsoleKit2-1.2.1/tools/linux/ck-system-stop 2019-06-09 17:40:31.110006347 +0000
+@@ -2,10 +2,10 @@
+
+ #Try for common tools
+ if [ -x "/sbin/shutdown" ] ; then
+- /sbin/shutdown -h now
++ /sbin/shutdown -hP now
+ exit $?
+ elif [ -x "/usr/sbin/shutdown" ] ; then
+- /usr/sbin/shutdown -h now
++ /usr/sbin/shutdown -hP now
+ exit $?
+ else
+ exit 1