summaryrefslogtreecommitdiff
path: root/system/abuild
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-20 23:47:13 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-20 23:47:13 +0000
commitd83763c892fe347b0784839e5a4d0197ea773f33 (patch)
tree64983e7c289e0bded45e0b61d6ffd25caf78a05d /system/abuild
parent6095488ca117fb1c9ad3e377fd36cbf2c17c0541 (diff)
downloadpackages-d83763c892fe347b0784839e5a4d0197ea773f33.tar.gz
packages-d83763c892fe347b0784839e5a4d0197ea773f33.tar.bz2
packages-d83763c892fe347b0784839e5a4d0197ea773f33.tar.xz
packages-d83763c892fe347b0784839e5a4d0197ea773f33.zip
system/abuild: support dev and symbols metapackages
Diffstat (limited to 'system/abuild')
-rw-r--r--system/abuild/APKBUILD12
-rw-r--r--system/abuild/auto-dev-symbols.patch18
2 files changed, 23 insertions, 7 deletions
diff --git a/system/abuild/APKBUILD b/system/abuild/APKBUILD
index 30428a27c..cb6cb9ba9 100644
--- a/system/abuild/APKBUILD
+++ b/system/abuild/APKBUILD
@@ -1,10 +1,11 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=abuild
pkgver=3.3.1
-pkgrel=2
+pkgrel=3
pkgdesc="Script to build APK packages"
url="https://code.foxkit.us/adelie/abuild"
arch="all"
+options="suid !check"
license="GPL-2.0-only"
depends="fakeroot sudo pax-utils openssl apk-tools>=2.0.7-r1 libc-utils
attr libarchive-tools pkgconf patch lzip"
@@ -16,10 +17,10 @@ makedepends_host="openssl-dev zlib-dev"
makedepends="$makedepends_host $makedepends_build"
install="$pkgname.pre-install $pkgname.pre-upgrade"
subpackages="abuild-rootbld:_rootbld:noarch $pkgname-doc"
-options="suid !check"
pkggroups="abuild"
source="https://distfiles.adelielinux.org/source/abuild-$pkgver+adelie.tar.xz
keyhole.patch
+ auto-dev-symbols.patch
"
builddir="$srcdir/$pkgname-$pkgver+adelie"
@@ -30,18 +31,14 @@ builddir="$srcdir/$pkgname-$pkgver+adelie"
prepare() {
default_prepare
- cd "$builddir"
sed -i -e "/^CHOST=/s/=.*/=$CHOST/" abuild.conf
}
build() {
- cd "$builddir"
make VERSION="$pkgver-r$pkgrel"
}
package() {
- cd "$builddir"
-
make install VERSION="$pkgver-r$pkgrel" DESTDIR="$pkgdir"
install -m 644 abuild.conf "$pkgdir"/etc/abuild.conf
@@ -60,4 +57,5 @@ _rootbld() {
}
sha512sums="c358f84d198527eeeac1a1aacc101174e18f9f34f692b12a4e4deb6b32d5f3ebdc703c90de6a6f81f195a81eebb90a11f9bfea13ef5db531d9b5d5ae6ecd6a66 abuild-3.3.1+adelie.tar.xz
-757d750d4b5c88bf00774b64f2b93a9461e03f284d9423dc58c581e1309f276628de3114fcb510afd7c3cd55ceb721c1278e42756977c97ebe2597207805318d keyhole.patch"
+757d750d4b5c88bf00774b64f2b93a9461e03f284d9423dc58c581e1309f276628de3114fcb510afd7c3cd55ceb721c1278e42756977c97ebe2597207805318d keyhole.patch
+2aa43539fc465f5abdc7c3d994363b80d1f7494c2d659093e5a2c45056e07617506ad8ea98f0e7d4ebe2596802b76605cd7c9f3ffc5a30c488c30bb36248e3d2 auto-dev-symbols.patch"
diff --git a/system/abuild/auto-dev-symbols.patch b/system/abuild/auto-dev-symbols.patch
new file mode 100644
index 000000000..1fbca7bad
--- /dev/null
+++ b/system/abuild/auto-dev-symbols.patch
@@ -0,0 +1,18 @@
+--- abuild-3.3.1+adelie/abuild.in.old 2019-03-07 00:48:00.110000000 +0000
++++ abuild-3.3.1+adelie/abuild.in 2019-12-20 23:44:19.956669659 +0000
+@@ -1651,6 +1651,7 @@
+ default_dbg() {
+ local f
+ pkgdesc="$pkgdesc (debug symbols)"
++ install_if="symbols $pkgname=$pkgver-r$pkgrel"
+
+ binfiles=$(scanelf -R "$pkgdir" | grep ET_DYN | sed "s:$pkgdir\/::g" | sed "s:ET_DYN ::g")
+ for f in $binfiles; do
+@@ -1681,6 +1682,7 @@
+ local i= j=
+ depends="$depends_dev"
+ pkgdesc="$pkgdesc (development files)"
++ install_if="dev $pkgname=$pkgver-r$pkgrel"
+
+ cd "$pkgdir" || return 0
+ local libdirs=usr/