summaryrefslogtreecommitdiff
path: root/system/at
diff options
context:
space:
mode:
authorMax Rees <maxcrees@me.com>2019-07-21 16:49:33 -0400
committerMax Rees <maxcrees@me.com>2019-07-21 16:49:33 -0400
commit94731625b42d0dfc0fd5111482938584b40c7478 (patch)
treea3bd7f85b1674ffcdb4e74048696012bd3249417 /system/at
parent1c094f0b6391ac321c21351ea3def051b81b1d79 (diff)
downloadpackages-94731625b42d0dfc0fd5111482938584b40c7478.tar.gz
packages-94731625b42d0dfc0fd5111482938584b40c7478.tar.bz2
packages-94731625b42d0dfc0fd5111482938584b40c7478.tar.xz
packages-94731625b42d0dfc0fd5111482938584b40c7478.zip
system/*: use useradd, groupadd instead of adduser, addgroup
Diffstat (limited to 'system/at')
-rw-r--r--system/at/APKBUILD2
-rw-r--r--system/at/at.pre-install4
2 files changed, 3 insertions, 3 deletions
diff --git a/system/at/APKBUILD b/system/at/APKBUILD
index d4bdb4f2e..a50d7fb77 100644
--- a/system/at/APKBUILD
+++ b/system/at/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=at
pkgver=3.1.23
-pkgrel=1
+pkgrel=2
pkgdesc="Delayed job execution and batch processing daemon"
url="https://packages.qa.debian.org/a/at.html"
arch="all"
diff --git a/system/at/at.pre-install b/system/at/at.pre-install
index 78aa4bcf1..1d92862db 100644
--- a/system/at/at.pre-install
+++ b/system/at/at.pre-install
@@ -1,6 +1,6 @@
#!/bin/sh
-addgroup -S at 2>/dev/null
-adduser -S -D -H -s /bin/false -G at -g at at 2>/dev/null
+groupadd -r at 2>/dev/null
+useradd -c at -s /sbin/nologin -g at -r at 2>/dev/null
exit 0