summaryrefslogtreecommitdiff
path: root/system/binutils/APKBUILD
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-11-03 04:08:28 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-11-03 04:08:46 +0000
commit2c3b41e222ff1ad8eefd64fe3641522f3b801526 (patch)
treeaa8f6cf09dc2e74067b72a47a2cbe3212f2e4331 /system/binutils/APKBUILD
parenteb2ac2b0ce4c14f582cb40755b774cb39c963b17 (diff)
downloadpackages-2c3b41e222ff1ad8eefd64fe3641522f3b801526.tar.gz
packages-2c3b41e222ff1ad8eefd64fe3641522f3b801526.tar.bz2
packages-2c3b41e222ff1ad8eefd64fe3641522f3b801526.tar.xz
packages-2c3b41e222ff1ad8eefd64fe3641522f3b801526.zip
system/binutils: disable -z separate-code by default on x86 since it breaks kernels
Diffstat (limited to 'system/binutils/APKBUILD')
-rw-r--r--system/binutils/APKBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/system/binutils/APKBUILD b/system/binutils/APKBUILD
index d8fc3e7c5..4cd3901ec 100644
--- a/system/binutils/APKBUILD
+++ b/system/binutils/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Adelie Platform Group <adelie-devel@lists.adelielinux.org>
pkgname=binutils
pkgver=2.31.1
-pkgrel=0
+pkgrel=1
pkgdesc="Tools necessary to build programs"
url="http://www.gnu.org/software/binutils/"
depends=""
@@ -47,9 +47,11 @@ build() {
_cross_configure="--disable-install-libiberty"
fi
- if [ "$CTARGET_ARCH" = "x86_64" ]; then
- _arch_configure="--enable-targets=x86_64-pep"
- fi
+ # -z separate-code is currently causing kernel miscompiles on x86*
+ case "$CTARGET_ARCH" in
+ x86 | pmmx | i528) _arch_configure="--disable-separate-code" ;;
+ x86_64) _arch_configure="--disable-separate-code --enable-targets=x86_64-pep" ;;
+ esac
case "$CTARGET_ARCH" in
mips*) _hash_style_configure="--enable-default-hash-style=sysv" ;;