summaryrefslogtreecommitdiff
path: root/system/binutils
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-21 00:07:21 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-21 00:07:21 +0000
commit1fc145e97b0ee14150e795d4696a786eba0c8efe (patch)
tree84d69774121778a5ad81951d5f5fb2f9649b28b4 /system/binutils
parentb4e00d02ace367aeee24818164758f3cb35bba75 (diff)
downloadpackages-1fc145e97b0ee14150e795d4696a786eba0c8efe.tar.gz
packages-1fc145e97b0ee14150e795d4696a786eba0c8efe.tar.bz2
packages-1fc145e97b0ee14150e795d4696a786eba0c8efe.tar.xz
packages-1fc145e97b0ee14150e795d4696a786eba0c8efe.zip
system/b*: modernise, fix descriptions
Diffstat (limited to 'system/binutils')
-rw-r--r--system/binutils/APKBUILD19
1 files changed, 8 insertions, 11 deletions
diff --git a/system/binutils/APKBUILD b/system/binutils/APKBUILD
index f5defac52..fc6113836 100644
--- a/system/binutils/APKBUILD
+++ b/system/binutils/APKBUILD
@@ -4,16 +4,16 @@ pkgver=2.32
pkgrel=5
pkgdesc="Tools necessary to build programs"
url="https://www.gnu.org/software/binutils/"
+arch="all"
+# non-PIC is unsupported by musl/ppc
+[ "${CARCH}" != "ppc" ] || options='!check'
+license="GPL-2.0+ AND GPL-3.0+ AND LGPL-2.0+ AND LGPL-2.1+ AND LGPL-3.0+ AND BSD-3-Clause"
depends=""
makedepends_build="byacc flex texinfo"
makedepends_host="zlib-dev"
makedepends="$makedepends_build $makedepends_host"
checkdepends="dejagnu"
-arch="all"
-license="GPL-2.0+ AND GPL-3.0+ AND LGPL-2.0+ AND LGPL-2.1+ AND LGPL-3.0+ AND BSD-3-Clause"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang $pkgname-libs"
-# non-PIC is unsupported by musl/ppc
-[ "${CARCH}" != "ppc" ] || options='!check'
source="https://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.xz
arm-pie.patch
binutils-ld-fix-static-linking.patch
@@ -90,7 +90,6 @@ build() {
*) _hash_style_configure="--enable-default-hash-style=gnu" ;;
esac
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -117,8 +116,11 @@ build() {
make
}
+check() {
+ make check
+}
+
package() {
- cd "$builddir"
make install DESTDIR="$pkgdir"
if [ -d "$pkgdir"/usr/lib64 ]; then
die "Something really bad happened."
@@ -133,11 +135,6 @@ package() {
fi
}
-check() {
- cd "$builddir"
- make check
-}
-
libs() {
pkgdesc="Runtime libraries from binutils"