summaryrefslogtreecommitdiff
path: root/system/bubblewrap
diff options
context:
space:
mode:
authorZach van Rijn <me@zv.io>2022-05-03 22:45:26 +0000
committerZach van Rijn <me@zv.io>2022-05-06 12:37:31 -0500
commitab525f26fbb1d20c58d877214bb2d9931382cd4a (patch)
treea6aacd59dd1b8baf6bdeba37c5b688abafeebbc1 /system/bubblewrap
parent433a7752608e77a7b7281ccfee6f51d093e3a2de (diff)
downloadpackages-ab525f26fbb1d20c58d877214bb2d9931382cd4a.tar.gz
packages-ab525f26fbb1d20c58d877214bb2d9931382cd4a.tar.bz2
packages-ab525f26fbb1d20c58d877214bb2d9931382cd4a.tar.xz
packages-ab525f26fbb1d20c58d877214bb2d9931382cd4a.zip
system/bubblewrap: bump { 0.4.1 --> 0.6.1 }.
Diffstat (limited to 'system/bubblewrap')
-rw-r--r--system/bubblewrap/APKBUILD11
-rw-r--r--system/bubblewrap/realpath-workaround.patch19
-rw-r--r--system/bubblewrap/tests.patch23
3 files changed, 3 insertions, 50 deletions
diff --git a/system/bubblewrap/APKBUILD b/system/bubblewrap/APKBUILD
index 866bdb468..445c74852 100644
--- a/system/bubblewrap/APKBUILD
+++ b/system/bubblewrap/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Timo Teräs <timo.teras@iki.fi>
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=bubblewrap
-pkgver=0.4.1
+pkgver=0.6.1
pkgrel=0
pkgdesc="Unprivileged sandboxing tool"
url="https://github.com/projectatomic/bubblewrap"
@@ -12,10 +12,7 @@ makedepends="autoconf automake libcap-dev docbook-xsl"
checkdepends="python3 sudo"
subpackages="$pkgname-nosuid $pkgname-doc
$pkgname-bash-completion:bashcomp:noarch"
-source="bubblewrap-$pkgver.tar.gz::https://github.com/containers/bubblewrap/archive/v$pkgver.tar.gz
- realpath-workaround.patch
- tests.patch
- "
+source="bubblewrap-$pkgver.tar.gz::https://github.com/containers/bubblewrap/archive/v$pkgver.tar.gz"
# secfixes:
# 0.3.3-r0:
@@ -76,6 +73,4 @@ bashcomp() {
mv "$pkgdir"/usr/share/bash-completion/ "$subpkgdir"/usr/share/
}
-sha512sums="83e036e242503e1364b2d0052bba5127175891203c57bd22ba47a1b1e934fdca64ca620cd0e48c903fa2bc7cdcf92339b8a7fcb8716b54c2e28034b6d6f86adc bubblewrap-0.4.1.tar.gz
-400a0446670ebf80f16739f1a7a2878aadc3099424f957ba09ec3df780506c23a11368f0578c9e352d7ca6473fa713df826fad7a20c50338aa5f9fa9ac6b84a4 realpath-workaround.patch
-d572a6296729ab192dd4f04707e0271df600d565897ce089b7f00b9ae6c62e71a087e864b4c4972e0a64aeb222a337ff4ed95560620c200cc44534db1ca79efd tests.patch"
+sha512sums="30743cadc4f536430e253e1e21af5e0e56ae5dc4a11258faa42321b04b7490b54f904e72fc0147b23b0a0524870f41b5805c1482d20a11e0c4549bf8ae1d651f bubblewrap-0.6.1.tar.gz"
diff --git a/system/bubblewrap/realpath-workaround.patch b/system/bubblewrap/realpath-workaround.patch
deleted file mode 100644
index 6f1e3b54b..000000000
--- a/system/bubblewrap/realpath-workaround.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-Musl realpath() implementation currently depends on /proc which is
-not available when setting up pivot root. For the time being just
-fallback to given path if realpath() fails. If there was symlinks
-that would have required normalizing the following parse_mountinfo()
-will fail.
-
-diff --git a/bind-mount.c b/bind-mount.c
-index 7d3543f..c33b701 100644
---- a/bind-mount.c
-+++ b/bind-mount.c
-@@ -397,7 +397,7 @@ bind_mount (int proc_fd,
- path, so to find it in the mount table we need to do that too. */
- resolved_dest = realpath (dest, NULL);
- if (resolved_dest == NULL)
-- return 2;
-+ resolved_dest = strdup (dest);
-
- mount_tab = parse_mountinfo (proc_fd, resolved_dest);
- if (mount_tab[0].mountpoint == NULL)
diff --git a/system/bubblewrap/tests.patch b/system/bubblewrap/tests.patch
deleted file mode 100644
index 651d6269a..000000000
--- a/system/bubblewrap/tests.patch
+++ /dev/null
@@ -1,23 +0,0 @@
---- bubblewrap-0.3.3/tests/test-run.sh 2019-05-01 04:51:47.000000000 -0400
-+++ bubblewrap-0.3.3/tests/test-run.sh 2019-06-03 14:43:33.881226220 -0400
-@@ -127,8 +127,9 @@
- fi
-
- # bind dest in symlink (https://github.com/projectatomic/bubblewrap/pull/119)
-- $RUN $ALT --dir /tmp/dir --symlink dir /tmp/link --bind /etc /tmp/link true
-- echo "ok - can bind a destination over a symlink"
-+ #$RUN $ALT --dir /tmp/dir --symlink dir /tmp/link --bind /etc /tmp/link true
-+ #echo "ok - can bind a destination over a symlink"
-+ echo "ok # SKIP musl realpath depends on /proc"
- done
-
- # Test devices
-@@ -215,7 +216,7 @@
- # Test --die-with-parent
-
- cat >lockf-n.py <<EOF
--#!/usr/bin/env python
-+#!/usr/bin/env python3
- import struct,fcntl,sys
- path = sys.argv[1]
- if sys.argv[2] == 'wait':