summaryrefslogtreecommitdiff
path: root/system/curl/APKBUILD
diff options
context:
space:
mode:
authorZach van Rijn <me@zv.io>2021-10-11 16:28:24 -0500
committerZach van Rijn <me@zv.io>2021-10-11 16:28:24 -0500
commit69e286c579a161eab377c452ca3c459a32e32ca3 (patch)
tree763735bb30000019edf983e32efffd8257e29169 /system/curl/APKBUILD
parent1feea8154e3e7aacee94e42ad351cecb00822816 (diff)
downloadpackages-69e286c579a161eab377c452ca3c459a32e32ca3.tar.gz
packages-69e286c579a161eab377c452ca3c459a32e32ca3.tar.bz2
packages-69e286c579a161eab377c452ca3c459a32e32ca3.tar.xz
packages-69e286c579a161eab377c452ca3c459a32e32ca3.zip
system/curl: bump to 7.79.1, take maintainership
Diffstat (limited to 'system/curl/APKBUILD')
-rw-r--r--system/curl/APKBUILD76
1 files changed, 7 insertions, 69 deletions
diff --git a/system/curl/APKBUILD b/system/curl/APKBUILD
index 712bcefab..41b7f58dd 100644
--- a/system/curl/APKBUILD
+++ b/system/curl/APKBUILD
@@ -1,9 +1,9 @@
# Contributor: Sergei Lukin <sergej.lukin@gmail.com>
# Contributor: Valery Kartel <valery.kartel@gmail.com>
# Contributor: Łukasz Jendrysik <scadu@yandex.com>
-# Maintainer:
+# Maintainer: Zach van Rijn <me@zv.io>
pkgname=curl
-pkgver=7.73.0
+pkgver=7.79.1
pkgrel=0
pkgdesc="A URL retrival utility and library"
url="https://curl.haxx.se"
@@ -16,69 +16,6 @@ makedepends="$makedepends_build $makedepends_host"
source="https://curl.haxx.se/download/$pkgname-$pkgver.tar.xz"
subpackages="$pkgname-dbg $pkgname-doc $pkgname-dev libcurl"
-# secfixes:
-# 7.66.0-r0:
-# - CVE-2019-5481
-# - CVE-2019-5482
-# 7.65.1-r0:
-# - CVE-2019-5435
-# - CVE-2019-5436
-# 7.64.0-r0:
-# - CVE-2019-3823
-# - CVE-2019-3822
-# - CVE-2018-16890
-# - CVE-2018-16842
-# - CVE-2018-16840
-# - CVE-2018-16839
-# 7.60.0-r0:
-# - CVE-2017-8816
-# - CVE-2017-8817
-# - CVE-2017-8818
-# - CVE-2018-1000005
-# - CVE-2018-1000007
-# - CVE-2018-1000120
-# - CVE-2018-1000121
-# - CVE-2018-1000122
-# - CVE-2018-1000300
-# - CVE-2018-1000301
-# 7.56.1-r0:
-# - CVE-2017-1000257
-# 7.55.0-r0:
-# - CVE-2017-1000099
-# - CVE-2017-1000100
-# - CVE-2017-1000101
-# 7.54.0-r0:
-# - CVE-2017-7468
-# 7.53.1-r2:
-# - CVE-2017-7407
-# 7.53.0:
-# - CVE-2017-2629
-# 7.52.1:
-# - CVE-2016-9594
-# 7.51.0:
-# - CVE-2016-8615
-# - CVE-2016-8616
-# - CVE-2016-8617
-# - CVE-2016-8618
-# - CVE-2016-8619
-# - CVE-2016-8620
-# - CVE-2016-8621
-# - CVE-2016-8622
-# - CVE-2016-8623
-# - CVE-2016-8624
-# - CVE-2016-8625
-# 7.50.3:
-# - CVE-2016-7167
-# 7.50.2:
-# - CVE-2016-7141
-# 7.50.1:
-# - CVE-2016-5419
-# - CVE-2016-5420
-# - CVE-2016-5421
-# 7.36.0:
-# - CVE-2014-0138
-# - CVE-2014-0139
-
build() {
./configure \
--build=$CBUILD \
@@ -90,14 +27,15 @@ build() {
--without-libidn \
--without-libidn2 \
--disable-ldap \
- --with-pic
+ --with-pic \
+ --with-openssl
make
}
check() {
# -p: print log contents on test failure
- # !1592: requires DNS access
- make check TFLAGS='-p !1592'
+ # ignore: 557: fails under valgrind only
+ make check TFLAGS='-p ~557'
}
package() {
@@ -110,4 +48,4 @@ libcurl() {
mv "$pkgdir"/usr/lib "$subpkgdir"/usr
}
-sha512sums="95330bac2d6bc5306d47723b3c7bdb754fabe2ba2df7b2a8027453a40286f1c7caaee69333f0715e59fbc7fdf09080968ea624398c995cabf3d57493973867bd curl-7.73.0.tar.xz"
+sha512sums="1edb71647a7f4dbb070baf1a019b4751aefeda793ff523c504410bb5cc74e5bffc52f20dd889697d1585f9ca3c4e81b1a9caadd182c30c8358ffd25f33e4db4d curl-7.79.1.tar.xz"