summaryrefslogtreecommitdiff
path: root/system/dash/APKBUILD
diff options
context:
space:
mode:
authorMax Rees <maxcrees@me.com>2018-05-26 21:15:38 -0400
committerMax Rees <maxcrees@me.com>2018-05-26 21:15:38 -0400
commit92563f5289c64332795cd296e2a9187a773f470c (patch)
treeff35e77691356aa930b9892b2b67bf538318367e /system/dash/APKBUILD
parent36e31b560eb3b4a6154deecfbf91f27494de21b7 (diff)
downloadpackages-92563f5289c64332795cd296e2a9187a773f470c.tar.gz
packages-92563f5289c64332795cd296e2a9187a773f470c.tar.bz2
packages-92563f5289c64332795cd296e2a9187a773f470c.tar.xz
packages-92563f5289c64332795cd296e2a9187a773f470c.zip
system/{bash-binsh,dash-binsh,build-tools}: add provider_priority
This makes bash-binsh the default and should fix compatibility in /usr/bin/abuild for populating a chroot with only abuild, alpine-base (adelie-base), build-base (build-tools), and git
Diffstat (limited to 'system/dash/APKBUILD')
-rw-r--r--system/dash/APKBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/system/dash/APKBUILD b/system/dash/APKBUILD
index f22c6c8eb..c1fbec305 100644
--- a/system/dash/APKBUILD
+++ b/system/dash/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=dash
pkgver=0.5.9.1
-pkgrel=1
+pkgrel=2
pkgdesc="Small and fast POSIX-compliant shell"
url="http://gondor.apana.org.au/~herbert/dash/"
arch="all"
@@ -37,6 +37,7 @@ package() {
binsh() {
pkgdesc="Use dash as /bin/sh"
provides="/bin/sh"
+ provider_priority=1
mkdir -p "$subpkgdir"/bin
ln -s dash "$subpkgdir"/bin/sh
}